publish active sync with adfs

eg1995 886 Reputation points
2020-09-02T13:08:33.697+00:00

dears,

i configured since a while active sync and published it using adfs and wap. it was working great.
relying party trust created type : non claims aware
publishing on wap using adfs: rich clients

starting the last night, it stopped working with an error: the username or password are wrong.
however, nothing has changed.
these event ids are in the event viewer of adfs
22262-adfs2.jpg

your help is so appreciated

Active Directory Federation Services
Active Directory Federation Services
An Active Directory technology that provides single-sign-on functionality by securely sharing digital identity and entitlement rights across security and enterprise boundaries.
955 questions
No comments
{count} votes

4 answers

Sort by: Most helpful
  1. Manu Philip 14,056 Reputation points Microsoft MVP
    2020-09-02T13:46:40.67+00:00

    Error 521 indicates the any one of the following user actions needed

    User action:
    Examine the request and verify that at least one of the following parameter sets are present.
    Username and password
    Username, password, and device registration certificate
    User certificate

    Probably, check the certificate at first and see the certificate is still valid

    No comments

  2. eg1995 886 Reputation points
    2020-09-02T13:56:07.973+00:00

    adfs proxy trust on adfs personal store shows 2 certifcates: both of the are expired.
    but owa is still working.
    just activesyn is not.

    however, how can i renew the certificate? the adfs proxy certificate is different that the one used for adfs wap and exchange which is a wildcard one.


  3. eg1995 886 Reputation points
    2020-09-03T06:29:31.24+00:00

    "the proxy trust certificate is a rolling certificate valid for 2 weeks and periodically updated. This is stored in an internal, protected store so you won’t see it in any of the usual certificate stores. "

    if the above is real, then why i am seeing proxy certificates are expired in the personal store.
    in addition, owa is working fine usinf adfs and wap. the issue is just with activesync. and wap config is green

    the client informed me, that the activesync stopped working while the pdc was rebooting. however, the pdc is running now but the issue is still persisting

    any ideas
    tahnk you


  4. eg1995 886 Reputation points
    2020-09-17T07:10:42.44+00:00

    this worked after rebooting the exchange server
    thank you

    No comments