question

66304432 avatar image
0 Votes"
66304432 asked YukiSun-MSFT commented

Teams lagging

Hello Teams Community


Please i need your help on this


On an M1 mac, we are experiencing severe lag in the latest build of teams. This user has also tried the M1 beta with no luck. Tried reinstalling it multiple times.


We are having them use the web version. Wasn't sure if there were any solutions.

office-teams-windows-itprooffice-for-mac-itpro
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

YukiSun-MSFT avatar image
0 Votes"
YukiSun-MSFT answered YukiSun-MSFT commented

Hi @66304432,

Does this affect all M1 Mac users in your environment or only a particular user is having this issue?

I can understand that you've already tried reinstalling the Teams application multiple times, but considering that the local cache won't be cleared with the uninstall of Teams, it's suggested to try signing out and quit Teams, clearing Teams cache in macOS and then sign in back to check if there would be any improvement:

  1. In the Finder, open the /Applications/Utilities folder, and then double-click Terminal.

  2. Enter the following command, and then press Return:

    rm -r ~/Library/Application\ Support/Microsoft/Teams


If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Thank you for your reply.


It very well do have a theory it is because it is an M1 Mac, however even the Beta performance of the M1 version was rather poor. So I felt this is something you should be made aware of and if we could see if there was anything that could at least give him better performance in the meantime until the official M1 version releases.

Switching to a different network made no difference.

Teams web app works fine, but that would be expected since it is browser based and not hardware based.

We may just have to go this route till the official M1 version is out of beta.

Clearing the teams cache did not help.

0 Votes 0 ·

Hi @66304432,

Please try disabling GPU on one of the affected Mac and see if it can make any difference:
204570-1.jpg

Then regarding your concern about the M1 version, personally I'd recommend trying to contact the support for M1 Mac as well, see if there are other M1 Mac users who have also experienced this and whether there are any potential solutions or workaround from their end.


0 Votes 0 ·
1.jpg (66.3 KiB)

Hi @66304432,

Just checking in to see how things are going on with this issue. Should there's any update or you need further assistance on this, feel free to post back.

0 Votes 0 ·