question

BrianB24 avatar image
0 Votes"
BrianB24 asked BrianB24 answered

Enable button greyed out on Manage Machines for Update Management

The Enable button is greyed out for every machine that I am trying to Enable update management for. I am PIM'd as a Global Administrator, yet I am unable to to add any machines to Update Management.
204144-2022-05-20-10-00-07-window.png


azure-automation
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

SwathiDhanwada-MSFT avatar image
0 Votes"
SwathiDhanwada-MSFT answered BrianB24 commented

@BrianB24 Welcome to Microsoft Q & A Community Forum. I understand that you want to add further machines to update management for patch management but the enable button has been greyed out. These are couple scenarios where enable button is disabled.

  • To enable Update Management for all available machines reporting to the workspace, select Enable on all available machines on the Manage Machines page. This action disables the control to add machines individually and adds all of the machines reporting to the workspace to the computer group saved search query MicrosoftDefaultComputerGroup. When selected, this action disables the Manage Machines option.

  • To enable the feature for all available machines and future machines, select Enable on all available and future machines. This option deletes the saved search and scope configuration from the workspace and permits the feature to include all Azure and non-Azure machines that currently or in the future, report to the workspace. When selected, this action disables the Manage Machines option permanently, as there's no scope configuration available.

I assume, you have selected one of the above options, due to which the option to enable the virtual machines has been disabled. If necessary, you can add the scope configuration back by re-adding the initial saved search query. For more information, see Limit Update Management deployment scope. Also, you can try adding the virtual machines by following the steps mentioned in this document.


5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

BrianB24 avatar image
0 Votes"
BrianB24 answered

Found that it was a permissions issue. This has been resolved Thank you for your input.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.