question

JeremiahMercier-3136 avatar image
1 Vote"
JeremiahMercier-3136 asked MarileeTurscak-MSFT commented

Access share on non-domain Windows 10 PC using domain user

I've spent several hours reading questions & answers for a variety of related problems, but I couldn't find one that matched my configuration, which doesn't seem that complicated:

I'm a remote worker and I have two Windows 10 laptops. Both laptops are connected wirelessly to the same router at home. I log into my personal laptop with a Microsoft account. I log into my work laptop with my company email address. I can also log in to the same account using DOMAIN\USERNAME. Windows Settings shows my work laptop is connected to my company's Azure AD, but it is not joined to the domain. (It is a member of WORKGROUP.) Local Users and Groups does not show my user account, but it is listed as a member of the local Administrators group as DOMAIN\USERNAME. I am able to VPN to my company network as needed, but most of the time I do not use the VPN.

How do I access network shares on my work laptop from my personal laptop? When I try to connect using \\COMPUTERNAME I am prompted for credentials. No matter what I use, I get the error "The user name or password is incorrect." I've tried all of the following:

username@domain.com

DOMAIN\USERNAME

domain.com\username

MicrosoftAccount\username@domain.com

PCNAME\USERNAME

I've verified that I can log on locally to my work laptop with username@domain.com or DOMAIN\USERNAME, so I know I have the correct credentials and password.

I'm wondering if the problem has something to do with trying to log on with a domain account when I can't reach a company domain controller. Of course, both laptops could reach Azure AD. Do they use Azure AD when connecting to a network share?

azure-ad-authentication
· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Does your user account actually exist in the on-prem AD? If it only exists in Azure AD then the file share will know nothing about it.

0 Votes 0 ·

Thanks for your response and sorry mine is delayed. I didn't receive any notification of the activity.

To address your question, I've never been on-premise nor do I use anything on-premise nor is the file share on-premise. Neither laptop is on the domain. All I'm using Azure for is to log in to my work laptop. Both laptops are sitting in front of me right now, at my home office a thousand miles away from the organization I work for. I'm simply trying to access the files on my work laptop from my personal laptop which is sitting a couple inches away. What credentials is my work laptop looking for when I try to access the file share? As you can see in my original question, I've tried using the same credentials I use when I log in to my work laptop and every variation of the username I can think of, but no matter what I try, it tells me the username or password is incorrect.

0 Votes 0 ·

1 Answer

MarileeTurscak-MSFT avatar image
0 Votes"
MarileeTurscak-MSFT answered MarileeTurscak-MSFT commented

Make sure that there is no duplicate account with a separate Object ID (as this can happen if there is more than one account created with the same UPN but different object IDs). Make sure also that the account exists both on premises and in Azure like Sam said.

It's possible also that the account got locked out, in which case you can set a lockout policy to prevent this from happening.

· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

When I search for my name in Azure Active Directory, I only see one of me. I copied the Object ID and searched for it and only found one of me.

I don't use anything on premises, I'm not on the premises, and I'm not trying to connect to any resources on the premises. This is entirely remote.

I am able to log in locally to my work laptop just fine, and the file share is on my work laptop, so the account is clearly not locked out. How do I connect to the file share from another laptop?

0 Votes 0 ·

This is less of an Azure AD question but there are some resources on this here: https://support.microsoft.com/en-us/help/4092694/windows-10-file-sharing-over-a-network

If you still are facing this issue can you please send me an email at AzCommunity@microsoft.com so that I can troubleshoot with you together?

0 Votes 0 ·