DB2OLEDB 6.0 on SQL Server 2016

asked 2022-06-16T15:30:58.233+00:00
Michael Henderson 111 Reputation points

I have heard that DB2OLEDB 5.0 requires SQL Server Enterprise or Developer Edition.

Does DB2OLEDB 6.0 require SQL Server Enterprise Edition.

This is SQL Server 2016

Thanks.

SQL Server
SQL Server
A family of Microsoft relational database management and analysis systems for e-commerce, line-of-business, and data warehousing solutions.
8,480 questions
{count} votes

3 additional answers

Sort by: Most helpful
  1. answered 2022-06-17T03:14:19+00:00
    Seeya Xi-MSFT 12,511 Reputation points Microsoft Employee

    Hi @Michael Henderson ,

    As ss said, Any edition will work. You should put the focus on the version.
    On an installed instance of SQL Server, we recommend that you apply the latest security updates and critical updates including general distribution releases (GDRs), service packs (SPs), and cumulative updates (CUs).
    Here is a link about downloading Microsoft® SQL Server® 2016 Service Pack 3 Feature Pack:
    See this part of Install Instructions:
    212302-image.png
    Also see this link about Microsoft OLE DB Provider for DB2 version 6.0:
    212312-image.png

    Best regards,
    Seeya


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    No comments

  2. answered 2022-06-17T05:36:40.04+00:00
    Olaf Helper 25,556 Reputation points

    I have heard that DB2OLEDB 5.0 requires SQL Server Enterprise or Developer Edition.

    No, that's only a simple data provider and is even not aware, to which SQL Server edition it's connect to; it waorks also with free Express Edition.

    No comments

  3. answered 2022-06-20T11:12:20.04+00:00
    Michael Henderson 111 Reputation points

    Thank everyone that responded.

    No comments