Trouble downloading updates from newly setup WSUS server

asked 2022-06-17T03:56:36.853+00:00
Devandran 31 Reputation points

Dear Experts.

I have setup WSUS server in our small environment where we does not have AD/DC servers. I have followed all instructions as per in microsoft to setting up the WSUS server. However my client server not able to download the patches from the WSUS and getting error as below. below is the steps which i already perform. Attached the configurations and error screenshots


1) Opened port 8530 from Client to WSUS Server - Tested, able to telnet.
2) WSUS Server endpoint have been updated in the Localpolicy.
3) Client server able to detected in WSUS console.
4) WSUS server already sync & updates have been approved.

Do i missing anything from the above steps?

Windows Server 2019
Windows Server 2019
A Microsoft server operating system that supports enterprise-level management, data storage, applications, and communications.
2,179 questions
Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
8,148 questions
No comments
{count} votes

Accepted answer
  1. answered 2022-06-20T07:33:57.94+00:00
    Limitless Technology 37,291 Reputation points


    Thank you for your question and reaching out. I can understand you are having issues related to Windows update error 0x80244o1c

    0x8024401C means the client response timeout: WU_E_PT_HTTP_STATUS_REQUEST_TIMEOUT — HTTP status 408 — the server timed out waiting for the request

    1. Check if .NET Framework 4.5 -> HTTP Activation is installed
    2. Change below settings in IIS pool

    Private Memory Limit (KB) – 0 (the previous value was 1258015. A value of 0 means that the limit on memory usage by WSUS workflow is removed, so the service may use more than 1.2 GB of memory)
    Queue Length – 25000 (increase the length of the queue to the pool from 10000)
    Limit Interval (minutes) — 15 (increase the time to reset the counters and run CPU Throttling from 5 to 15 minutes)
    Service Unavailable Response — TcpLevel

    1. Then change the value of Connection Time-out from 180 to 320 in WSUS Administration -> Advanced settings.
    2. Reboot IIS.


    --If the reply is helpful, please Upvote and Accept as answer--

2 additional answers

Sort by: Most helpful
  1. answered 2022-06-18T14:11:28.71+00:00
    Adam J. Marshall 5,661 Reputation points Microsoft MVP

    Synced and approved, but downloaded to the WSUS server yet? Check with the File Status Column. If you don't have it, follow my guide to enable it

    Also, start by running the client side script here:
    And if that doesn't work, go through the rest of the troubleshooting.

    I'd recommend reading through my guides (ignore the part that explains how to link it in GPOs, because you don't have AD - you're doing that manually with registry edits/local GPO)

    No comments

  2. answered 2022-06-19T23:45:15.713+00:00
    Rita Hu -MSFT 9,391 Reputation points

    I agree with AJTek-Adam-J-Marshall. It seems that the devices didn't report to the WSUS server right now.

    Please help to double confirm whether the devices report to the WSUS server right now.

    Also please refer to the below link and follow the Disable recycling and configure memory limits part to maintain.

    Best regards,

    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.