Windows not displaying previous versions but they are enabled and working - shadow explorer sees them. How do I fix this?

Anthony Tropiano 6 Reputation points
2022-07-02T01:03:41.563+00:00

Hello,

The title says it all,

I have my Windows Server 2022, brand new, Shadow copies are configured. They are working, I know this because I can restore a file properly from Shadow Explorer but no matter what I do I cannot seem to find how to make the file Shadow Copies tab show me the files.

I have tried the regular fixes, restrart the Volume shadow copy service / TCP/IP NetBIOS helper, tried vssadmin list shadows and tried to use mklink E:\shadows /d \?\GLOBALROOT\Device\HarddiskVolumeShadowCopyXXX (this doesn't work I cannot do anything with this) / tried rebooting

All I want is to have my Shadow copies back like every other Windows Server that has even been created since the beginning of time.

How does something like this happen, it's very frustrating that a most basic functions of Windows break right out of the box.

The server is freshly installed, it's updated, there is nothing to be updated on it.

I would really like some help on this it's very frustrating.

Thanks

Windows Server 2019
Windows Server 2019
A Microsoft server operating system that supports enterprise-level management updated to data storage.
3,342 questions
0 comments No comments
{count} vote

2 answers

Sort by: Most helpful
  1. Anthony Tropiano 6 Reputation points
    2022-07-02T20:30:02.957+00:00

    Hello has anyone ever seen this issue or has ever fixed it?
    I'm confused as to what the issue is I cannot figure out what made it happen that this server simply refuses to show the previous versions natively.
    Thanks

    0 comments No comments

  2. Franck Jack 1 Reputation point
    2023-01-13T12:29:26.1533333+00:00

    Hello,

    Did you find something about this ?

    We just get the exact same problem with our server.

    Franck

    0 comments No comments