Unable to Publish Pipeline Artifact to network file share in Azure Devops

Sunny Sharma 1 Reputation point
2022-07-13T13:03:52.35+00:00

We are using Azure Devops build and Release pipeline for an Winform app built on DotNet core and would be hosted on network file share (DFS)

My build pipeline is working fine and it's creating the necessary Published artifacts to be deployed to network file share

The problem is in release pipeline where i am trying to use the Publish Pipeline Artifact in order to connect to network file share path.

We are using the windows on premise agent which has the connectivity to connect to network file share from ADO. The problem is when i try to use the network file share path in Publish Pipeline Artifact task by giving the network share path, it fails with error "The user name or password is incorrect." I assume we would need the network file share credentials in the form of service account in order to connect to network file share from Azure but i don't see any option available in Publish Pipeline Artifact to pass the credentials with network file share. Does anyone know about this?

Not Monitored
Not Monitored
Tag not monitored by Microsoft.
34,919 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Monalla-MSFT 9,681 Reputation points
    2022-07-13T19:19:57.273+00:00

    @Sunny Sharma - Welcome to Microsoft Q&A and thanks for reaching out.
    Devops is not currently supported here on Microsoft QnA.
    The Community Members and Engineers are actively answering questions in dedicated forums here. Please post your question in that forum:
    https://developercommunity.visualstudio.com/spaces/21/index.html
    https://azure.microsoft.com/en-in/support/devops/

    Hope this helps. and please feel free to reach out if you have any further questions.

    ------------------------------------------------------------------

    If the above response was helpful, please feel free to "Accept as Answer" and "Upvote" the same so it can be beneficial to the community.

    0 comments No comments