App Service Domain is in a broken state

Barton Swarts 1 Reputation point
2020-09-14T16:39:25.767+00:00

I used the Domain Management API to transfer a domain from GoDaddy to Azure. I received the confirmation of the transfer from GoDaddy and my App Service Domain was successfully created in Azure with an Active status.

However, when I try to add the custom domain to may app service, I receive the following error message:

App Service Domain 'mydomain.com' is in a broken state. Please navigate to the App Service Domain resource and delegate to Azure DNS before adding hostname.

When I select “Manage DNS records” from the App Service Domain and select the “Delegate to Azure DNS zone” within my App Service Domain, I get notifications that it is successful. However, I receive the same error message when re-attempting to add the custom domain to the app service. I tried to delete the DNS Zone and re-create it but receive the same message. I have used the Advanced Management Portal feature to manually assign the Azure Nameservers and still have the same problem. I even deleted my App Service domain and re-purchased it on the Azure portal. The same problem exists.

An NSLookup and WhoIs search show that my domain is utilizing the 4 Azure Nameservers displayed in my DNS Zone. However, the App Service Domain Resource shows two GoDaddy NameServers instead of my 4 Azure Nameservers. It seems like the internal App Service Domain record for my domain is not being updated by the Azure Portal when I delegate "Delegate to Azure DNS zone" (even if the nameservers are manually entered in the DNS section of the Advanced Management portal)

Here is the json for my App Service Domain as displayed from the Resource Manager...

{
"id": "/subscriptions/******************************/resourceGroups/*************/providers/Microsoft.DomainRegistration/domains/mydomain.com",
"name": "mydomain.com",
"type": "Microsoft.DomainRegistration/domains",
"location": "global",
"properties": {
"registrationStatus": "Active",
"provisioningState": "Succeeded",
"nameServers": [
"ns47.domaincontrol.com",
"ns48.domaincontrol.com"
],
"privacy": true,
"createdTime": "2015-09-09T19:26:28",
"expirationTime": "2021-09-09T19:26:28",
"autoRenew": true,
"readyForDnsRecordManagement": true,
"managedHostNames": [],
"domainNotRenewableReasons": [
"ExpirationNotInRenewalTimeRange"
],
"dnsZoneId": "/subscriptions/***************************/resourcegroups/************/providers/Microsoft.Network/dnszones/mydomain.com"
}
}

However, the actual Name Servers for my DNS Zone are...

Name server 1: ns1-07.azure-dns.com.
Name server 2: ns2-07.azure-dns.net.
Name server 3: ns3-07.azure-dns.org.
Name server 4: ns4-07.azure-dns.info.

Interestingly, the above resource does not show the "dnsType": "AzureDns" setting that is displayed in the App Service Domain resource records that are working correctly.

Does anyone have a solution to this problem? Any suggestions on what else I can try to rectify this problem?

Azure App Services
Azure App Services
A feature of Azure App Service used to create and deploy scalable, mission-critical web apps.
4,324 questions
{count} votes