Logon After Reconnect RDP Without Password

Alexey 1 Reputation point
2022-08-23T09:05:22.56+00:00

Good day. Could anybody help please. I am connecting to my server via Linux Remmina, inside Remmina setting has no any login and password for auto connect. After I typr login and password, I connecting to RDP Active Dirrectory in to my session, then, if I block my PC in session all is ok, RDP PC is blocked, but if connection failt 1-2-10 sec and then connect again, my PC is logon without asking me about password, please look this video, how I can solved this, Windows 2019 Server on Active Dirrectory and all last updates is installed. Thanks for all!

Youtube video URL: https://youtu.be/sXz-TnogSr0

Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,028 questions
Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,216 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. Alexey 1 Reputation point
    2022-08-23T09:21:18.06+00:00

    In general, even not in domain PC I have worked with RDP any client not only Remmina, those somewhere there is an option in gpedit.msc domain or locale, if the logon was, restore it when reconnect after a break! Hmmm.

    0 comments No comments

  2. Limitless Technology 39,331 Reputation points
    2022-08-23T14:45:57.237+00:00

    Hello there,

    Are you using any VPN? Are you using certificate-based authentication?

    You need to configure the remote computer locally first. Not via the VPN/RDP you are trying to configure.

    Check that you have configured the accounts: "Limit local account use of blank passwords to console logon only policy", and set its value to Disabled. (this will let you use the RDP without a password. In the GPEdit.msc.

    ------------------------------------------------------------------------------------------------------------------------------------------------

    --If the reply is helpful, please Upvote and Accept it as an answer–


  3. Alexey 1 Reputation point
    2022-08-24T07:29:20.183+00:00

    There is still a solution, except GPO Always require a password in the section for Users, turn on Do not store passwords, as a result, when you break the connection does not log in by itself, requiring a login and password.

    0 comments No comments