Browsers Stop Working

Gods Admin 46 Reputation points

We have a handful of domain workstations from varying locations whose browsers stop resolving web pages. You can ping by URL from a command prompt successfully and all other network services seem to be working except their browsers, and I mean all of them, Firefox, Chrome, Edge... The fix is to restart the machine, after which, viola, pages are displaying again, until it happens again, which it does. Understand, this isn't an entire location, these are single workstations from disparate sites and only a small percentage of sites are affected. Here's what we've tried so far:

Disabling IPv6

Resetting Winsock and IP stack (netsh commands)

IPconfig/Flushdns /release and /renew

using public DNS servers - although clearly, it's not a DNS issue

Disabling LAN/WLAN auto-switching in the BIOS (however, the issue is not restricted to laptops)

Use the IPv4 address in the browser

Clear the browser cache and DNS

Disabling our AV's "web control" feature

Disabling the entire AV!

Checking proxy settings (which we do not use)

Updated device drivers (Which seems dumb because clearly, the driver is working)

We've looked for patterns in OS (occurs in both Win10 and Win11), machine models, Windows builds, adapter driver versions, switches, and firewall models - none of which bear fruit. But again, a reboot of the affected computer temporarily fixes the issue. You get a billion hits if you search Google for browser won't work but can ping by name, or any variation thereof. The vast majority of which recommend command prompt netsh commands which do nothing. Or do this and do that then restart your machine... but restart always works temporarily! Checking the Event Viewer reveals nothing.

We haven't tried:

Rolling back updates (only because you'd think it would be more wide-spread if it were an MS Update)

Booting to Command Prompt with Networking - restarting will correct this issue, then wait until the issue appears? (or doesn't) - this can take hours

Uninstalling\reinstalling browser(s)

Clean boot - again, restarting will correct this issue, then wait until the issue appears? (or doesn't) - this can take hours.

What could possibly cause this?

Microsoft Edge
Microsoft Edge
A Microsoft cross-platform web browser that provides privacy, learning, and accessibility tools.
1,816 questions
Windows 10 Network
Windows 10 Network
Windows 10: A Microsoft operating system that runs on personal computers and tablets.Network: A group of devices that communicate either wirelessly or via a physical connection.
2,149 questions
Windows 11
Windows 11
A Microsoft operating system designed for productivity, creativity, and ease of use.
6,057 questions
{count} votes

Accepted answer
  1. Gary Nebbett 5,166 Reputation points

    Hello Christopher,

    You could use the same "trace" command that I suggested to James in this thread: The "VPN" aspect of that problem was important, but it was analysis of browser requests that cracked the problem (I think that the problem has been resolved - just waiting for confirmation that removal/disabling of some network traffic management software was effective).


1 additional answer

Sort by: Most helpful
  1. Gods Admin 46 Reputation points

    Apologies for the late post. In short, Gary Nebbett resolved the issue after analyzing my packet capture files. He identified my enterprise AV as the culprit. Apparent updates to the software have all but eliminated the issue. I will mark Gary as having provided the correct answer. Thanks again, Gary.

    0 comments No comments