<?xml version="1.0" encoding="utf-8"?>
<rss xmlns:atom="https://www.w3.org/2005/Atom" xmlns:sy="https://purl.org/rss/1.0/modules/syndication/" xmlns:dc="https://purl.org/dc/elements/1.1/" xmlns:content="https://purl.org/rss/1.0/modules/content/" xmlns:wfw="https://wellformedweb.org/CommentAPI/" xmlns:slash="https://purl.org/rss/1.0/modules/slash/"
  version="2.0">
  <channel>
    <title>Chris Garty's Weblog</title>
    <atom:link
      href="https://docs.microsoft.com/archive/blogs/chrisgarty/feed.xml"
      rel="self"
      type="application/rss+xml" />
    <link>https://docs.microsoft.com/archive/blogs/chrisgarty/feed.xml</link>
    <description>Inside Microsoft Dynamics AX</description>
    <lastBuildDate>Tue, 16 Apr 2019 04:53:41 GMT</lastBuildDate>
    <language>en-US</language>
    <sy:updatePeriod>hourly</sy:updatePeriod>
    <sy:updateFrequency>1</sy:updateFrequency>
    <item>
      <title>Dynamics AX 2012 R2: Budget plan entry via Excel</title>
      <link>https://docs.microsoft.com/archive/blogs/chrisgarty/dynamics-ax-2012-r2-budget-plan-entry-via-excel</link>
      <pubDate>Wed, 06 Nov 2013 03:28:10 GMT</pubDate>
      <dc:creator><![CDATA[Chris Garty]]></dc:creator>
      <guid
        isPermaLink="false">https://blogs.msdn.microsoft.com/chrisgarty/2013/11/06/dynamics-ax-2012-r2-budget-plan-entry-via-excel/</guid>
      <description><![CDATA[The Excel Add-in enables users to interact with services to pull data from AX into Excel, enter and...]]></description>
      <content:encoded><![CDATA[<p>The Excel Add-in enables users to interact with services to pull data from AX into Excel, enter and edit data in Excel, and then publish that data back into AX.</p>
<p>One of the best usages of the Excel Add-in in Dynamics AX 2012 R2 is budget plan entry. To enable Excel entry of budget plans, a budget planning process designer creates a template worksheet&nbsp;that exposes the desired data with the appropriate budget structure.</p>
<p>A white paper is available that describes that design and configuration process:</p>
<p><a href="https://www.microsoft.com/en-us/download/confirmation.aspx?id=35819">Microsoft Dynamics AX 2012 R2 White Paper: Configuring Budget Plan Templates</a></p>]]></content:encoded>
    </item>
    <item>
      <title>Dynamics AX 2012 R2: Key Office 365 scenarios</title>
      <link>https://docs.microsoft.com/archive/blogs/chrisgarty/dynamics-ax-2012-r2-key-office-365-scenarios</link>
      <pubDate>Wed, 17 Jul 2013 15:19:00 GMT</pubDate>
      <dc:creator><![CDATA[Chris Garty]]></dc:creator>
      <guid
        isPermaLink="false">https://blogs.msdn.microsoft.com/chrisgarty/2013/07/17/dynamics-ax-2012-r2-key-office-365-scenarios/</guid>
      <description><![CDATA[Dynamics AX 2012 R2 has a number of new and improved Office Interop capabilities. They enable a...]]></description>
      <content:encoded><![CDATA[<p>Dynamics AX 2012 R2 has a number of <a href="https://blogs.msdn.com/b/chrisgarty/archive/2013/07/17/office-interop-in-dynamics-ax-2012-r2.aspx">new and improved Office Interop capabilities</a>. They enable a number of key scenarios for Office 365 that I wanted to list here.</p>
<p>If you have other scenarios that you'd like to highlight or other scenarios that we don't currently support, please mention them in the comments below. Thanks!</p>
<p><strong>Dynamics AX 2012 R2 + Office 365: Key scenarios</strong></p>
<ul>
<li>Send exports to SharePoint Online</li>
<ul>
<li>Send static and refreshable workbooks to SharePoint Online for storage and collaboration.</li>
</ul>
<li>Store document attachments in SharePoint Online</li>
<ul>
<li>SharePoint Online can be used as a document storage location for record attachments.</li>
</ul>
<li>Place templates in SharePoint Online</li>
<ul>
<li>Store templates in SharePoint Online for use with "Generate from template".</li>
</ul>
<li>Collaborate through Lync Online</li>
<ul>
<li>Your local Lync client can use Lync Online as the server.</li>
</ul>
<li>View documents in the Excel and Word web applications</li>
<ul>
<li>Documents stored in SharePoint Online will open in the web applications by default.</li>
<li>The Add-ins won&rsquo;t run, but you can view documents and workbooks.</li>
</ul>
</ul>]]></content:encoded>
    </item>
    <item>
      <title>Dynamics AX 2012 R2: Improved Office Interop capabilities</title>
      <link>https://docs.microsoft.com/archive/blogs/chrisgarty/dynamics-ax-2012-r2-improved-office-interop-capabilities</link>
      <pubDate>Wed, 17 Jul 2013 15:02:00 GMT</pubDate>
      <dc:creator><![CDATA[Chris Garty]]></dc:creator>
      <guid
        isPermaLink="false">https://blogs.msdn.microsoft.com/chrisgarty/2013/07/17/dynamics-ax-2012-r2-improved-office-interop-capabilities/</guid>
      <description><![CDATA[Dynamics AX 2012 R2 has been out for a while now, but I realized that I hadn't posted updated...]]></description>
      <content:encoded><![CDATA[<p>Dynamics AX 2012 R2 has been out for a while now, but I realized that I hadn't posted updated information about its Office Interop capabilities here.</p>
<p>In Dynamics AX 2012 R2 we responded to feedback from our customers and partners to provide new and updated support in a number of areas.</p>
<p><strong>Highlights for R2</strong></p>
<ul>
<li>Document management</li>
<ul>
<li>New: SharePoint and SharePoint Online support.</li>
</ul>
<li>Excel add-in</li>
<ul>
<li>New: Office 365 support via export, filtering APIs, dimension descriptions, refresh on open.</li>
<li>Improved: Table support (40% to 95%), services support, user experience.</li>
</ul>
<li>Word add-in</li>
<ul>
<li>New: Generate from template to Office 365, template storage in SharePoint Online.</li>
</ul>
<li>Lync</li>
<ul>
<li>New: Lync 2013 and Lync Online support.</li>
</ul>
</ul>
<p><strong>Highlights for R2: Excel</strong></p>
<ul>
<li>Fresh data automatically</li>
<ul>
<li>Added a user option and an OpenXML API to allow refresh of a workbook on open to retrieve fresh data.</li>
</ul>
<li>Send to Office 365</li>
<ul>
<li>Added support for sending exports to SharePoint and SharePoint Online to enable use of Office 365 Excel.</li>
</ul>
<li>Localize it</li>
<ul>
<li>Added support for localized templates via column and field label support.</li>
</ul>
<li>Easier to use</li>
<ul>
<li>Improved the Add-in user experience.</li>
</ul>
</ul>
<p><strong>Highlights for R2: Excel editing</strong></p>
<ul>
<li>Filter workbooks from code</li>
<ul>
<li>Added an OpenXML API for programmatic filter changes so workbooks can be customized to a user.</li>
</ul>
<li>Lock it down when needed</li>
<ul>
<li>Added an OpenXML API to optionally lock down the design of a workbook.</li>
</ul>
<li>Dimensions explained</li>
<ul>
<li>Added the dimension descriptions as a field binding option and as a helper in lookups.</li>
</ul>
<li>Matrix fields as editable aggregates</li>
<ul>
<li>Improved the support for data entry in a matrix table via new "Add Row" dialog.</li>
</ul>
</ul>
<p><strong>Highlights for R2: Word</strong></p>
<ul>
<li>Store templates anywhere</li>
<ul>
<li>Added SharePoint Online support for template storage.</li>
</ul>
<li>Generate to SharePoint</li>
<ul>
<li>Added support for SharePoint as a document storage location.</li>
</ul>
<li>Dimensions descriptions</li>
<ul>
<li>Added the option of including dimension descriptions in documents.</li>
</ul>
</ul>
<p><strong>Highlights for R2: Excel import</strong></p>
<ul>
<li>Tables galore</li>
<ul>
<li>Improved our support for surrogate foreign keys (SFK) to improve the percentage of tables supported for import/export from 40% to 95%.</li>
</ul>
<li>Use services when needed</li>
<ul>
<li>Added support for key services such as LedgerGeneralJournalService and VendVendTableService.</li>
</ul>
</ul>
<p><strong>Highlights for R2: Lync</strong></p>
<ul>
<li>Lync 2013</li>
<ul>
<li>Added support for Lync 2013.</li>
</ul>
<li>To the cloud!</li>
<ul>
<li>Added support for the latest version of Lync Online.</li>
</ul>
</ul>]]></content:encoded>
    </item>
    <item>
      <title>Dynamics AX: Copy+Paste vs Export to Excel</title>
      <link>https://docs.microsoft.com/archive/blogs/chrisgarty/dynamics-ax-copypaste-vs-export-to-excel</link>
      <pubDate>Wed, 27 Mar 2013 08:21:00 GMT</pubDate>
      <dc:creator><![CDATA[Chris Garty]]></dc:creator>
      <guid
        isPermaLink="false">https://blogs.msdn.microsoft.com/chrisgarty/2013/03/27/dynamics-ax-copypaste-vs-export-to-excel/</guid>
      <description><![CDATA[I had a question from a customer recently: "On a Details Form, copy+paste gives me more fields than...]]></description>
      <content:encoded><![CDATA[<p>I had a question from a customer recently: "On a Details Form, copy+paste gives me more fields than Export to Excel, so why would I use Export to Excel?". Below was my answer...</p>
<p>Copy+paste will give you values for all the visible form fields from the current datasource.<br />Export to Excel will initially give you values for all the visible fields from the current grid. And with refreshable Export to Excel you can add any field (not just the visible ones) from the exported datasource that you are interested in.<br />So, refreshable export can give you every field you want&hellip; and once you have that workbook set up, to give you all the fields you care about, then you can reuse it very easily and also build up adhoc reports on the refreshable data set.</p>]]></content:encoded>
    </item>
    <item>
      <title>Dynamics AX 2012 R2: Office, SharePoint, and Lync versions supported</title>
      <link>https://docs.microsoft.com/archive/blogs/chrisgarty/dynamics-ax-2012-r2-office-sharepoint-and-lync-versions-supported</link>
      <pubDate>Tue, 26 Mar 2013 16:08:00 GMT</pubDate>
      <dc:creator><![CDATA[Chris Garty]]></dc:creator>
      <guid
        isPermaLink="false">https://blogs.msdn.microsoft.com/chrisgarty/2013/03/26/dynamics-ax-2012-r2-office-sharepoint-and-lync-versions-supported/</guid>
      <description><![CDATA[I just completed my Office Interop presentation at Convergence in New Orleans and I had a number of...]]></description>
      <content:encoded><![CDATA[<p>I just completed my Office Interop presentation at <a href="https://www.microsoft.com/dynamics/convergence/">Convergence in New Orleans</a> and I had a number of people asking about version support for Office and SharePoint since I demonstrated in Microsoft Office 2013. I didn't make a specific mention of Microsoft Office 2010 but, yes, Office 2010 is supported as well as Office 2013.</p>
<p><strong>High Level</strong><br />At a high level, Dynamics AX 2012 R2 supports Office 2010 and 2013, SharePoint 2010 and 2013 (*not for EP yet), and Lync 2010 and 2013.</p>
<p><strong>Office Add-ins</strong><br />The Dynamics AX 2012 R2 Office Add-ins for Excel and Word can run and are supported in Office 2010 and 2013. Office 2007 SP3 also works at this time but is not officially supported and may encounter issues in the future.<br />The documents generated and workbooks exported from Dynamics AX 2012 R2 can also be viewed in the Office 365 web versions of Excel and Word, however the Add-ins only run in the local versions of Excel and Word.</p>
<p><strong>SharePoint</strong><br />Exports, generated documents, attachments, and templates can be exported to, sent to, placed in, and hosted on document libraries and folders within SharePoint 2010, SharePoint 2013, and SharePoint Onlne.</p>
<p><strong>Lync</strong><br />Dynamics AX 2012 R2 works with Lync 2010 client and Lync 2013 client.</p>
<p>&nbsp;</p>
<p>&nbsp;*Enterprise Portal support for SharePoint 2013 is still under development. A hotfix will be available soon.</p>]]></content:encoded>
    </item>
    <item>
      <title>Dynamics AX: Turning off specific tasks</title>
      <link>https://docs.microsoft.com/archive/blogs/chrisgarty/dynamics-ax-turning-off-specific-tasks</link>
      <pubDate>Mon, 25 Feb 2013 21:23:00 GMT</pubDate>
      <dc:creator><![CDATA[Chris Garty]]></dc:creator>
      <guid
        isPermaLink="false">https://blogs.msdn.microsoft.com/chrisgarty/2013/02/25/dynamics-ax-turning-off-specific-tasks/</guid>
      <description><![CDATA[Recently I had a someone ask me how to turn off or disable the Export to Excel task. Unfortunately,...]]></description>
      <content:encoded><![CDATA[<p>Recently I had a someone ask me how to turn off or disable the Export to Excel task. Unfortunately, like most tasks,&nbsp;it can't be disabled via&nbsp;the options dialog&nbsp;like the Document handling subsystem can&nbsp;be (Tools/Options/General/Miscellaneous/Document handling active).</p>
<p>In the AX2012 client, the task keyboard shortcuts like Ctrl+T don't go through the buttons, so disabling the Export to Excel button on a form doesn't affect keyboard shortcut access (or File menu access) to the Export to Excel task. However, each task does go through the task method. You can override the method to deny any task if wanted. And Class:SysSetupFormRun gives you cross cutting coverage across all forms where you can deny certain tasks by not calling through to super().</p>
<p>For example the following code would cause the Export to Excel task to be ignored:</p>
<p>public int task(int _p1)<br />{<br />&nbsp;&nbsp;&nbsp; #task<br />&nbsp;&nbsp;&nbsp; int ret;</p>
<p>&nbsp;&nbsp;&nbsp; if (_p1 == #taskExportExcel)<br />&nbsp;&nbsp;&nbsp; {<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; //Check for permissions if desired<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; //Ignore Export to Excel task<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; return 0;<br />&nbsp;&nbsp;&nbsp; }<br />//...other code here...<br />&nbsp;&nbsp;&nbsp; ret = super(_p1);<br />&nbsp;&nbsp;&nbsp; return ret;<br />}</p>
<p>&nbsp;</p>
<p>Of course I wouldn't recommend taking valuable options like Export to Excel away from users, but if you have specific requirements for the task subsystem it is useful to know how to influence it at such a low level.</p>]]></content:encoded>
    </item>
    <item>
      <title>Dynamics AX 2012 R2 Excel Add-in - Copy and paste and the addition of large data sets should be done with change tracking off</title>
      <link>https://docs.microsoft.com/archive/blogs/chrisgarty/dynamics-ax-2012-r2-excel-add-in-copy-and-paste-and-the-addition-of-large-data-sets-should-be-done-with-change-tracking-off</link>
      <pubDate>Sun, 28 Oct 2012 20:50:00 GMT</pubDate>
      <dc:creator><![CDATA[Chris Garty]]></dc:creator>
      <guid
        isPermaLink="false">https://blogs.msdn.microsoft.com/chrisgarty/2012/10/28/dynamics-ax-2012-r2-excel-add-in-copy-and-paste-and-the-addition-of-large-data-sets-should-be-done-with-change-tracking-off/</guid>
      <description><![CDATA[We did a lot of performance improvements for the Dynamics AX 2012 R2 Excel Add-in, but there is...]]></description>
      <content:encoded><![CDATA[<p>We did a lot of performance improvements for the Dynamics AX 2012 R2 Excel Add-in, but there is still one scenario that causes a lot of trouble... copy and paste.</p>
<p>When a large data set is pasted into a field bound table, then the VSTO change tracking evaluates the changes on the entire table after each row is pasted. This is just standard VSTO behavior that we can't work-around so the original 2012 advice still holds... turn track changes off when adding a large number of new rows.</p>
<p>Change tracking can be turned off via: Excel -&gt; Dynamics AX tab -&gt; Publish drop arrow -&gt; Publish options -&gt; Track changes checkbox</p>
<p>When track changes is turned back on then each row is treated as a new row, so remove existing data before turning track changes back on. When change tracking is resumed then each new row is evaluated once, resulting in a greatly reduced time waiting for the change tracking to analyze the new data set.</p>]]></content:encoded>
    </item>
    <item>
      <title>Responding to keyboard shortcuts in Dynamics AX</title>
      <link>https://docs.microsoft.com/archive/blogs/chrisgarty/responding-to-keyboard-shortcuts-in-dynamics-ax</link>
      <pubDate>Fri, 12 Oct 2012 08:10:00 GMT</pubDate>
      <dc:creator><![CDATA[Chris Garty]]></dc:creator>
      <guid
        isPermaLink="false">https://blogs.msdn.microsoft.com/chrisgarty/2012/10/12/responding-to-keyboard-shortcuts-in-dynamics-ax/</guid>
      <description><![CDATA[In Dynamics AX, the use of shortcut keys triggers a task. Some tasks do things, like Ctrl+F3 opening...]]></description>
      <content:encoded><![CDATA[<p>In Dynamics AX, the use of shortcut keys triggers a task. Some tasks do things, like Ctrl+F3 opening the advanced query window, while other tasks have been added just to allow override as needed, like many of the F keys (e.g. F4).</p>
<p>To override the standard behavior of a task, you can override the task method of that form&nbsp;e.g. \Forms\Form1\Methods\task.</p>
<p>Or for responding to that task across all forms, you can override the task method of the SysSetupFormRun class i.e. \Classes\SysSetupFormRun\Methods\task.</p>]]></content:encoded>
    </item>
    <item>
      <title>Data Migration for Microsoft Dynamics AX 2012</title>
      <link>https://docs.microsoft.com/archive/blogs/chrisgarty/data-migration-for-microsoft-dynamics-ax-2012</link>
      <pubDate>Mon, 26 Mar 2012 13:59:00 GMT</pubDate>
      <dc:creator><![CDATA[Chris Garty]]></dc:creator>
      <guid
        isPermaLink="false">https://blogs.msdn.microsoft.com/chrisgarty/2012/03/26/data-migration-for-microsoft-dynamics-ax-2012/</guid>
      <description><![CDATA[Partick Nelson recently made a Dynamics AX Data Migration white paper available on...]]></description>
      <content:encoded><![CDATA[<p>Partick Nelson recently made a <a title="Dynamics AX Data Migration white paper" href="https://informationsource.dynamics.com//RFPServicesOnline/Rfpservicesonline.aspx?DocName=Data+Migration+for+Microsoft+Dynamics+AX+2012%7cQJ4JEM76642V-8-857">Dynamics AX Data Migration white paper</a> available on <a title="InformationSource" href="https://informationsource.dynamics.com/">InformationSource</a>. <a title="Data Migration for Microsoft Dynamics AX 2012" href="https://informationsource.dynamics.com//RFPServicesOnline/Rfpservicesonline.aspx?DocName=Data+Migration+for+Microsoft+Dynamics+AX+2012%7cQJ4JEM76642V-8-857">Data Migration for Microsoft Dynamics AX 2012</a> includes sections on import via the Excel Add-in, import via RapidStart, using AIF document services and custom code, and an example of using AIF to import global address book data.</p>
<p>Once you've had a read of that whitepaper, go back and check out the other content that <a title="InformationSource" href="https://informationsource.dynamics.com/">InformationSource</a> has to offer... it is a fantastic resource.</p>
<p>&nbsp;</p>]]></content:encoded>
    </item>
    <item>
      <title>Can Dynamics AX 2012 work with Office 365?</title>
      <link>https://docs.microsoft.com/archive/blogs/chrisgarty/can-dynamics-ax-2012-work-with-office-365</link>
      <pubDate>Mon, 27 Feb 2012 12:40:00 GMT</pubDate>
      <dc:creator><![CDATA[Chris Garty]]></dc:creator>
      <guid
        isPermaLink="false">https://blogs.msdn.microsoft.com/chrisgarty/2012/02/27/can-dynamics-ax-2012-work-with-office-365/</guid>
      <description><![CDATA[Office 365 provides secure anywhere access to Microsoft Office capabilities including document...]]></description>
      <content:encoded><![CDATA[<p><a title="Office 365" href="https://www.microsoft.com/en-us/office365/">Office 365</a> provides secure anywhere access to Microsoft Office capabilities including document collaboration. Users can create, store, and edit Office documents online in Office 365. SharePoint Online can be thought of as the storage mechanism for Office 365 documents.</p>
<p><strong>Document Generation and Office 365</strong></p>
<p>If Word and Excel documents generated by Dynamics AX 2012 are uploaded to SkyDrive, SharePoint Online, or SharePoint 2010, then the corresponding Office Web Apps for that storage mechanism can be used to view and edit that document. <br />Document generation functionality is disabled if the appropriate Office application is not detected.</p>
<p><strong>Export to Excel&nbsp;and Office 365</strong></p>
<p>Export to Excel requires a local copy of Excel to be available. Export to Excel functionality is disabled if Excel is not detected. If a local copy of Excel is available, then the workbook can be saved and uploaded to SkyDrive or SharePoint Online for future collaboration and editing using the web version of Excel. However, the Office Add-in capability of refreshing the data in a workbook is not supported in Office 365 Excel.</p>
<p>Update for Dynamics AX 2012 R2 specifically... Users can set the Export location (File &gt; Tools &gt; General &gt; Miscellaneous &gt; Export location) to an Office 365 SharePoint Online folder. After the export workbook is copied to the SharePoint Online folder, then it will be opened, at that location, using Web Excel.</p>
<p><strong>Document Management&nbsp;and Office 365</strong></p>
<p>Document attachments can be located anywhere on the Internet or an intranet using the URL DocuType. If a document attached to a record is located on SharePoint Online, then, when opened, the attachment will automatically open in the web version of Word, Excel or PowerPoint. The user can also choose to save attachments for local editing as needed.</p>
<p><strong>Office Add-ins&nbsp;and Office 365</strong></p>
<p>Office Add-ins cannot be installed on Office 365 so Office Add-in scenarios are not supported when viewing a document in the web versions of Word and Excel.</p>
<p><strong>Your needs?</strong></p>
<p>In this forum I can't mention specifics about what we're working on with regards to Office 365 integration in the future, but I'm interested in hearing from anyone that is working with or intends to work with Dynamics AX 2012 and Office 365. How is it working out for you? Are there things you'd like to see us add in the future?</p>
<p>Feel free to comment on this post or drop me an email. Thanks!</p>
<p>Update 2013-07-17: Also see this new post on <a href="https://blogs.msdn.com/b/chrisgarty/archive/2013/07/17/office-interop-in-dynamics-ax-2012-r2.aspx">Dynamics AX 2012 R2: Improved Office Inerop capabilities</a></p>]]></content:encoded>
    </item>
  </channel>
</rss>