<?xml version="1.0" encoding="utf-8"?>
<rss xmlns:atom="https://www.w3.org/2005/Atom" xmlns:sy="https://purl.org/rss/1.0/modules/syndication/" xmlns:dc="https://purl.org/dc/elements/1.1/" xmlns:content="https://purl.org/rss/1.0/modules/content/" xmlns:wfw="https://wellformedweb.org/CommentAPI/" xmlns:slash="https://purl.org/rss/1.0/modules/slash/"
  version="2.0">
  <channel>
    <title>FrontPoint</title>
    <atom:link
      href="https://docs.microsoft.com/archive/blogs/frontpoint/feed.xml"
      rel="self"
      type="application/rss+xml" />
    <link>https://docs.microsoft.com/archive/blogs/frontpoint/feed.xml</link>
    <description>Using Microsoft FrontPage to do amazing things with SharePoint Products and Technologies</description>
    <lastBuildDate>Tue, 16 Apr 2019 05:07:04 GMT</lastBuildDate>
    <language>en-US</language>
    <sy:updatePeriod>hourly</sy:updatePeriod>
    <sy:updateFrequency>1</sy:updateFrequency>
    <item>
      <title>DataViewWebPart RunTime documentation</title>
      <link>https://docs.microsoft.com/archive/blogs/frontpoint/dataviewwebpart-runtime-documentation</link>
      <pubDate>Wed, 05 Oct 2005 15:05:00 GMT</pubDate>
      <dc:creator><![CDATA[frontpoint]]></dc:creator>
      <guid
        isPermaLink="false">https://blogs.msdn.microsoft.com/frontpoint/2005/10/05/dataviewwebpart-runtime-documentation/</guid>
      <description><![CDATA[Hey everyone, 
Sorry to be so lax in my postings. I was really busy getting ready for PDC and now...]]></description>
      <content:encoded><![CDATA[<P><FONT face=Tahoma size=2>Hey everyone, </FONT></P>
<P><FONT face=Tahoma size=2>Sorry to be so lax in my postings. I was really busy getting ready for PDC and now Beta1 for Office looms somewhere on the horizon. Please check out </FONT><a href="https://blogs.msdn.com/rmauceri/"><FONT face=Tahoma size=2>Rob Mauceri's blog</FONT></A><FONT face=Tahoma size=2> on our plans moving forward.</FONT></P>
<P><FONT face=Tahoma size=2>Additionally, check out this article on MSDN which documents the </FONT><A href="https://msdn.microsoft.com/library/?url=/library/en-us/odc_SP2003_ta/html/OfficeSharePointDDWRT.asp"><FONT face=Tahoma size=2>DDWRT (data driven web runtime) functions available in the DataViewWebPart</FONT></A><FONT face=Tahoma size=2>. This was done with a lot of work from Serge Van Den Oever as well as our dev team.</FONT></P>
<P><FONT face=Tahoma size=2>Thanks!<BR>-John</FONT></P>]]></content:encoded>
    </item>
    <item>
      <title>Editing items inside Nested Document Libraries</title>
      <link>https://docs.microsoft.com/archive/blogs/frontpoint/editing-items-inside-nested-document-libraries</link>
      <pubDate>Mon, 23 May 2005 13:40:00 GMT</pubDate>
      <dc:creator><![CDATA[frontpoint]]></dc:creator>
      <guid
        isPermaLink="false">https://blogs.msdn.microsoft.com/frontpoint/2005/05/23/editing-items-inside-nested-document-libraries/</guid>
      <description><![CDATA[I just found something pretty interesting about using a Data View Web Part to view items in a...]]></description>
      <content:encoded><![CDATA[<P><FONT face=Tahoma color=#000000 size=2>I just found something pretty interesting about using a Data View Web Part to view items in a Document Library that contains folders. Without going into all the technical details, essentially the "Edit" link will return an "Item not found" error for any documents inside the subfolders.</FONT></P>
<P><FONT face=Tahoma color=#000000 size=2>If you ever see this error, and you are positive the item does exist, the most likely cause for error is that the URL does not contain the RootFolder attribute. As an additional side note, for some reason the DataView converts the EDIT link into the DISPLAY link, so there are two issues here that I will show you how to fix.</FONT></P>
<P><FONT face=Tahoma color=#000000 size=2>First, for the repro: Browse to the Shared Documents document library in the browser. Create a new document called docOne.doc. Create a new folder called FolderOne and browse to this folder. Create a new doc in this folder called docTwo.doc.</FONT></P>
<P><FONT face=Tahoma color=#000000 size=2>Next you want to open the site in FrontPage and create a new WebPart page. Then click Data..Insert WebPart. Choose the Shared Documents web part and insert it.</FONT></P>
<P><FONT face=Tahoma color=#000000 size=2>After it is inserted, right click it and choose List View Properties. Click Fields and add the Edit field. Then right click the List View and choose "Convert to XSLT Data View".</FONT></P>
<P><FONT face=Tahoma color=#000000 size=2>Save the page and preview in browser.</FONT></P>
<P><FONT face=Tahoma color=#000000 size=2>You should notice that if you click to edit docOne.doc, you see the Display form (which is wrong)</FONT></P>
<P><FONT face=Tahoma color=#000000 size=2>If you click to edit docTwo.doc, you will see an item doesn't exist error (which is also wrong)</FONT></P>
<P><FONT face=Tahoma color=#000000 size=2>So, back to FrontPage to fix this:</FONT></P>
<P class=MsoNormal><SPAN><FONT face=Tahoma color=#000000>In code view for the page where the DataView lives, find:</FONT></SPAN></P>
<P class=MsoNormal><SPAN><FONT face=Tahoma color=#000000 size=2></FONT></SPAN>&nbsp;</P>
<P class=MsoNormal><SPAN><FONT face=Tahoma color=#ff0000>&lt;a href="{$URL_DISP}?ID={@ID}" onclick="GoToPage('{$URL_DISP}?ID={@ID}');return false;" target="_self"&gt;</FONT></SPAN></P>
<P class=MsoNormal><SPAN><FONT face=Tahoma color=#000000 size=2></FONT></SPAN>&nbsp;</P>
<P class=MsoNormal><SPAN><FONT face=Tahoma color=#000000>And replace it with this:</FONT></SPAN></P>
<P class=MsoNormal><SPAN><FONT face=Tahoma color=#ff0000>&lt;a href="{$URL_EDIT}?ID={@ID}&amp;amp;RootFolder={@FileDirRef}" onclick="GoToPage('{$URL_EDIT}?ID={@ID}&amp;amp;RootFolder={@FileDirRef}');return false;" target="_self"&gt;</FONT></SPAN></P>
<P class=MsoNormal><SPAN><FONT face=Tahoma></FONT></SPAN>&nbsp;</P>
<P class=MsoNormal><SPAN><FONT face=Tahoma color=#000000>That should do it. Have you seen other problems with Document Libraries? Let me know (the fact that the folders don't show up in the above scenario is already known and is unfortunately by design...)</FONT></SPAN></P>
<P class=MsoNormal><SPAN><FONT face=Tahoma color=#000000>-John</FONT></SPAN></P>]]></content:encoded>
    </item>
    <item>
      <title>Creating a Link using a Lookup field</title>
      <link>https://docs.microsoft.com/archive/blogs/frontpoint/creating-a-link-using-a-lookup-field</link>
      <pubDate>Fri, 15 Apr 2005 17:01:00 GMT</pubDate>
      <dc:creator><![CDATA[frontpoint]]></dc:creator>
      <guid
        isPermaLink="false">https://blogs.msdn.microsoft.com/frontpoint/2005/04/15/creating-a-link-using-a-lookup-field/</guid>
      <description><![CDATA[&nbsp;
Hi,
&nbsp;
I was just asked a great question: "How do I create a hyperlink when using a...]]></description>
      <content:encoded><![CDATA[<P class=MsoPlainText><o:p><FONT face=Tahoma size=2>&nbsp;</FONT></o:p></P>
<P class=MsoPlainText><FONT face=Tahoma size=2>Hi,</FONT></P>
<P class=MsoPlainText><o:p><FONT face=Tahoma size=2>&nbsp;</FONT></o:p></P>
<P class=MsoPlainText><FONT face=Tahoma size=2>I was just asked a great question: "How do I create a hyperlink when using a Lookup field that points to the item for that lookup field..."</FONT></P>
<P class=MsoPlainText><o:p><FONT face=Tahoma size=2>&nbsp;</FONT></o:p></P>
<P class=MsoPlainText><FONT face=Tahoma size=2>This is not completely straightforward, so bare with me. In this example, I am using the Announcements list and the Contacts list. In the Announcements list I created a lookup field the LastName value in the Contacts list and have created a few announcements with the LastName value in them.</FONT></P>
<P class=MsoPlainText><o:p><FONT face=Tahoma size=2>&nbsp;</FONT></o:p></P>
<P class=MsoPlainText><FONT face=Tahoma size=2>1. I need to get the List Id of the Contacts list. You can use the web service for this, but I find it much easier to simply drag the Contacts list onto a new page in design view, switch to code view, and Find '@ID' and then grab the list ID (it is a GUID). Then I close that page without saving it.</FONT></P>
<P class=MsoPlainText><o:p><FONT face=Tahoma size=2>&nbsp;</FONT></o:p></P>
<P class=MsoPlainText><FONT face=Tahoma size=2>2. Create a new page</FONT></P>
<P class=MsoPlainText><FONT face=Tahoma size=2>3. insert a view of the Announcements list including the Lookup field 4. select the Lookup field data value 5. Insert &gt; Hyperlink 6. type the following into the URL address field:</FONT></P>
<P class=MsoPlainText><A href="https://server/subsite/Lists/Contacts/dispform.aspx%7bddwrt:URLLookup('%7bLIST-GUID-FOUND-IN-STEP-ONE%7d"><FONT face=Tahoma size=2>https://server/subsite/Lists/Contacts/dispform.aspx{ddwrt:URLLookup('{LIST-GUID-FOUND-IN-STEP-ONE}</FONT></A><FONT face=Tahoma size=2>', 'lookup', string(@ID))}</FONT></P>
<P class=MsoPlainText><o:p><FONT face=Tahoma size=2>&nbsp;</FONT></o:p></P>
<P class=MsoPlainText><FONT face=Tahoma size=2>(NOTE The nested {} around the GUID). </FONT></P>
<P class=MsoPlainText><FONT face=Tahoma size=2>My URL looks like this:</FONT></P>
<P class=MsoPlainText><FONT face=Tahoma size=2>{ddwrt:URLLookup('{BBD5C595-B540-4839-AAAF-7FB2555A0960}', 'lookup', string(@ID))}</FONT></P>
<P class=MsoPlainText><o:p><FONT face=Tahoma size=2>&nbsp;</FONT></o:p></P>
<P class=MsoPlainText><FONT face=Tahoma size=2>7. Save the page</FONT></P>
<P class=MsoPlainText><FONT face=Tahoma size=2>8. switch back to code view and find "mailto:" </FONT></P>
<P class=MsoPlainText><FONT face=Tahoma size=2>9. Delete this. It is a bug that when your URL has an @ symbol in it, FrontPage adds the mailto: code...goofy, but should be fixed in the next release.</FONT></P>
<P class=MsoPlainText><FONT face=Tahoma size=2>10. save the page again</FONT></P>
<P class=MsoPlainText><FONT face=Tahoma size=2>11. Preview in the browser</FONT></P>
<P class=MsoPlainText><FONT face=Tahoma size=2>12. click the Link</FONT></P>
<P class=MsoPlainText><o:p><FONT face=Tahoma size=2>&nbsp;</FONT></o:p></P>
<P class=MsoPlainText><FONT face=Tahoma size=2>NOTICE: You should be directed to the dispform.aspx page and see the contact information.</FONT></P>
<P><FONT face=Tahoma></FONT>&nbsp;</P>]]></content:encoded>
    </item>
    <item>
      <title>Totals in the DataView when the View is Filtered</title>
      <link>https://docs.microsoft.com/archive/blogs/frontpoint/totals-in-the-dataview-when-the-view-is-filtered</link>
      <pubDate>Fri, 18 Mar 2005 09:05:00 GMT</pubDate>
      <dc:creator><![CDATA[frontpoint]]></dc:creator>
      <guid
        isPermaLink="false">https://blogs.msdn.microsoft.com/frontpoint/2005/03/18/totals-in-the-dataview-when-the-view-is-filtered/</guid>
      <description><![CDATA[Hello again, We are chugging along with the next version of Office and are super busy around here...]]></description>
      <content:encoded><![CDATA[<p><font face="Tahoma" size="2">Hello again,</font></p> <p><font face="Tahoma" size="2">We are chugging along with the next version of Office and are super busy around here trying to get the right features into the next version of the Data View and <a title="Microsoft SharePoint Products and Technologies" href="https://www.microsoft.com/sharepoint/" target="_blank">SharePoint</a> customization story. That said, I was looking through some older posts and saw this one:</font></p> <p><A href="https://blogs.msdn.com/frontpoint/archive/2004/04/30/123982.aspx"><font face="Tahoma" size="2">https://blogs.msdn.com/frontpoint/archive/2004/04/30/123982.aspx</font></a></p> <p><font face="Tahoma" size="2">from Rob. This is a really cool feature for showing the count of items in your view. However, this count is not accurate once you start using Ad Hoc filtering. This post is about extending the above example by making a minor edit to the XSLT in code view.</font></p> <p><font face="Tahoma" size="2">So....</font></p> <ul> <li><font face="Tahoma" size="2">Create a Data View of some data source (I'll just assume you know how if you're still reading this post)</font></li> <li><font face="Tahoma"><font size="2">Click on <strong>Data</strong> then <strong>Style</strong></font></font></li> <li><font face="Tahoma"><font size="2">Enable the default toolbar and the Show View Footer checkboxes on the&nbsp;<strong>Options</strong> tab and click <strong>OK</strong></font></font></li> <li><font face="Tahoma" size="2">Drag some data value into the View Footer and use the OOUI to change this to a COUNT (this is how far the above article gets you, this next step is the Money step)</font></li> <li><font face="Tahoma" size="2">Switch to code view (this next part is a little complicated - you are going to modify the View Footer XSLT and then move the code that says where to display the View Footer*)</font></li> <ol> <li><font face="Tahoma"><font size="2">Click <strong>Edit</strong> and then <strong>Find</strong></font></font></li> <li><font face="Tahoma" size="2">find the following: dvt_1.footer</font></li> <ul> <li><font face="Tahoma" size="2">the code should look like this:</font></li> <li><font face="Tahoma" color="#ff0000" size="2">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;xsl:call-template name="dvt_1.footer"&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;xsl:with-param name="Rows" select="$Rows"/&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;/xsl:call-template&gt;</font></li></ul> <li><font face="Tahoma" size="2">select this code and CUT</font></li> <li><font face="Tahoma"><font size="2">Click <strong>Edit</strong> and then <strong>Find</strong></font></font></li> <li><font face="Tahoma" size="2">find the following: groupend</font></li> <ul> <li><font face="Tahoma" size="2">the code should look like this:</font></li> <li><font face="Tahoma" color="#ff0000" size="2">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;xsl:variable name="groupend"&gt;&lt;xsl:value-of select="ddwrt:NameChanged('', -1)"/&gt;&lt;/xsl:variable&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&lt;/xsl:if&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&lt;/xsl:foreach&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&lt;/xsl:template&gt;</font></li></ul> <li><font face="Tahoma" size="2">paste in the code from step 2 immediately after the &lt;/xsl:foreach&gt; so it looks like this:</font></li> <ul> <li><font face="Tahoma"><font size="2"><font color="#ff0000">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;xsl:variable name="groupend"&gt;&lt;xsl:value-of select="ddwrt:NameChanged('', -1)"/&gt;&lt;/xsl:variable&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;/xsl:if&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;/xsl:for-each&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;xsl:call-template name="dvt_1.footer"&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;xsl:with-param name="Rows" select="$Rows"/&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;/xsl:call-template&gt;</font><br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; <font color="#ff0000">&lt;/xsl:template&gt;</font></font></font></li></ul> <li><font face="Tahoma"><font size="2">click <strong>Edit</strong> and then <strong>Find</strong></font></font></li> <li><font face="Tahoma" size="2">Find the following (again): dvt_1.footer</font></li> <ul> <li><font face="Tahoma" size="2">The code should look like this:</font></li> <li><font face="Tahoma" color="#ff0000" size="2">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;xsl:template name="dvt_1.footer"&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;xsl:param name="Rows"/&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;table cellSpacing="0" cellPadding="4" border="0" width="100%"&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;tr&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;td class="ms-vb"&gt;&lt;xsl:value-of select="count(/dataroot/Categories/CategoryID)"/&gt;&lt;/td&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;/tr&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;/table&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;/xsl:template&gt;</font></li></ul> <li><font face="Tahoma" size="2">Remove the &lt;table&gt; code so it looks like this</font></li> <ul> <li><font face="Tahoma" color="#ff0000" size="2">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;xsl:template name="dvt_1.footer"&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;xsl:param name="Rows"/&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;tr&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;td class="ms-vb"&gt;&lt;xsl:value-of select="count(/dataroot/Categories/CategoryID)"/&gt;&lt;/td&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;/tr&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;/xsl:template&gt;</font></li></ul> <li><font face="Tahoma" size="2">Change the Count code so it references a variable rather than a literal path</font></li> <ul> <li><font face="Tahoma" color="#ff0000" size="2">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;xsl:template name="dvt_1.footer"&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;xsl:param name="Rows"/&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;tr&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;td class="ms-vb"&gt;&lt;xsl:value-of select="count($Rows)"/&gt;&lt;/td&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;/tr&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;/xsl:template&gt;</font></li></ul></ol> <li><font face="Tahoma" size="2">Save the page and preview in the browser</font></li> <li><font face="Tahoma" size="2">Change the Filter and you should see the count change</font></li></ul> <p><font face="Tahoma" size="2">I am hoping this will be much easier in the next release.</font></p> <p><font face="Tahoma" size="2">-John</font></p> <p><strong><font face="Tahoma" size="2">*technical details: our design is to put the view footer outside the body template that displays your data. Because of this, the scope of the $Rows parameter is outside the current Repeating Data Region. What we have to do is move the scope inside the current RDR. In doing so, we need to delete the &lt;table&gt; code so it will be valid HTML.</font></strong></p> <p><font face="Tahoma" size="2">&nbsp;&nbsp;&nbsp;</font></p>]]></content:encoded>
    </item>
    <item>
      <title>Serge van den Oever</title>
      <link>https://docs.microsoft.com/archive/blogs/frontpoint/serge-van-den-oever</link>
      <pubDate>Tue, 01 Mar 2005 07:38:00 GMT</pubDate>
      <dc:creator><![CDATA[frontpoint]]></dc:creator>
      <guid
        isPermaLink="false">https://blogs.msdn.microsoft.com/frontpoint/2005/03/01/serge-van-den-oever/</guid>
      <description><![CDATA[I just came across Serge's Blog last night and wanted to link to it, but also wanted to get some...]]></description>
      <content:encoded><![CDATA[<p><font face="Tahoma" size="2">I just came across Serge's Blog last night and wanted to link to it, but also wanted to get some feedback. I've been working on documenting all the DDWRT functions the come with the DataViewWebPart, when much to my surprise, Serge had already a good job of it himself.</font></p> <p><span style="FONT-SIZE: 12pt; FONT-FAMILY: 'Times New Roman'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><a href="https://weblogs.asp.net/soever/archive/2005/01/03/345535.aspx"><font face="Tahoma" size="2">https://weblogs.asp.net/soever/archive/2005/01/03/345535.aspx</font></a></span></p> <p><span style="FONT-SIZE: 12pt; FONT-FAMILY: 'Times New Roman'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><font face="Tahoma" size="2">I was hoping to get some feedback about whether this information is useful, high priority, necessary...any comments at all.</font></span></p> <p><span style="FONT-SIZE: 12pt; FONT-FAMILY: 'Times New Roman'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><font face="Tahoma" size="2">Thanks!</font></span></p> <p><span style="FONT-SIZE: 12pt; FONT-FAMILY: 'Times New Roman'; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><font face="Tahoma" size="2">-John</font></span></p>]]></content:encoded>
    </item>
    <item>
      <title>Some Behaviors may not be restored even though you check the button to "Restore onmouseout"</title>
      <link>https://docs.microsoft.com/archive/blogs/frontpoint/some-behaviors-may-not-be-restored-even-though-you-check-the-button-to-restore-onmouseout</link>
      <pubDate>Thu, 10 Feb 2005 07:29:00 GMT</pubDate>
      <dc:creator><![CDATA[frontpoint]]></dc:creator>
      <guid
        isPermaLink="false">https://blogs.msdn.microsoft.com/frontpoint/2005/02/10/some-behaviors-may-not-be-restored-even-though-you-check-the-button-to-restore-onmouseout/</guid>
      <description><![CDATA[This one is really more of a KB article topic than SharePoint specific, but I was asked this...]]></description>
      <content:encoded><![CDATA[<p><font face="Verdana" color="#000000" size="2">This one is really more of a KB article topic than <a title="Microsoft SharePoint Products and Technologies" href="https://www.microsoft.com/sharepoint/" target="_blank">SharePoint</a> specific, but I was asked this question by a <a title="Microsoft SharePoint Products and Technologies" href="https://www.microsoft.com/sharepoint/" target="_blank">SharePoint</a> developer who uses a lot of DIVs, so I thought I'd post it here.</font></p> <p><font face="Verdana" color="#000000" size="2">If you use <a title="Microsoft Office FrontPage" href="https://office.microsoft.com/frontpage" target="_blank">FrontPage</a> Behaviors to do things like change the background color of a layer, or change the style of a font tag using onclick or onmouseover commands, and you also want to restore the style onmouseout or onblur, you may find that the style is not restored properly in certain cases.</font></p> <p><font face="Verdana" color="#000000" size="2">These cases are when the style is set as part of the style attribute. For example, if you have:<br />&lt;DIV style="background-color: red;"&gt;this is in the div&lt;/DIV&gt;</font></p> <p><font face="Verdana" color="#000000" size="2">And you use <a title="Microsoft Office FrontPage" href="https://office.microsoft.com/frontpage" target="_blank">FrontPage</a>'s behaviors to change the color to black onmouseover, it will not turn back to red onmouseout even though you check the box for it to do so.</font></p> <p><font face="Verdana" color="#000000" size="2">The workaround if pretty simple, but also very hard to figure out, so here it is:</font></p> <p><font face="Verdana" color="#000000" size="2">In code view, use Edit &gt; Find to find the following code in the restore javascript function:</font></p> <p class="MsoNormal"><span style="FONT-SIZE: 10pt; COLOR: blue; FONT-FAMILY: Verdana"><font color="#ff0000">eval("x."+x.n+"=x.v"); }</font></span></p> <p class="MsoNormal"><span style="FONT-SIZE: 10pt; COLOR: blue; FONT-FAMILY: Verdana"><font color="#000000">and change it to: </font></span></p> <p class="MsoNormal"><span style="FONT-SIZE: 10pt; COLOR: blue; FONT-FAMILY: Verdana"><font color="#ff0000">eval("x."+x.n+"=String(x.v)"); }</font></span></p> <p class="MsoNormal"><span style="FONT-SIZE: 10pt; COLOR: blue; FONT-FAMILY: Verdana"><font color="#000000">That should do it for you.</font></span></p> <p class="MsoNormal"><span style="FONT-SIZE: 10pt; COLOR: blue; FONT-FAMILY: Verdana"><font color="#000000">-John</font></span></p>]]></content:encoded>
    </item>
    <item>
      <title>Selecting unique values in a Drop-down list using the Data View Web Part</title>
      <link>https://docs.microsoft.com/archive/blogs/frontpoint/selecting-unique-values-in-a-drop-down-list-using-the-data-view-web-part</link>
      <pubDate>Tue, 08 Feb 2005 10:48:00 GMT</pubDate>
      <dc:creator><![CDATA[frontpoint]]></dc:creator>
      <guid
        isPermaLink="false">https://blogs.msdn.microsoft.com/frontpoint/2005/02/08/selecting-unique-values-in-a-drop-down-list-using-the-data-view-web-part/</guid>
      <description><![CDATA[I posted awhile ago about how to select unique values for tabular data views, but I have now...]]></description>
      <content:encoded><![CDATA[<p><font face="Tahoma" size="2">I posted awhile ago about how to select unique values for tabular data views, but I have now received a few emails asking how to do it for drop-down lists. It is almost the exact same code, but apparently this is confusing enough to warrant&nbsp;a different post.</font></p> <p><font face="Tahoma" size="2">My code sample assumes you are using the default Announcements list on <a title="Microsoft SharePoint Products and Technologies" href="https://www.microsoft.com/sharepoint/" target="_blank">SharePoint</a> and that the Title field is what you want to display.</font></p> <p><font face="Tahoma" size="2">First, browse out to your&nbsp;Announcements list (which you get by default when you create a </font><a title="Microsoft SharePoint Products and Technologies" href="https://www.microsoft.com/sharepoint/" target="_blank"><a title="Microsoft SharePoint Products and Technologies" href="https://www.microsoft.com/sharepoint/" target="_blank"><font face="Tahoma" size="2">SharePoint</font></a></a><font face="Tahoma" size="2"> site), and add a few Announcements all with the same title (just for demonstrations sake :-))</font></p> <p><font face="Tahoma" size="2">Then...</font></p> <p><font face="Tahoma" size="2">1. </font><A href="https://blogs.msdn.com/frontpoint/articles/119028.aspx"><font face="Tahoma" size="2">Insert a Data View Web Part</font></a><font face="Tahoma"><font size="2"> based on the&nbsp;Announcements list<br />2. Click Data..Style and change to the drop-down view style..OK<br />2. Probably best to switch to code view at this point<br />3. Find the code that looks like this:<br /><font color="#0000ff">&lt;xsl:template name="dvt_1.body" xmlns:ddwrt="</font></font></font><a href="https://schemas.microsoft.com/WebParts/v2/DataView/runtime"><font face="Tahoma" color="#0000ff" size="2">https://schemas.microsoft.com/WebParts/v2/DataView/runtime</font></a><font face="Tahoma" color="#0000ff" size="2">" xmlns:xsl="</font><a href="https://www.w3.org/1999/XSL/Transform"><font face="Tahoma" color="#0000ff" size="2">https://www.w3.org/1999/XSL/Transform</font></a><font face="Tahoma"><font size="2"><font color="#ff0000"><font color="#0000ff">" xmlns:msxsl="urn:schemas-microsoft-com:xslt"&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;xsl:param name="Rows"/&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;xsl:param name="FirstRow"/&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;xsl:param name="LastRow"/&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;xsl:for-each select="$Rows"&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;xsl:variable name="KeepItemsTogether" select="false()"/&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;xsl:variable name="HideGroupDetail" select="false()"/&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;xsl:variable name="GroupStyle" select="'auto'"/&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;xsl:if test="(position() &amp;gt;= $FirstRow and position() &amp;lt;= $LastRow) or $KeepItemsTogether"&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;xsl:if test="not($HideGroupDetail)" ddwrt:cf_ignore="1"&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;option style="display:{$GroupStyle}"&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;xsl:value-of select="@Title"/&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;/option&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;/xsl:if&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;/xsl:if&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;/xsl:for-each&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;/xsl:template&gt;</font><br /></font>4. Change that code to look like this:<br /><font color="#0000ff">&lt;xsl:template name="dvt_1.body" xmlns:ddwrt="</font></font></font><a href="https://schemas.microsoft.com/WebParts/v2/DataView/runtime"><font face="Tahoma" color="#0000ff" size="2">https://schemas.microsoft.com/WebParts/v2/DataView/runtime</font></a><font face="Tahoma" color="#0000ff" size="2">" xmlns:xsl="</font><a href="https://www.w3.org/1999/XSL/Transform"><font face="Tahoma" color="#0000ff" size="2">https://www.w3.org/1999/XSL/Transform</font></a><font face="Tahoma" color="#0000ff" size="2">" xmlns:msxsl="urn:schemas-microsoft-com:xslt"&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;xsl:param name="Rows"/&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;xsl:param name="FirstRow"/&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;xsl:param name="LastRow"/&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;xsl:for-each select="$Rows"&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;xsl:variable name="KeepItemsTogether" select="false()"/&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;xsl:variable name="HideGroupDetail" select="false()"/&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;xsl:variable name="GroupStyle" select="'auto'"/&gt;</font></p> <p><font face="Tahoma" color="#ff0000" size="2">&lt;!-- this next line is used to store the&nbsp;value we need to compare&nbsp;for uniqueness --&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;xsl:variable name="uniqueTitle" select="@Title"/&gt;</font><font color="#0000ff"><br /><font face="Tahoma"><font size="2"><font color="#ff0000"><font color="#0000ff">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;xsl:if test="(position() &amp;gt;= $FirstRow and position() &amp;lt;= $LastRow) or $KeepItemsTogether"&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;xsl:if test="not($HideGroupDetail)" ddwrt:cf_ignore="1"&gt;<br /></font>&lt;!-- this next part is where we compare the variable created above to the current selection and if they are different, we write the value --&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;xsl:if test="@ID=//Rows/Row[@Title=$uniqueTitle][1]/@ID"&gt;<br /></font><font color="#0000ff">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;option style="display:{$GroupStyle}" value="</font></font></font><a href="mailto:{@Title"><font face="Tahoma" color="#0000ff" size="2">{@Title</font></a></font><font face="Tahoma" color="#0000ff" size="2">}"&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;xsl:value-of select="@Title"/&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;/option&gt;</font><font face="Tahoma"><font size="2"><font color="#0000ff"><font color="#ff0000">&lt;/xsl:if&gt;<br /></font>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;/xsl:if&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;/xsl:if&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;/xsl:for-each&gt;<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;/xsl:template&gt;<br /></font><font color="#000000">5. Save the page.&nbsp; Notice that only the unique values are displayed.&nbsp; You can use this code in any number of places in the XSLT (for example, inside a drop-down menu).</font></font></font></p>]]></content:encoded>
    </item>
    <item>
      <title>Use a drop-down control's onchange event to navigate to pages dyanamically</title>
      <link>https://docs.microsoft.com/archive/blogs/frontpoint/use-a-drop-down-controls-onchange-event-to-navigate-to-pages-dyanamically</link>
      <pubDate>Tue, 08 Feb 2005 10:27:00 GMT</pubDate>
      <dc:creator><![CDATA[frontpoint]]></dc:creator>
      <guid
        isPermaLink="false">https://blogs.msdn.microsoft.com/frontpoint/2005/02/08/use-a-drop-down-controls-onchange-event-to-navigate-to-pages-dyanamically/</guid>
      <description><![CDATA[I have seen this come up a few times lately and I feel like I'm just typing the same thing over an...]]></description>
      <content:encoded><![CDATA[<p class="MsoNormal"><span style="COLOR: blue"><font face="Tahoma" size="2">I have seen this come up a few times lately and I feel like I'm just typing the same thing over an over, so I'll post it here.&nbsp; I'm sorry I am being so bad about posting lately, I am going to try to do better.</font></span></p> <p class="MsoNormal"><span style="COLOR: blue"><font face="Tahoma" size="2">The goal of this article is to use an XML data source to populate a drop-down control that will take you to some other URL when you change the drop-down controls value. Now, if you are using List Data, you may want to check out my article for </font><A href="https://blogs.msdn.com/frontpoint/articles/123113.aspx"><font face="Tahoma" size="2">breaking up a URL field type</font></a><font face="Tahoma" size="2">. And I am going to post in just a minute or two with instructions for selecting unique values in the drop-down.</font></span></p> <ol> <li class="MsoNormal"><span style="COLOR: blue"><font face="Tahoma"><font size="2">Open your page in <a title="Microsoft Office FrontPage" href="https://office.microsoft.com/frontpage" target="_blank">FrontPage</a> 2003<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" /><o:p></o:p></font></font></span></li> <li> <div class="MsoNormal"><span style="COLOR: blue"><font face="Tahoma"><font size="2">Data..Insert Data View<o:p></o:p></font></font></span></div></li> <li> <div class="MsoNormal"><span style="COLOR: blue"><font face="Tahoma"><font size="2">Choose your data source, right click &gt; Show Data<o:p></o:p></font></font></span></div></li> <li> <div class="MsoNormal"><span style="COLOR: blue"><font face="Tahoma"><font size="2">Select the fields you want to use in the drop-down<o:p></o:p></font></font></span></div></li> <li> <div class="MsoNormal"><span style="COLOR: blue"><font face="Tahoma" size="2">Insert Data View</font></span></div></li> <li> <div class="MsoNormal"><span style="COLOR: blue"><font face="Tahoma"><font size="2">Data..Style<o:p></o:p></font></font></span></div></li> <li> <div class="MsoNormal"><span style="COLOR: blue"><font face="Tahoma" size="2">Change to “Drop-down view style”..OK</font></span></div></li> <li> <div class="MsoNormal"><span style="COLOR: blue"><font face="Tahoma" size="2">Switch to code view</font></span></div></li> <li> <div class="MsoNormal"><span style="COLOR: blue"><font face="Tahoma" size="2">Just before the &lt;/head&gt; tag, add this code:</font></span></div></li></ol> <p class="MsoNormal"><span style="COLOR: #993300"><font face="Tahoma" size="2">&lt;script language="JavaScript"&gt;<br /></font></span><span style="COLOR: #993300"><font face="Tahoma" size="2">&lt;!--<br /></font></span><span style="COLOR: #993300"><font face="Tahoma" size="2">function FP_jumpMenu(el,frm,sel) {//v1.0<br /></font></span><span style="COLOR: #993300"><font face="Tahoma" size="2">var href=el.options[el.selectedIndex].value; if(sel) el.selectedIndex=0;<br /></font></span><span style="COLOR: #993300"><font face="Tahoma" size="2">if('_new'==frm) open(href); else eval(frm+".location='"+href+"'");<br /></font></span><span style="COLOR: #993300"><font face="Tahoma" size="2">}<br /></font></span><font face="Tahoma"><font size="2"><span style="COLOR: #993300">// --&gt;<br /></span><span style="COLOR: #993300">&lt;/script&gt;</span></font></font></p> <p class="MsoNormal"><span style="COLOR: #993300"><font color="#000000"><font face="Tahoma"><font size="2">11. <span style="COLOR: blue">FIND: </span></font></font><span style="COLOR: #993300"><font face="Tahoma"><font size="2">&lt;select name="ID" size="1"<br /><font color="#000000">12.</font> <span style="COLOR: blue">Change to: &lt;</span></font></font><span style="COLOR: #993300"><font face="Tahoma" size="2">select name="ID" size="1" onchange="FP_jumpMenu(this,'window',false)"&gt;<br /><font color="#000000">13.</font>&nbsp;</font></span></span></font></span><span style="COLOR: blue"><o:p><font face="Tahoma"><font size="2">&nbsp;<span style="COLOR: blue">FIND: </span></font></font><span style="COLOR: #993300"><font face="Tahoma"><font size="2">&lt;option style="display:{$GroupStyle}"<br /><font color="#000000">14.</font> <span style="COLOR: blue">Change </span><span style="COLOR: #993300">to: &lt;option style="display:{$GroupStyle}" value=”{@FieldWithURL}”&gt; &lt;!--where FieldWIthURL is your field with the URL </span><span style="COLOR: #993300; FONT-FAMILY: Wingdings">J</span></font></font><span style="COLOR: #993300"><font face="Tahoma" size="2"> --&gt;<br /><font color="#000000">15.</font>&nbsp;</font></span></span></o:p></span><span style="COLOR: blue"><font face="Tahoma"><font size="2">Save the page and preview in the browser.<o:p></o:p></font></font></span></p>]]></content:encoded>
    </item>
    <item>
      <title>Using Conditional Formatting and the data view opens up a whole new world of possibilities</title>
      <link>https://docs.microsoft.com/archive/blogs/frontpoint/using-conditional-formatting-and-the-data-view-opens-up-a-whole-new-world-of-possibilities</link>
      <pubDate>Thu, 11 Nov 2004 10:09:00 GMT</pubDate>
      <dc:creator><![CDATA[frontpoint]]></dc:creator>
      <guid
        isPermaLink="false">https://blogs.msdn.microsoft.com/frontpoint/2004/11/11/using-conditional-formatting-and-the-data-view-opens-up-a-whole-new-world-of-possibilities/</guid>
      <description><![CDATA[I have a Data View Web Part that displays the status of several different servers I maintain.&nbsp;...]]></description>
      <content:encoded><![CDATA[<p><font face="Arial" size="2">I have a Data View Web Part that displays the status of several different servers I maintain.&nbsp; Basically, I am using a <a title="Microsoft SharePoint Products and Technologies" href="https://www.microsoft.com/sharepoint/" target="_blank">SharePoint</a> list.&nbsp; The List has a Title field which contains the name of each server and a multiple choice field that lets me set the status to "UP," "DOWN," or "CAUTION."</font></p> <p><font face="Arial" size="2">For each of these three statuses, I have&nbsp;a little gif image of a green arrow, red arrow and yellow circle respectively.&nbsp; What I want to do is create a data view that has the name of the server and displays the arrow based on the what the status is.&nbsp; </font></p> <p><font face="Arial" size="2">Here's how to do that.</font></p> <ol> <li><font face="Arial" size="2">Open the <a title="" href="https://www.microsoft.com/sharepoint/" >wss</a> site in <a title="Microsoft Office FrontPage" href="https://office.microsoft.com/frontpage" target="_blank">FrontPage</a> 2003</font></li> <li><font face="Arial" size="2">Click Data..Insert Data View</font></li> <li><font face="Arial" size="2">Right click the <a title="Microsoft SharePoint Products and Technologies" href="https://www.microsoft.com/sharepoint/" target="_blank">SharePoint</a> list that contains my data</font></li> <li><font face="Arial" size="2">Click "Show Data"</font></li> <li><font face="Arial" size="2">Select the Title field</font></li> <li><font face="Arial" size="2">Click "Insert Data View"</font></li> <li><font face="Arial" size="2">Since I only selected one field, I get a bulleted list. So I change this: by clicking on Data..Style &gt; General tab and changing to Tabular view..OK</font></li> <li><font face="Arial" size="2">Place the Cursor next to one of the server names and add a new column to my view: Table &gt; Insert &gt; Rows and Columns</font></li> <li><font face="Arial" size="2">Place the Cursor inside a cell in this new column and insert my image</font></li> <li><font face="Arial" size="2">Insert &gt; Picture from file</font></li> <li><font face="Arial" size="2">I type in the URL to the green.gif</font></li> <li><font face="Arial" size="2">Next to this image, I insert the red.gif and yellow.gif as well so each row of data now shows all three images</font></li> <li><font face="Arial" size="2">Select the green.gif image</font></li> <li><font face="Arial" size="2">Click on Data..Conditional Formatting</font></li> <li><font face="Arial" size="2">Click Create</font></li> <li><font face="Arial" size="2">Click Show Content...</font></li> <li><font face="Arial" size="2">I create a filter that says "Status == UP"..OK (now the green arrow only shows in rows where status is UP)</font></li> <li><font face="Arial" size="2">Repeat steps 13 through 17 for the other two gifs, setting the filter appropriately</font></li> <li><font face="Arial" size="2">Save the page</font></li></ol> <p><font face="Arial" size="2">Using Conditional Formatting opens up a huge world of possibilities.&nbsp; You can modify views by passing parameters via web part connections, you can format items conditionally, you can show data or hide data based on complex XPATH by clicking on the Advanced button in the filter dialog, and on and on.</font></p>]]></content:encoded>
    </item>
    <item>
      <title>HowTo: Display a different image inside a data view web part based on data in the XML</title>
      <link>https://docs.microsoft.com/archive/blogs/frontpoint/howto-display-a-different-image-inside-a-data-view-web-part-based-on-data-in-the-xml</link>
      <pubDate>Thu, 11 Nov 2004 10:01:00 GMT</pubDate>
      <dc:creator><![CDATA[frontpoint]]></dc:creator>
      <guid
        isPermaLink="false">https://blogs.msdn.microsoft.com/frontpoint/2004/11/11/howto-display-a-different-image-inside-a-data-view-web-part-based-on-data-in-the-xml/</guid>
      <description><![CDATA[I have a Data View Web Part that displays the status of several different servers I maintain.&nbsp;...]]></description>
      <content:encoded><![CDATA[<p><font face="Arial" size="2">I have a Data View Web Part that displays the status of several different servers I maintain.&nbsp; Basically, I am using a <a title="Microsoft SharePoint Products and Technologies" href="https://www.microsoft.com/sharepoint/" target="_blank">SharePoint</a> list.&nbsp; The List has a Title field which contains the name of each server and a multiple choice field that lets me set the status to "UP," "DOWN," or "CAUTION."</font></p> <p><font face="Arial" size="2">For each of these three statuses, I have&nbsp;a little gif image of a green arrow, red arrow and yellow circle respectively.&nbsp; What I want to do is create a data view that has the name of the server and displays the arrow based on the what the status is.&nbsp; </font></p> <p><font face="Arial" size="2">Here's how to do that.</font></p> <ol> <li><font face="Arial" size="2">Open the <a title="" href="https://www.microsoft.com/sharepoint/" >wss</a> site in <a title="Microsoft Office FrontPage" href="https://office.microsoft.com/frontpage" target="_blank">FrontPage</a> 2003</font></li> <li><font face="Arial" size="2">Click Data..Insert Data View</font></li> <li><font face="Arial" size="2">Right click the <a title="Microsoft SharePoint Products and Technologies" href="https://www.microsoft.com/sharepoint/" target="_blank">SharePoint</a> list that contains my data</font></li> <li><font face="Arial" size="2">Click "Show Data"</font></li> <li><font face="Arial" size="2">Select the Title field</font></li> <li><font face="Arial" size="2">Click "Insert Data View"</font></li> <li><font face="Arial" size="2">Since I only selected one field, I get a bulleted list. So I change this: by clicking on Data..Style &gt; General tab and changing to Tabular view..OK</font></li> <li><font face="Arial" size="2">Place the Cursor next to one of the server names and add a new column to my view: Table &gt; Insert &gt; Rows and Columns</font></li> <li><font face="Arial" size="2">Place the Cursor inside a cell in this new column and insert my image</font></li> <li><font face="Arial" size="2">Insert &gt; Picture from file</font></li> <li><font face="Arial" size="2">I type in the URL to the green.gif</font></li> <li><font face="Arial" size="2">Next to this image, I insert the red.gif and yellow.gif as well so each row of data now shows all three images</font></li> <li><font face="Arial" size="2">Select the green.gif image</font></li> <li><font face="Arial" size="2">Click on Data..Conditional Formatting</font></li> <li><font face="Arial" size="2">Click Create</font></li> <li><font face="Arial" size="2">Click Show Content...</font></li> <li><font face="Arial" size="2">I create a filter that says "Status == UP"..OK (now the green arrow only shows in rows where status is UP)</font></li> <li><font face="Arial" size="2">Repeat steps 13 through 17 for the other two gifs, setting the filter appropriately</font></li> <li><font face="Arial" size="2">Save the page</font></li></ol> <p><font face="Arial" size="2"></font>&nbsp;</p>]]></content:encoded>
    </item>
  </channel>
</rss>