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Your mailbox can't sync incoming emails because the email connection channel is set to sync using an Email Router

This article provides a solution to an error that occurs when you try to Test and Enable a mailbox in Dynamics 365.

Applies to:   Microsoft Dynamics CRM
Original KB number:   4053588

Symptoms

When you attempt to Test and Enable a mailbox in Dynamics 365, one of the following alerts is logged:

  • "Your mailbox <Mailbox Name> can't sync incoming emails because the email connection channel is set to sync using an Email Router. Contact your administrator to change the default connection channel to Server-Side Synchronization.
    Email Server Error Code: IncomingEmailConnectionChannelError"

  • "Your mailbox <Mailbox Name> can't sync outgoing emails because the email connection channel is set to sync using an Email Router. Contact your administrator to change the default connection channel to Server-Side Synchronization.
    Email Server Error Code: OutgoingEmailConnectionChannelError"

  • "Your mailbox <Mailbox Name> can't sync appointments, contacts, and tasks because the email connection channel is set to sync using an Email Router. Contact your administrator to change the default connection channel to Server-Side Synchronization.
    Email Server Error Code: ExchangeSyncACTEmailConnectionChannelError"

Cause

These alerts are logged if the Process Email Using option within System Settings is configured to use Microsoft Dynamics 365 Email Router instead of Server-Side Synchronization.

Resolution

To use Server-Side Synchronization instead of Email Router, make sure the Process Email Using option within System Settings is configured to use Server-Side Synchronization:

  1. Access your Dynamics 365 instance as a user with the System Administrator role.
  2. Navigate to Settings and then select Administration.
  3. Select the Email tab.
  4. Locate the Process Email Using option, and make sure it's set to Server-Side Synchronization.
  5. Select OK.
  6. Navigate to Settings, and then select Email Configuration.
  7. Select Mailboxes.
  8. Change the selected view from My Active Mailboxes to Active Mailboxes.
  9. Select the mailboxes you want to enable for Server-Side Synchronization, and then select the Test & Enable Mailboxes button. Make sure to select the checkbox on the dialog that appears and then select OK.
  10. Wait for the Test & Enable process to complete. If the test results aren't Success, review the Alerts area within the mailbox record.

More information

You can only use Email Router or Server-Side Synchronization (recommended) for sending and receiving email in Dynamics 365. Both options can't be used in the same Dynamics 365 instance. The Process Email Using option determines which of these options is enabled. The Test & Enable Mailbox button is for use with the Server-Side Synchronization feature. If you're using the Email Router, you don't need to Test & Enable the mailbox.