"String or binary data would be truncated" error when activating an SLA
This article provides a resolution for an error that occurs when you activate a service-level agreement (SLA) in Microsoft Dynamics 365 Customer Service.
Symptoms
When you activate an SLA, you receive the following error message:
String or binary data would be truncated in table '{0}', column '{1}'. Truncated value: {2}" appears.
Cause
The MaxLength
property of the ChangedAttributeList attribute of an SLA entity has reached its limit of 4000. This might occur based on the number or name of the fields configured in the SLA conditions.
Resolution
To solve this issue, simplify your existing SLA structure. Here's an example:
SLA 1 includes 10 SLA items. Create a new SLA named SLA 2. Transfer five SLA items from SLA 1 to SLA 2. You now have two SLAs, each containing five SLA items. This approach helps streamline and manage SLAs more effectively based on specific requirements.
To apply SLA 2 to newly created cases, you need to develop the necessary custom logic, workflows/flows, or plug-ins.