Dynamics 365 App for Outlook didn't load completely error occurs in Microsoft Dynamics 365 App for Outlook
This article provides a solution to an error that occurs when you try to use the Dynamics 365 App for Outlook.
Applies to: Microsoft Dynamics 365 Customer Engagement Online
Original KB number: 4567653
Symptoms
When attempting to use the Dynamics 365 App for Outlook, you see the following error:
"Dynamics 365 App for Outlook didn't load completely. Please ensure you are connected to internet and restart the add-in."
If you select the Show more link, the extra details include the following error:
"Error: window.Office not available"
Cause
While loading Dynamics 365 App for Outlook, external script office.js might fail to load. Because office.js is a required dependency, Dynamics 365 App for Outlook can't start and will show an error.
Resolution
- Verify your computer has a connection to the Internet.
- If you're using Outlook desktop app, follow Switch from working offline to online to ensure that you're online.
- Reload Dynamics 365 App for Outlook.