New CMG creation fails after entering sign-in credentials in Configuration Manager

This article helps to resolve the issue in which a new Cloud Management Gateway (CMG) creation fails after entering sign-in credentials in Configuration Manager version 2207 or earlier versions.

Applies to:   Configuration Manager current branch, versions 2207, 2203, and 2111

Cause

The new CMG creation fails because the Configuration Manager console terminates unexpectedly after entering sign-in credentials in Configuration Manager.

When you try to create a CMG, there's a failure to obtain the Microsoft Graph token, and the Microsoft.Identity.Client.MsalUiRequiredException exception is referenced in the SMSAdminUI.log file.

This issue occurs in one of the following conditions:

  • The Prompt.Never flag is passed, but the constraint can't be honored because user interaction is required.
  • An error occurs during a silent web authentication that prevents the HTTP authentication flow from completing in a short enough time frame.

Resolution

Note

This issue doesn't occur in Configuration Manager version 2211.

To fix this issue, use one of the following methods:

  • If you're running Configuration Manager version 2207, install the hotfix rollup (KB15152495).

    Note

    To get the hotfix, go to the Administration workspace, select the Updates and Servicing node, and then select Check for updates in the ribbon.

  • If you're running Configuration Manager version 2203, install the limited release hotfix to address this issue.

    Prerequisite: To install the hotfix, you must have the hotfix rollup KB14244456 installed.

  • If you're running Configuration Manager version 2111, install the limited release hotfix to address this issue.

    Prerequisite: To install the hotfix, you must have the hotfix rollup KB12896009 installed.

For more information about installing the out-of-band update, see Use the update registration tool to import hotfixes.