AI models fail to be imported in a new environment

This article provides a solution to an error that occurs when AI models fail to be imported in a new environment.

Applies to:   Power Automate, Power Apps

Symptoms

Your AI models fail to be imported in a new environment.

Cause

AI models are in error state after importing them in a new environment.

Resolution

Here's a sequence of actions you can try to resolve the issue.

  1. Uninstall the solution containing the model(s).
  2. If your solution is unmanaged, manually delete the models in the AI Builder model page.
  3. Reinstall the solution containing the model(s).
  4. Wait for the end of the Importing state for each model.

If the problem persists (no new model gets fixed by this sequence), contact the support team.