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This article provides a workaround for an issue where you can't import a solution or install an application due to missing privileges in Microsoft Power Apps.
Applies to: Power Platform, Solutions
Symptoms
When a user tries to import a solution or install an application in the Power Platform admin center, an error message like the following one occurs:
Microsoft.Crm.CrmSecurityException: Principal user (Id=… accessMode=1... (Setup/Stub unlicensed user with filtered privileges from associated roles. Consider assigning License.)), is missing <Component type> privilege ...
Cause
This error occurs for the following reasons:
- The access mode of the user performing the import or installation is set to Administrative instead of Read-Write. Users that don't have a valid Power Platform license will have a default access mode of Administrative.
- The user doesn't have sufficient privileges to import the solution that includes all the components in the solution.
Workaround
To work around this issue, use the following methods:
- If the access mode of the user performing the import or installation is Administrative, update it to Read-Write and assign the user a valid license.
- Review the security roles for the user, and check if the user has Create and Update privileges for all the tables used by the components included in the solution. If not, assign the user a security role that contains these privileges. The System Administrator, System Customizer, and Environment Maker security roles have these privileges.