Troubleshoot issues with Dynamics 365 Sales Professional
Article
Use the following troubleshooting topics to quickly find information to solve your users' issues.
Issue 1 - Can't sign up for a Sales Professional trial
Cause
If your Microsoft 365 tenant administrator has disabled trial sign-up for your organization, you'll see the following error message:
Your IT department has turned off signup for Dynamics 365 Sales Professional Trial. Contact them to complete signup.
There are two ways that the tenant administrator can prevent users from performing self-service sign-up:
Prevent email sign-ups for the tenant by using the AdHocSubscriptionsNotAllowed parameter
Prevent new users to be created within the tenant (NewUsersNotAllowed).
Resolution
Contact your IT department and work with them to help you sign up.
Issue 2 - "Something went wrong building your Sales Pro experience. Do you want to try again?" error occurs when signing up
When you sign up, you receive the following error message:
Something went wrong building your Sales Pro experience. Do you want to try again?
Cause
There are several possible reasons for this error:
You've already signed up for the Sales Professional application for your tenant, and are trying to sign up again by using other credentials for the same tenant before the expiry of the first trial instance.
What is Dynamics 365 Sales Professional and how do I get started? Get started with the basics. See how Dynamics 365 Sales Professional helps you manage customers, work with leads, and manage tasks, appointments, email, and phone calls.
As a Microsoft Dynamics 365 customer experience analyst, you’re responsible for configuring, customizing, and expanding the functionality of Dynamics 365 Sales to create business solutions that support, automate, and accelerate the company's sales process.
Business units group related activities and control access so people can only see the data they need. Follow these steps to create or edit a business unit.
Predefined security roles define permissions and access levels specific to different sales personas. Assign users to appropriate security roles to grant them adequate access to the system.