El propietario no puede crear carpetas públicas modernas mediante Outlook en Exchange Server 2013 o Exchange Server 2016
Síntomas
Supongamos que es el propietario de un buzón de carpeta pública o que tiene permisos de acceso suficientes para crear una carpeta pública en un entorno de Microsoft Exchange Server 2013 o Microsoft Exchange Server 2016. El buzón usa la jerarquía secundaria como buzón de carpeta pública predeterminado. En esta situación, cuando intenta crear una carpeta pública mediante Microsoft Outlook, recibe el siguiente mensaje de error:
No se puede crear la carpeta. No tiene permiso suficiente para realizar esta operación en este objeto. Consulte el contacto de carpeta o el administrador del sistema.
Nota:
Si el buzón de carpeta pública predeterminado se cambia a un buzón de carpeta pública que contiene la jerarquía principal, puede crear carpetas públicas mediante Outlook.
Consulte Más información sobre cómo solucionar el problema en este artículo.
Causa
Este problema se produce porque la entrada del LmCompatibilityLevel
Registro en el rol servidor de buzón de Exchange Server está configurada en un valor menor que 2.
Solución alternativa
Importante
Siga atentamente los pasos de esta sección. La modificación incorrecta del Registro puede producir graves problemas. Antes de modificarlo, realice una copia de seguridad del Registro para efectuar una restauración en caso de que surjan problemas.
Para solucionar este problema, siga estos pasos en el rol Exchange Server servidor de buzón de correo que hospeda el buzón de carpeta pública de la jerarquía secundaria:
Cambie el valor de la entrada del
LmCompatibilityLevel
Registro a 2 o superior.Nota:
La entrada se encuentra en la siguiente ruta de acceso del Registro:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\LsaReinicie los servicios siguientes:
- Microsoft Exchange Information Store
- Acceso de cliente RPC de Microsoft Exchange
- Administrador de mantenimiento de Microsoft Exchange
Más información
Para obtener más información sobre la configuración LmCompatibilityLevel, consulte los artículos siguientes:
Información general sobre la entrada del Registro LmCompatibilityLevel
Más información para solucionar este problema
Cuando se produce este problema, aparte del mensaje de error, también puede encontrar la siguiente información que puede ayudar a solucionar este problema.
El siguiente mensaje se registra en el registro "Acceso de cliente RPC" en Visor de eventos:
Client=MSExchangeRPC,,,,-2147024891 (rop::AccessDenied),00:00:00.0310000,,"RopHandler: CreateFolder: [AccessDeniedException] Cannot open mailbox /o=Contoso/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=9f049c7972fb4d8ebe9f5ece73e136fe-PFHierarchy. -> [MapiExceptionNoAccess] Unable to make connection to the server. (hr=0x80070005, ec=-2147024891) [diag::AAAGAgAA/wAAAAAAAAAAA/gBAACYMvAvAQAAACwQAsAAAAAA6PIAEHA5FpCYP/AvBQAAAG4vYQBwORaQmCHwH/Q1AACYMfAvcDkWkAk00AEsEALAmCnwHw0AAACYOfAfLBACwJgl8B95BQAAmDXwHwAAAACYLfAfAAAAAOjyABBwORaQmD/wLwUAAABuL2EAcDkWkJgh8B/0NQAAmDHwL3A5FpAJNNABkQEAAJgp8B8NAAAAmDnwH5EBAACYJfAfiQUAAJg18B8AAAAAmC3wHwEAAACYIvA/AAAAAFVuYXV0aG9yaXplZAAAAADo8gAQcDkWkJg/8C8FAAAAbi9hAHA5FpCYIfAf9DUAAJgx8C9wORaQCTTQAQAAAACYKfAfDQAAAJg58B8AAAAAmCXwH+ELAACYNfAfAAAAAJgt8B8AAAAA6PIAEHA5FpCYP/AvBQAAAG4vYQBwORaQmCHwH/Q1AACYMfAvcDkWkAk00AHhCwAAmCnwHw0AAACYOfAfAAAAAJgl8B/hCwAAmDXwHwAAAACYLfAfAAAAAHHoQBAFAAeAcMVAIQAPFIQZAPAvBQAAAHDLQBAFAAeA0McAEPQ1AADxzEAQBQAHgKHqABAFAAAA8YNAEAUAB4Cd6QAQBQAAAAfNQBAFAAeAQk0AEAAAAABCbUAQBQAHgEJFABAAAAAAQmVAEAUAB4A=] at M.E.D.S.RPCPrimaryHierarchyProvider.GetHierarchyStore() at M.E.D.S.RPCPrimaryHierarchyProvider.CreateFolder(String folderName, String folderDescription, StoreId parentFolderId, CreateMode mode, Guid& contentMailboxGuid) at M.E.R.H.PublicFolderOperations.<>c__DisplayClass1.<CreateFolder>b__0(StoreId& folderIdToSync, Guid& contentMailboxGuid) at M.E.R.H.PublicFolderOperations.InvokeOnPrimaryHierarchyAndSync[T](Boolean isCompleteSync, PublicLogon publicLogon, PrimaryHierarchy",,,admin@contoso.com,
Si ejecuta el comando "Outlook.Protocol" de Get-ServerHealth -Identity ServerIdParameter -HealthSet en el Shell de administración de Exchange (EMS), el conjunto de mantenimiento de Outlook.Protocol notifica un estado incorrecto, específicamente para los siguientes monitores relacionados con la llamada a RPC de procedimiento remoto de Outlook:
- OutlookRpcDeepTestMonitor
- OutlookRpcSelfTestMonitor
El error del sondeo OutlookRpcDeepTestProbe registra el siguiente mensaje:
Microsoft.Exchange.Rpc.RpcException: Error 0x5 (Access is denied) from ClientAsyncCallState.CheckCompletion: RpcAsyncCompleteCall