Cómo dividir manualmente una base de datos de Access en Microsoft Access

Avanzado: requiere conocimientos expertos de codificación, interoperabilidad y multiusuario.

Este artículo se aplica a un archivo de base de datos de Microsoft Access .mdb o .accdb.

Resumen

Por varias razones, puede decidir dividir la base de datos en una aplicación front-end o una aplicación back-end. La base de datos back-end contiene las tablas y se almacena en un servidor de archivos. La base de datos front-end que se vincula a las tablas back-end contiene todos los formularios, las consultas, los informes, las macros y los módulos. La base de datos front-end se distribuye a las estaciones de trabajo de los usuarios.

En este artículo se describe cómo dividir manualmente la base de datos en lugar de usar la utilidad Database Splitter.

Más información

Para dividir la base de datos en Microsoft Office Access 2003 y en versiones anteriores de Access, siga estos pasos:

  1. Cree una base de datos de Access en blanco.

  2. En el menú Archivo, seleccione Obtener datos externos y, a continuación, haga clic en Importar.

  3. Busque y seleccione la base de datos que desea dividir.

  4. En la pestaña Tablas , haga clic en Seleccionar todoy, a continuación, haga clic en Aceptar.

    Observe que Access importa todas las tablas a la nueva base de datos, que es la base de datos back-end.

  5. Almacene la nueva base de datos back-end en un recurso compartido de red y asegúrese de que todos los usuarios tengan permisos completos para el recurso compartido.

  6. Cree una segunda base de datos de Access en blanco.

  7. En el menú Archivo, seleccione Obtener datos externos y, a continuación, haga clic en Vincular tablas.

  8. Seleccione la base de datos back-end que acaba de crear.

  9. En la pestaña Tablas , haga clic en Seleccionar todo y, a continuación, haga clic en Aceptar.

    Observe que Access vincula las tablas de la base de datos back-end a la base de datos front-end.

  10. En el menú Archivo, seleccione Obtener datos externos y, a continuación, haga clic en Importar.

  11. Seleccione la base de datos original que va a dividir y, a continuación, haga clic en Importar.

  12. En la pestaña Formularios, haga clic en Seleccionar todo. Repita este paso en todas las pestañas excepto en la pestaña Tablas. Dado que ya ha vinculado a las tablas, ahora solo necesita importar el resto de los objetos.

  13. Después de seleccionar todos los objetos excepto las tablas, haga clic en Aceptar.

    Observe que ahora tiene todas las tablas vinculadas y que ha importado los objetos restantes.

Para dividir la base de datos en Microsoft Office Access 2007 o en una versión posterior, siga estos pasos:

  1. Cree una base de datos de Access en blanco.

  2. En la pestaña Datos externos , haga clic en Acceso en el grupo Importar .

  3. En el cuadro de diálogo Obtener datos externos , haga clic en Examinar para buscar y seleccionar la base de datos que desea dividir, haga clic para seleccionar importar tablas, consultas, formularios, informes, macros y módulos en la base de datos actual. y, a continuación, haga clic en Aceptar.

  4. En el cuadro de diálogo Importar objetos , haga clic en Seleccionar todo en la pestaña Tablas y, a continuación, haga clic en Aceptar.

    Observe que Access importa todas las tablas a la nueva base de datos, que es la base de datos back-end.

  5. Almacene la nueva base de datos back-end en un recurso compartido de red y asegúrese de que todos los usuarios tengan permisos completos para el recurso compartido.

  6. Cree una segunda base de datos de Access en blanco.

  7. En Datos externos, haga clic en Acceso en el grupo Importar .

  8. En el cuadro de diálogo Obtener datos externos , haga clic en Examinar para seleccionar la base de datos back-end que creó y haga clic para seleccionar el vínculo al origen de datos mediante la creación de una tabla vinculada. y, a continuación, haga clic en Aceptar.

  9. En el cuadro de diálogo Importar objetos , haga clic en Seleccionar todo en la pestaña Tablas y, a continuación, haga clic en Aceptar.

    Observe que Access vincula las tablas de la base de datos back-end a la base de datos front-end.

  10. En Datos externos, haga clic en Acceso en el grupo Importar .

  11. En el cuadro de diálogo Obtener datos externos , haga clic en Examinar para seleccionar la base de datos original que va a dividir, haga clic para seleccionar importar tablas, consultas, formularios, informes, macros y módulos en la base de datos actual. y, a continuación, haga clic en Aceptar.

  12. En el cuadro de diálogo Importar objetos , haga clic en Seleccionar todo en la pestaña Formularios y repita este paso en todas las demás pestañas excepto en la pestaña Tablas porque ya se ha vinculado a las tablas. Ahora solo necesita importar el resto de los objetos y, a continuación, haga clic en Aceptar.

    Observe que ahora tiene todas las tablas vinculadas y que ha importado los objetos restantes.

Notas

Esta base de datos es la base de datos front-end. Puede distribuir esta base de datos front-end a las estaciones de trabajo para que cada usuario tenga su propia copia de la base de datos front-end.

Ahora ha dividido correctamente la base de datos, lo que mejorará el rendimiento. Ahora, cuando un usuario abre un formulario, el formulario se abre localmente en su equipo y no se envía a través de la red. Los únicos datos que se cruzan en la red son los datos de las tablas vinculadas.

Motivos por los que puede querer dividir la base de datos

A continuación se indican los motivos habituales para dividir una base de datos:

  • Está compartiendo la base de datos con varios usuarios en una red.
  • Tiene varias personas desarrollando en la base de datos y no tiene instalado Microsoft Visual Source Safe.
  • No quiere que los usuarios puedan realizar cambios de diseño en las tablas.

La razón más común para dividir una base de datos es que está compartiendo la base de datos con varios usuarios en una red. Si simplemente almacena la base de datos en un recurso compartido de red, cuando los usuarios abren un formulario, una consulta, una macro, un módulo o un informe, estos objetos deben enviarse a través de la red a cada persona que use la base de datos. Si divide la base de datos, cada usuario tiene su propia copia de los formularios, consultas, macros, módulos e informes. Por lo tanto, los únicos datos que se deben enviar a través de la red son los datos de las tablas.

Nota Para dividir la base de datos, también puede usar la utilidad Database Splitter.