Lista de Autocompletar de Outlook

Número KB original: 2199226

Importante

Exchange Online proporciona algunas características de búsqueda a través de Microsoft Search. A partir de Outlook para Microsoft 365 versión 2202 (compilación 14931.20604), si está conectado a un buzón de Exchange Online, la lista de sugerencias para las líneas To/Cc/Bcc cuando redacta un mensaje se alimenta de Microsoft Search. En este escenario específico, solo se aplican dos secciones de este artículo: "Habilitar la característica Autocompletar" y "Quitar entradas de lista de Autocompletar de uno en uno".

Microsoft Outlook mantiene la lista Autocompletar. La lista se utiliza tanto en la característica de comprobación automática de nombres como en la de finalización automática. La lista Autocompletar, también conocida como caché de alias, se genera automáticamente al enviar mensajes de correo electrónico desde Outlook. La lista contiene direcciones SMTP, entradas de LegacyExchangeDN y nombres para mostrar de personas a las que envió correos electrónicos anteriormente.

Nota: La lista Autocompletar para Outlook es específica de Outlook y no se comparte con Outlook en la Web. Esta aplicación mantiene su propia lista de Autocompletar.

Número limitado de entradas

Outlook limita el número de entradas que puede guardar en la lista de Autocompletar. Tras alcanzar este límite, Outlook usa un algoritmo interno para determinar qué nombres deberían quitarse de la lista. Lo hace en función del proceso de ponderación de uso. Por lo tanto, es posible que encuentre que algunos nombres se quitan inesperadamente de la caché de alias. Para evitar esta situación, puede usar los siguientes enfoques generales:

  1. Puede quitar proactivamente de la lista de Autocompletar las entradas que ya no necesite. Este es el enfoque preferido. Para obtener información sobre cómo hacerlo, vea Quitar entradas de lista autocompletar de uno en uno.
  2. Puede incrementar el límite de la caché de alias. Dado que esta configuración no está probada, no se recomienda. Si una caché de alias grande se daña, será inutilizable y podría perder muchas entradas almacenadas en caché. Para obtener información sobre cómo aumentar el límite, vea Cambiar el límite de la lista Autocompletar.

Los límites son los siguientes:

  • Outlook 2019: 1000 entradas
  • Outlook 2016: 1000 entradas
  • Outlook 2013: 1000 entradas
  • Outlook 2010: 1000 entradas

Habilitación de la característica Autocompletar

Para obtener acceso a la configuración de Autocompletar, haga lo siguiente:

  1. En el menú Archivo, seleccione Opciones.

  2. Seleccione la pestaña Correo.

  3. Desplácese hasta, aproximadamente, la mitad, hasta que vea Enviar mensajes. Asegúrese de que la casilla Usar lista de Autocompletar para sugerir nombres al escribir en las líneas Para, CC y CCO esté activada.

    Captura de pantalla de la ventana Enviar mensajes y la opción Usar lista de autocompletar para sugerir nombres al escribir en el cuadro Líneas para, Cc y CCO está activada.

Copia de la lista autocompletar

Microsoft Office Outlook 2007 y versiones anteriores almacenan la lista de Autocompletar en un archivo de alias (.nk2) en el disco. Outlook 2021, 2019, 2016, 2013 y 2010 almacenan la lista autocompletar como un mensaje oculto en el almacén de mensajes principal. También permiten la importación de los archivos .nk2 más antiguos.

Para ver los pasos detallados para copiar la lista Autocompletar y copiar e importar un archivo .nk2, consulte Importación o copia de la lista autocompletar en otro equipo.

Eliminación de entradas de lista autocompletar de uno en uno

Siga estos pasos:

  1. Abra un nuevo mensaje de correo electrónico.
  2. Escriba los primeros caracteres de la entrada de Autocompletar que quiera quitar.
  3. Cuando aparezca la entrada en la lista de nombres sugeridos, pase el puntero del ratón sobre el nombre hasta que aparezca resaltado, pero no haga clic en él.
  4. Cuando aparezca el icono "X" junto al nombre resaltado, haga clic en X para quitar la entrada de la lista o pulse la tecla Supr en el teclado.

La selección de X impedirá que esa entrada de nombre vuelva a aparecer en la lista autocompletar, pero no la quitará de su cuenta. Esta entrada todavía puede aparecer en otras áreas de Outlook (como cuadros de búsqueda).

Nota: Si envías a una persona un nuevo correo electrónico después de quitar su nombre de la lista autocompletar, su información se restaurará en la lista.

Borrar la lista autocompletar

Use uno de los dos métodos siguientes para eliminar de lista de Autocompletar.

Método 1

  1. Abra Outlook.

  2. En la pestaña Archivo, seleccione Opciones.

  3. Seleccione la pestaña Correo.

  4. En Enviar mensajes, haga clic en Vaciar lista de Autocompletar.

    Captura de pantalla de la ventana Opciones de Outlook que muestra el botón Lista de autocompletar vacía.

  5. Seleccione .

Método 2

Inicie Outlook con el modificador /CleanAutoCompleteCache.

  1. Haga clic en Inicio y, a continuación, en Ejecutar.
  2. Escriba Outlook.exe /CleanAutoCompleteCache.

Nota: Si Outlook no está instalado en la ubicación predeterminada, debe apuntar a la ruta de acceso de Outlook.exe.

Problemas conocidos en la caché de Autocompletar

La caché de Autocompletar puede dañarse con el tiempo y es posible que no guarde nuevas entradas. Si esto ocurre, puede intentar quitar las entradas de lista autocompletar de uno en uno. Si eso no resuelve el problema, borre la lista Autocompletar".

Cambiar el límite de la lista autocompletar

Dado que esta configuración no está probada, no se recomienda. Si una caché de alias grande se daña, será inutilizable y podría perder muchas entradas almacenadas en caché. Use esta información con precaución.

Importante

Esta sección, método o tarea contiene pasos que le indican cómo modificar el Registro. No obstante, pueden producirse problemas graves si modifica el registro de manera incorrecta. En consecuencia, asegúrese de seguir estos pasos cuidadosamente. Para mayor protección, cree una copia de seguridad del registro antes de modificarlo. Después, puede restaurar el registro si se produce un problema. Para obtener más información sobre cómo hacer una copia de seguridad del Registro y cómo restaurarlo, consulte Hacer una copia de seguridad del Registro y restaurarlo en Windows.

  1. Cierre Outlook.

  2. Inicie el Editor del Registro.

    • En Windows 8. x, presione la tecla del logotipo de Windows, escriba regedit y presione Entrar.
    • En Windows 7 y Windows Vista, haga clic en Inicio, escriba regedit en el cuadro Iniciar búsqueda y, luego, pulse Entrar.
  3. Busque la siguiente subclave del Registro y selecciónela:
    HKEY_CURRENT_USER\Software\Microsoft\Office\<x.0>\Outlook\AutoNameCheck

    Nota: El marcador de posición <x.0> de esta subclave del Registro representa la versión de Microsoft Office. Use el valor adecuado de la lista siguiente.

    • Outlook 2021 = 16.0
    • Outlook 2019: 16.0
    • Outlook 2016: 16.0
    • Outlook 2013: 15.0
    • Outlook 2010: 14.0
  4. En el menú Edición, seleccione Nuevo y, después, Valor DWORD.

  5. Escriba MaxNickNames y presione Entrar.

  6. En el menú Edición, seleccione Modificar.

  7. Escriba el valor nuevo del límite y, luego, haga clic en Aceptar.

    Nota:

    • Asegúrese de escribir el número en formato decimal. Esa es la manera correcta de escribir el número.
    • Para probar el nuevo límite, intente aumentar el límite solo en una pequeña cantidad. Por ejemplo, para crear un aumento del 20 por ciento en el límite en Outlook 2013, especificaría 1200 para el MaxNickNames valor.
  8. Salga del Editor del Registro.

  9. Inicie Outlook.

Nota: El MaxNickNames valor del Registro especifica solo el límite no predeterminado. Por tanto, también puede usar este valor para disminuir el límite de la caché de alias.