Recibe errores de memoria insuficientes al expandir un buzón de correo o una carpeta pública en Outlook

Número de KB original: 2968387

Síntomas

Al expandir un buzón de correo o una carpeta pública (excepto la Bandeja de entrada) en Microsoft Outlook o seleccionar Libreta de direcciones en la barra de herramientas, puede recibir uno de los siguientes errores:

No se puede mostrar la carpeta. No hay suficiente memoria libre para ejecutar este programa. Salga de uno o varios programas y vuelva a intentarlo.

No se puede expandir la carpeta. No hay suficiente memoria disponible para realizar la operación.

No se pudo acceder a la lista de direcciones. Necesita más recursos de memoria o del sistema. Cierre algunas ventanas e inténtelo de nuevo.

Cuando recibe uno de estos errores, es posible que el correo saliente se bloquee en la carpeta Bandeja de salida y no se envíe hasta que reinicie Outlook.

Causa

Este problema se produce cuando el perfil de mensajería de Outlook incluye una cuenta de Microsoft Exchange configurada para usar el modo de intercambio en caché, la opción Descargar favoritos de carpetas públicas está habilitada y tiene muchas carpetas públicas almacenadas en caché. Normalmente, este problema se produce cuando tiene más de 1000 carpetas públicas aproximadamente, o cuando las carpetas públicas almacenadas en caché consumen un gigabyte de espacio.

Solución

Para evitar este problema, deshabilite la opción Descargar favoritos de carpetas públicas o mantenga el número de favoritos de carpetas públicas almacenadas en caché en menos de 1000. Si el problema continúa ocurriendo con menos de 1000 favoritos de carpetas públicas, reduzca el número de carpetas hasta que deje de recibir el error o los errores. Normalmente, puede reducir el número de favoritos de carpetas públicas eliminándolos mediante el cliente de Outlook. Sin embargo, en algunos casos en los que tiene demasiados favoritos de carpetas públicas, es posible que no pueda eliminar las carpetas mediante el cliente de Outlook porque el error se produce al seleccionar la carpeta pública Favoritos. Si esto ocurre, puede eliminar los favoritos de carpetas públicas mediante MFCMapi en su lugar.

Para resolver este problema deshabilitando la opción Descargar favoritos de carpetas públicas , siga estos pasos:

  1. En Outlook, seleccione Archivo, Configuración de la cuenta y, a continuación, Configuración de la cuenta.

  2. Seleccione su cuenta de Microsoft Exchange y, a continuación, seleccione Cambiar.

  3. Seleccione Más ajustes.

  4. En la pestaña Opciones avanzadas , desactive la casilla Descargar favoritos de carpetas públicas .

  5. Seleccione Aceptar.

  6. Se le pedirá que reinicie Outlook para que estos cambios surtan efecto. Seleccione Aceptar.

  7. Seleccione Siguiente, seleccione Finalizar y, a continuación, seleccione Cerrar.

  8. Salga de Outlook y reinicie Outlook.

Para eliminar los favoritos de carpetas públicas mediante MFCMapi, siga estos pasos:

  1. Descargue MFCMAPI.

  2. Ejecute MFCMAPI.exe.

  3. En el menú Session, haga clic en Logon.

  4. Seleccione el nombre del perfil de Outlook y, a continuación, seleccione Aceptar.

  5. En el panel superior, localice la línea que corresponde a su buzón y, a continuación, haga doble clic en ella.

  6. En el panel de navegación (panel izquierdo), expanda Raíz - Buzón y, a continuación, seleccione la carpeta Accesos directos.

  7. En el panel de detalles (panel derecho), busque las propiedades PR_FOLDER_CHILD_COUNT. La columna Valor contiene el número de favoritos de carpetas públicas.

  8. Si desea eliminar todos los favoritos de carpetas públicas, siga estos pasos:

    1. En el panel de navegación. Haga clic con el botón derecho en la carpeta Accesos directos, seleccione Avanzadas y, a continuación, seleccione Elementos vacíos y subcarpetas de la carpeta.

      Captura de pantalla de la opción Elementos vacíos y subcarpetas de la carpeta en el menú contextual.

    2. Mantenga las opciones predeterminadas y, a continuación, seleccione Aceptar.

  9. Si desea eliminar favoritos de carpetas públicas específicas, siga estos pasos:

    1. En el panel de navegación, expanda la carpeta Accesos directos, haga clic con el botón derecho en el favorito carpeta pública que desea eliminar y seleccione Eliminar carpeta.

      Captura de pantalla de la opción Eliminar carpeta en el menú contextual.

    2. Mantenga las opciones predeterminadas y, a continuación, seleccione Aceptar.