No se puede conectar al mensaje de Exchange que aparece al usar la aplicación Microsoft Dynamics 365 para Outlook

En este artículo se proporcionan soluciones para el problema por el que recibe un mensaje No se puede conectar a Exchange cuando se usa La aplicación de Microsoft Dynamics 365 para Outlook.

Se aplica a: Microsoft Dynamics 365 Customer Engagement Online
Número de KB original: 4534356

Síntomas

Al usar Microsoft Dynamics 365 App for Outlook, verá el siguiente mensaje:

"No se puede conectar a Exchange".

El resto de la aplicación puede cargarse correctamente, pero puede que falte la capacidad de realizar un seguimiento de los elementos y usar Establecer con relación.

Causa

Esto suele ocurrir cuando se usa un buzón local de Microsoft Exchange y puede deberse a uno de los siguientes motivos:

Causa 1: La autenticación de OAuth no está habilitada en Exchange.
Causa 2: Hay un problema con el certificado de autenticación usado por Exchange.

Resolución 1: Comprobar que la autenticación de OAuth está habilitada en Exchange

  1. En el servidor exchange, abra el Shell de administración de Exchange.

  2. Ejecute el comando siguiente:

    Get-WebServicesVirtualDirectory | FL server,*auth
    
  3. Compruebe que los resultados devueltos muestran que OAuthAthentication está establecido en True.

  4. Si OAuthAthentication se establece en False, es necesario ejecutar un comando como el siguiente:

    Set-WebServicesVirtualDirectory -Identity "EWS (Default Web Site)" -OAuthAuthentication $true
    

    El valor de identificación es el nombre del directorio virtual que se puede encontrar en el Centro de exchange Administración seleccionando servidores y, a continuación, seleccionando directorios virtuales o ejecutando el siguiente comando y revisando el valor Nombre devuelto:

    Get-WebServicesVirtualDirectory | FL
    

    Puede encontrar más información sobre este comando en Set-WebServicesVirtualDirectory.

    Para obtener más información sobre los requisitos de autenticación para permitir que un complemento de Outlook realice solicitudes asincrónicas de Exchange Web Service (EWS), vea Consideraciones de autenticación y permisos para makeEwsRequestAsync.

  5. Ejecute el comando siguiente:

    Get-OrganizationConfig | FL OAuth2ClientProfileEnabled
    

    Si el valor devuelto es False, ejecute el siguiente comando:

    Set-OrganizationConfig -OAuth2ClientProfileEnabled:$True
    
  6. Compruebe también que la versión de Exchange tiene la actualización mencionada en No se puede acceder a EWS desde complementos de Outlook/OWA a través de makeEwsRequestAsync en Exchange Server 2016 y Exchange Server 2013.

Resolución 2: Comprobación del certificado de Exchange

  1. En el servidor exchange, abra el Shell de administración de Exchange.

  2. Ejecute el comando siguiente:

    Get-AuthConfig | FL

  3. Compruebe que los resultados muestran IsValid como True.

  4. Copie el valor devuelto para CurrentCertificateThumbprint y úselo en el siguiente comando:

    Get-ExchangeCertificate -Thumbprint <CurrentCertificateThumbprint Value>| FL
    
  5. Compruebe que los resultados muestran lo siguiente:

    Status = Valid

    La fecha actual está dentro de las fechas NotAfter y NotBefore que indican que el certificado no ha expirado.

    Si el comando anterior no recupera correctamente el certificado, esto indica un problema con la configuración del certificado que puede requerir que cree y configure un nuevo certificado. A continuación se muestran algunos recursos con pasos para crear y configurar un certificado nuevo:

Si se requiere algún cambio después de seguir los pasos anteriores, cierre y vuelva a abrir Outlook para ver si el problema se ha resuelto. Si el problema persiste y el administrador de Microsoft Exchange ha comprobado que OAuth está habilitado y el certificado es válido, es posible que sea necesario ponerse en contacto con Soporte técnico de Microsoft.