Las citas, los contactos y las tareas no se pueden sincronizar para el buzón porque el usuario del buzón no tiene permisos suficientes en este buzón.
En este artículo se proporciona una solución a un error que se produce al intentar probar y habilitar un buzón en Dynamics 365.
Se aplica a: Microsoft Dynamics 365
Número de KB original: 4052824
Síntomas
Al intentar probar y habilitar un buzón en Dynamics 365, se registra la siguiente alerta:
"Las citas, los contactos y las tareas no se pueden sincronizar para el nombre> del buzón de correo <porque el usuario del buzón no tiene permisos suficientes en este buzón.
Email Código de error del servidor: Crm.80048306.No hay suficiente privilegio para acceder al objeto de Microsoft Dynamics 365 o realizar la operación solicitada".
Si selecciona ver los detalles, se muestran los siguientes detalles adicionales:
"T:195
ActivityId: <GUID>
>Excepción : Excepción no controlada: Microsoft.Crm.CrmSecurityException: Error de SecLib::AccessCheckEx. Se devuelve hr = -2147187962, ObjectID: <GUID>, OwnerId: <GUID>, OwnerIdType: 8 y CallingUser: <GUID>. ObjectTypeCode: 4120, objectBusinessUnitId: <GUID>, AccessRights: WriteAccess at Microsoft.Crm.BusinessEntities.SecurityLibrary.AccessCheckEx2(ExecutionContext context, SecurityPrincipal principal, SecurityPrincipal ownerPrincipal, Guid objectId, Int32 objectTypeCode, Guid objectBusinessUnitId, AccessRights rights) en Microsoft.Crm.Asynchronous.EmailConnector.ExchangeSyncUtility.HasExchangeSyncIdMappingAccess(Guid userId, Int32 userIdTypeCode, IACTProviderContextContextCode, IACTProviderContext orgContext) en Microsoft.Crm.Asynchronous.EmailConnector.ExchangeSyncWorker.PerformPreMailboxSyncChecks() en Microsoft.Crm.Asynchronous.EmailConnector.ExchangeS..."
Causa
El usuario de Dynamics 365 asociado al buzón no tiene privilegios suficientes. A menudo se debe a que el usuario no tiene asignado un rol de seguridad o a su rol de seguridad le falta acceso de lectura o escritura en el nivel de usuario a la entidad Mailbox.
Importante
Compruebe que el propietario del registro de buzón es el mismo que el usuario. Ejemplo: si el buzón es un buzón de usuario para Paul Cannon, compruebe el valor Propietario dentro del registro de buzón para que Paul Cannon se muestre como Paul Cannon. Si es otro usuario, es posible que ese usuario no tenga acceso al buzón de este usuario.
Solución
Para resolver este problema, siga estos pasos:
- Como usuario con el rol Administrador del sistema, abra el registro de buzón en Dynamics 365.
Nota:
La alerta incluye un vínculo al registro de buzón de correo.
- Compruebe que el campo Propietario del formulario de buzón se rellena con el nombre del usuario. Si aparece algún otro usuario, cámbielo para que sea el mismo que este usuario.
- Seleccione el vínculo dentro del campo Propietario para abrir el registro de usuario del usuario propietario.
- Seleccione Administrar roles para ver qué roles de seguridad se asignan a este usuario.
- Vaya a Configuración, seleccione Seguridad y, a continuación, seleccione Roles de seguridad.
- Abra los roles que se encuentran en el paso 4. Consulte Error de privilegio denegado al usar la sincronización de Server-Side para obtener una lista de los privilegios necesarios y comprobar que el rol de seguridad del usuario contiene estos privilegios.
- Después de comprobar que el usuario es el propietario de su registro de buzón de correo y su rol de seguridad contiene los privilegios necesarios, vuelva a seleccionar el botón Probar & habilitar buzón dentro de su registro de buzón. Si la prueba no resulta correcta, revise el mensaje que aparece en la sección Alertas.
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