La consulta Balance in Item Stock (Balance in Item Stock Inquiry) es incorrecta en Microsoft Dynamics GP

En este artículo se proporciona una solución a un problema en el que el campo Saldo de la línea superior de la ventana Consulta de existencias de artículos no se suma a la cantidad de la transacción.

Se aplica a: Microsoft Dynamics GP
Número de KB original: 2647425

Síntomas

En Microsoft Dynamics GP, al revisar las cantidades de un artículo en la ventana Consulta de existencias de artículos, el campo Saldo de la primera línea transaccional no es igual a la cantidad de esa transacción. Por ejemplo, la primera transacción mostrada es un ajuste de aumento para una cantidad de 5, pero el campo Saldo muestra 3.

Causa

Hay muchas cosas que harán que el campo Saldo de la ventana Consulta de existencias de artículos sea incorrecto.

  1. El stock total en la parte inferior de la ventana es incorrecto. Consulte resolución 1.

  2. La casilla Mantener historial - Transacción no se ha marcado de forma coherente para el elemento en Opciones de mantenimiento de elementos. Consulte resolución 2.

  3. Las transacciones históricas se quitaron para este elemento mediante la ventana Quitar historial de transacciones de inventario. Consulte resolución 2.

  4. Una interrupción durante la contabilización hizo que el IV30300 no se actualizara o actualizara incorrectamente. Consulte resolución 2.

  5. Se ha cambiado la unidad de medida equivalente para este elemento. Consulte resolución 3.

  6. Es un artículo numerado serializado o de lote y las cantidades se invalidaron para vender mercancías que no estaban en el inventario. Por ejemplo, vendió 10 de un artículo cuando tenía 0 a mano. Consulte resolución 4.

Solución 1

Para corregir el stock total en la parte inferior de la ventana, ejecute Conciliar inventario. Para ejecutar Conciliación de inventario en la ventana Microsoft Dynamics GP, seleccione Herramientas, Utilidades, Inventario y, a continuación, seleccione Conciliar. Inserte el elemento que está revisando en la ventana Consulta y seleccione Procesar.

Solución 2

Si faltan transacciones históricas o están incompletas, la ventana Consulta de existencias de artículos no será confiable para este artículo y es posible que tenga que interrumpir su uso. Si no es deseable, es posible que desee volver a empezar con el elemento. Para ello, estos son los pasos recomendados.

  1. Si hay cantidades que no están a mano, escriba y publique transacciones de transferencia de inventario para moverlas al depósito de cantidad a mano.

  2. Nota:

    Cantidad actual a mano para el artículo y, a continuación, escriba y publique una transacción de reducción de inventario para llevar esa cantidad a 0.

  3. Use Quitar historial de transacciones de inventario para quitar todo el historial transaccional de este elemento.

  4. En este momento, la ventana Consulta de existencias de artículos tendrá 0 Total Stock y 0 cantidad Saldo. Compruebe que la casilla Mantener historial - Transacción está marcada en la ventana Opciones de mantenimiento de elementos para mantener esta información en el futuro.

  5. Escriba una transacción de ajuste de inventario de aumento para hacer que la cantidad disponible vuelva a ser la que debe ser.

    La ventana Consulta de existencias de artículos ahora será correcta.

    Nota:

    Puede ser posible manipular los datos del back-end mediante SQL para corregir esta ventana.

    Clientes:
    Para obtener más información sobre los servicios de consultoría de manipulación de datos, póngase en contacto con su asociado de registro Si no tiene un asociado de registro, visite Microsoft Pinpoint para identificar a un asociado.

    Socios:
    Para obtener más información sobre los servicios de consultoría de manipulación de datos, póngase en contacto con Los servicios de asesoramiento de Microsoft en 800-MPN-SOLVE.

Resolución 3

Si se han cambiado unidades de medida equivalentes, la ventana Consulta de existencias de artículos no será confiable para este artículo y es posible que tenga que detener su uso. Si no es deseable, es posible que desee volver a empezar con el elemento. Consulte los pasos de la Resolución 2 para ver los pasos recomendados para hacerlo.

Resolución 4

Teniendo en cuenta que al invalidar un artículo numerado serializado o de lote, la cantidad a mano no es negativa, la venta de esos 10 dejó la cantidad disponible en 0. Cuando ha traído la cantidad en (supongamos 10), que ha aumentado la cantidad disponible en lugar de consumir la invalidación. Ahora su cantidad a mano se supera por los 10 que ha superado. Para corregirlo y la ventana Consulta de existencias de artículos, siga estos pasos:

  1. Escriba y publique una transacción de reducción para sacar esos 10 del inventario, de modo que la cantidad disponible ahora sea correcta. Normalmente, la disminución no se contabilizaría en General Ledger.

  2. Use Quitar historial de transacciones para quitar la transacción realizada en el paso A del historial de inventario. En la ventana Quitar historial de transacciones de inventario, elija Número de documento en el intervalo e inserte el número de documento de la transacción en el paso A. Proceso.

La ventana Consulta de existencias de artículos y la cantidad a mano ahora serán correctas.

Más información

La columna Balance de esta ventana se calcula a partir de la cantidad en el campo Stock total de la parte inferior. Se calcula a partir de los campos de cantidad de la tabla IV00102 (maestro de cantidad de artículos). Por lo tanto, si estas cantidades son incorrectas, el stock total también será incorrecto. Esto significa que es probable que el saldo calculado también sea incorrecto.

Una vez que se determina el número total de existencias, agregamos todas las transacciones que reducen la cantidad del artículo y RESTAMOS las transacciones que aumentan la cantidad que funciona desde la parte inferior de la ventana hasta la parte superior para determinar lo que se muestra en el campo Saldo. Las transacciones que se usan se almacenan en la tabla IV30300 (Historial de importes de transacción de inventario).

Para determinar si faltan u otras transacciones en la tabla IV30300 que causan discrepancias para el artículo, compare las entradas de iv30300 con los recibos de la tabla IV10200 (Trabajo de recibos de inventario). Compare también las transacciones de disminución de IV30300 con las salidas de la tabla IV10201 (Detalle de recibos de compra de inventario).