Solución de problemas de error de credenciales no válidas en el flujo de escritorio mediante la cuenta de AAD
En este artículo se proporciona una resolución para solucionar los errores de InvalidConnectionCredentials o WindowsIdentityIncorrect al ejecutar el flujo de interfaz de usuario.
Se aplica a: Power Automate
Número de KB original: 4555623
Síntomas
Un flujo que se ejecutó con una cuenta de AAD produce un error con los códigos de error InvalidConnectionCredentials o WindowsIdentityIncorrect .
Causa
Hay muchas razones por las que puede recibir este error al usar una cuenta de AAD:
- Es posible que las credenciales de cuenta especificadas en la conexión no coincidan con las del equipo.
- Es posible que el dispositivo no esté unido a AAD (o unido a AAD híbrido) para admitir la autenticación de AAD.
- Es posible que la cuenta de AAD no se sincronice con la máquina.
Solución
En primer lugar, asegúrese de que el dispositivo está unido a AAD o unido a un dominio:
- Abra un símbolo del sistema.
- Ejecute el comando
dsregcmd /status
. - Compruebe la sección Estado del dispositivo.
Asegúrese de que uno de los DomainJoined
valores o AzureAdJoined
es SÍ.
Si no es así, no se puede usar una cuenta de AAD a menos que el dispositivo esté unido, consulte la documentación de Microsoft sobre cómo unirse a un dispositivo.
En segundo lugar, identifique la cuenta de AAD que se usará en la configuración del equipo:
- Abra Configuración y seleccione Cuentas.
- Seleccione Access work or school (Acceder a trabajo o escuela).
- Asegúrese de que ve texto que dice algo parecido a Conectado a <your_organization> Azure AD. La cuenta por la que dice que está conectada se puede usar en la conexión.
En tercer lugar, sincronice la cuenta de AAD en el dispositivo. Para hacerlo:
- Seleccione el botón Información al seleccionar la conexión de Azure AD en la pantalla Acceso profesional o educativo .
- Se abrirá una pantalla que describe la información de conexión y el estado de sincronización del dispositivo. Al final, habrá un botón Sincronizar , seleccione este botón y espere a que se complete este proceso.
En cuarto lugar, compruebe que la cuenta de AAD configurada puede iniciar sesión en el dispositivo:
- Intente iniciar sesión en el equipo con la cuenta de AAD identificada en el paso anterior.
- El inicio de sesión del dispositivo debe ser correcto para poder usarse en una conexión.
Por último, asegúrese de que el flujo está configurado correctamente con el nombre de usuario y la contraseña correctos. Esto coincide mucho con la cuenta en el equipo.