Instalación de la CLI de Azure en Linux

La CLI de Azure es una herramienta de línea de comandos multiplataforma que se puede instalar localmente en equipos Linux. Puede usar la CLI de Azure en Linux para conectarse a Azure y ejecutar comandos administrativos en recursos de Azure. La CLI de Azure en Linux permite la ejecución de diversos comandos mediante un terminal con mensajes de la línea de comandos interactivos o un script. Cuando lo tenga todo listo para instalar la CLI de Azure en Linux, se recomienda usar el administrador de paquetes de una distribución de Linux. Seleccione el administrador de paquetes adecuado para su distribución entre las opciones anteriores. Si no tiene uno de los administradores de paquetes enumerados, puede instalar manualmente la CLI de Azure en Linux; para ello, seleccione la opción Script de instalación.

La versión actual de la CLI de Azure es la 2.44.1. Para más información sobre la versión más reciente, consulte las notas de la versión. Para averiguar la versión instalada y ver si tiene que actualizar, ejecute az version.

Información general

En el caso de las distribuciones de Linux con dnf, como RHEL 8/9 o CentOS Stream 8/9, hay paquetes RPM para la CLI de Azure.

Advertencia

A partir de la CLI de Azure 2.39.0 (publicada el 2 de agosto de 2022), no se publicarán paquetes RPM para RHEL 7 y CentOS 7. Puede seguir usando las versiones históricas de la CLI de Azure en estos sistemas, pero no habrá actualizaciones ni correcciones de errores. Considere la posibilidad de actualizar a versiones más recientes de RHEL o CentOS para usar la última versión de la CLI de Azure.

La versión actual de la CLI de Azure es la 2.44.1. Para más información sobre la versión más reciente, consulte las notas de la versión. Para averiguar la versión instalada y ver si tiene que actualizar, ejecute az version.

Importante

El paquete RPM de la CLI de Azure depende del paquete python3. En su sistema, esta puede ser una versión de Python anterior al requisito de Python 3.6.x. Si esto le afecta, busque un paquete python3 de reemplazo.

Tenga en cuenta que Python 2 ha llegado al final de su ciclo de vida (EOL) el 1 de enero de 2020 y dejará de recibir actualizaciones. La CLI de Azure ha dejado de ser compatible con Python 2.7 a partir de versión 2.1.0. Las nuevas versiones ya no garantizan su ejecución correcta con Python 2.7.

Nota

Use el Administrador de paquetes yum si trabaja con sistemas Linux que no son compatibles con el Administrador de paquetes dnf.

Instalar

  1. Importe la clave del repositorio de Microsoft.

    sudo rpm --import https://packages.microsoft.com/keys/microsoft.asc
    
  2. Para RHEL 9 o CentOS Stream 9, agregue el repositorio packages-microsoft-com-prod:

    sudo dnf install -y https://packages.microsoft.com/config/rhel/9.0/packages-microsoft-prod.rpm
    

    Para RHEL 8 o CentOS Stream 8, agregue el repositorio packages-microsoft-com-prod:

    sudo dnf install -y https://packages.microsoft.com/config/rhel/8/packages-microsoft-prod.rpm
    

    Para RHEL 7 o CentOS 7, agregue el repositorio azure-cli:

    echo -e "[azure-cli]
    name=Azure CLI
    baseurl=https://packages.microsoft.com/yumrepos/azure-cli
    enabled=1
    gpgcheck=1
    gpgkey=https://packages.microsoft.com/keys/microsoft.asc" | sudo tee /etc/yum.repos.d/azure-cli.repo
    
  3. Realice la instalación con el comando dnf install.

    sudo dnf install azure-cli
    

Instalación de una versión concreta

Primero debe configurar la información del repositorio azure-cli como se mostró anteriormente. Las versiones disponibles se pueden encontrar en las notas de la versión de la CLI de Azure.

  1. Para ver las versiones disponibles con el comando:

    dnf list --showduplicates azure-cli
    
  2. Para instalar una versión concreta:

    sudo dnf install azure-cli-<version>-1.el7
    

Solución de problemas

Estos son algunos problemas comunes que se han observado cuando se instala con dnf. Si tiene algún problema que no se trata aquí, abra una incidencia en GitHub.

Instalación en RHEL 7.6 u otros sistemas sin Python 3

Si es posible, actualice el sistema a una versión con soporte técnico oficial del paquete python 3.6+. En caso contrario, debe instalar primero el paquete de python3 y, a continuación, instalar la CLI de Azure sin dependencias.

Puede usar el siguiente comando para instalar la CLI de Azure con python 3.6 compilado desde el código fuente:

curl -sL https://azurecliprod.blob.core.windows.net/rhel7_6_install.sh | sudo bash

También puede hacerlo paso a paso:

En primer lugar, la CLI de Azure requiere SSL 1.1+ y debe compilar openssl 1.1 desde el código fuente antes de compilar python3:

sudo dnf install gcc gcc-c++ make ncurses patch wget tar zlib zlib-devel -y
# build openssl from source
cd ~
wget https://www.openssl.org/source/openssl-1.1.1d.tar.gz
tar -xzf openssl-1.1.1d.tar.gz
cd openssl-1.1.1d
./config --prefix=/usr/local/ssl --openssldir=/usr/local/ssl
make
sudo make install
# configure shared object lookup directory so that libssl.so.1.1 can be found
echo "/usr/local/ssl/lib" | sudo tee /etc/ld.so.conf.d/openssl-1.1.1d.conf
# reload config
sudo ldconfig -v

A continuación, compile Python 3 desde el código fuente:

PYTHON_VERSION="3.6.9"
PYTHON_SRC_DIR=$(mktemp -d)
wget -qO- https://www.python.org/ftp/python/$PYTHON_VERSION/Python-$PYTHON_VERSION.tgz | tar -xz -C "$PYTHON_SRC_DIR"
cd $PYTHON_SRC_DIR/Python-$PYTHON_VERSION
./configure --prefix=/usr --with-openssl=/usr/local/ssl
make
sudo make install

Finalmente, siga los pasos 1 a 2 de las instrucciones de instalación para agregar el repositorio de la CLI de Azure. Ahora puede descargar el paquete e instalarlo sin dependencias.

Nota

Si no tiene instalado el complemento de descarga de dnf, se producirá un error de comando no encontrado al ejecutar el código siguiente. Use dnf install 'dnf-command(download)' para instalar el complemento de descarga de dnf.

sudo dnf download azure-cli
sudo rpm -ivh --nodeps azure-cli-*.rpm

Como alternativa, también puede instalar Python 3 mediante algún repositorio adicional. Según este procedimiento, si ha configurado python3 pero sigue recibiendo el error python3: command not found al intentar ejecutar la CLI, tiene que agregarlo a la ruta de acceso.

scl enable rh-python36 bash

El servidor proxy bloquea la conexión

Si no puede conectarse a un recurso externo debido a un servidor proxy, asegúrese de que ha configurado correctamente las variables HTTP_PROXY y HTTPS_PROXY en el shell. Deberá ponerse en contacto con el administrador del sistema para saber qué hosts y puertos se van a usar para estos servidores proxy.

Estos valores se respetan en muchos programas de Linux, incluidos los que se usan en el proceso de instalación. Para establecer estos valores:

# No auth
export HTTP_PROXY=http://[proxy]:[port]
export HTTPS_PROXY=https://[proxy]:[port]

# Basic auth
export HTTP_PROXY=http://[username]:[password]@[proxy]:[port]
export HTTPS_PROXY=https://[username]:[password]@[proxy]:[port]

Importante

Si está detrás de un servidor proxy, estas variables de Shell deben establecerse para conectarse a los servicios de Azure con la CLI. Si no utiliza autenticación básica, se recomienda exportar estas variables en su archivo .bashrc. Siga siempre las directivas de seguridad de su empresa y los requisitos del administrador del sistema.

También puede configurar explícitamente dnf para usar este servidor proxy en todo momento. Asegúrese de que las líneas siguientes aparecen en la sección [main] de /etc/dnf/dnf.conf:

[main]
# ...
proxy=http://[proxy]:[port] # If your proxy requires https, change http->https
proxy_username=[username] # Only required for basic auth
proxy_password=[password] # Only required for basic auth

Para obtener la clave de firma de Microsoft y obtener el paquete de nuestro repositorio, el servidor proxy debe permitir las conexiones HTTPS a la siguiente dirección:

  • https://packages.microsoft.com

Se produce un error en la CLI al instalar o ejecutar en el subsistema de Windows para Linux

Como el subsistema de Windows para Linux (WSL) es una capa de traducción de llamadas del sistema que se ejecuta en la plataforma Windows, es posible que experimente un error al intentar instalar o ejecutar en la CLI de Azure. La CLI se basa en algunas características que podrían producir un error en WSL. Si experimenta un error, independientemente de cómo instale la CLI, es muy probable que se trate de un problema de WSL y no del proceso de instalación de la CLI.

Para solucionar los problemas de instalación de WSL:

  • Si puede, ejecute un proceso de instalación idéntico en una máquina Linux para ver si se realiza correctamente. Si es así, su problema seguramente está relacionado con WSL. Para iniciar una máquina virtual Linux en Azure, consulte Creación de una máquina virtual Linux en Azure Portal.
  • Asegúrese de que usa la versión más reciente de WSL. Para obtener la última versión, actualice su instalación de Windows 10.
  • Consulte los problemas abiertos con WSL que pudieran resolver el problema. Suele haber sugerencias sobre cómo solucionar el problema o información sobre una versión donde se corregirá el problema.
  • Si no hay ninguna incidencia abierta para su problema, abra una incidencia nueva con WSL y asegúrese de incluir toda la información posible.

Si aún tiene problemas para instalar o ejecutar en WSL, considere la posibilidad de instalar la CLI para Windows.

Actualizar

La CLI proporciona un comando en la herramienta para actualizar a la versión más reciente:

az upgrade

Nota

El comando az upgrade se agregó en la versión 2.11.0 y no funcionará con versiones anteriores a la 2.11.0. Las versiones anteriores se pueden actualizar reinstalando como se indica en Instalación de la CLI de Azure.

Este comando también actualizará todas las extensiones instaladas de forma predeterminada. Para más opciones de az upgrade, consulte la página de referencia del comando.

También puede actualizar la CLI de Azure con el comando dnf update.

sudo dnf update azure-cli

Desinstalación

Si decide desinstalar la CLI de Azure, sentimos que se marche. Antes de desinstalar, use el comando az feedback para contarnos lo que se podría mejorar o corregir. Nuestro objetivo es hacer una CLI de Azure sin errores y fácil de usar. Si encuentra un error, le rogamos que abra una incidencia en GitHub.

  1. Elimine el paquete de su equipo.

    sudo dnf remove azure-cli
    
  2. Si no tiene previsto volver a instalar la CLI, elimine la información del repositorio.

    sudo rm /etc/yum.repos.d/azure-cli.repo
    
  3. Si no usa otros paquetes de Microsoft, quite la clave de firma.

    MSFT_KEY=`rpm -qa gpg-pubkey /* --qf "%{version}-%{release} %{summary}\n" | grep Microsoft | awk '{print $1}'`
    sudo rpm -e --allmatches gpg-pubkey-$MSFT_KEY
    

Advertencia

El paquete más reciente de la CLI de Azure desarrollado por Microsoft para SUSE Linux Enterprise Server (SLES) y OpenSUSE (Leap) es la versión 2.39.0 (publicada el 02/08/2022). Puede seguir usando las versiones históricas de la CLI de Azure en estos sistemas, pero no habrá más actualizaciones ni correcciones de errores por parte de Microsoft para esas versiones.

La CLI de Azure y el script de instalación de Linux seguirán en desarrollo y con soporte técnico de Microsoft. SUSE mantiene y proporciona soporte técnico de los paquetes suministrados en los repositorios de SUSE/OpenSUSE.

Información general

En Azure, las máquinas virtuales con SUSE y OpenSUSE basadas en imágenes de Azure Marketplace ya tienen instalada la interfaz de la línea de comandos de Azure (CLI de Azure).

Para instalar la CLI de Azure en SUSE/OpenSUSE, elija uno de los métodos siguientes:

  1. Use el paquete Enterprise proporcionado por SUSE en los repositorios de SUSE/OpenSUSE.

  2. Use el método de instalación descrito en la pestaña "Install script (any)".

Instalación de la CLI de Azure

Instalación desde los repositorios de SUSE u OpenSUSE

Importante

El paquete RPM de la CLI de Azure depende del paquete python3. En su sistema, esta puede ser una versión de Python anterior al requisito de Python 3.6.x. Si esto le afecta, busque un paquete python3 de reemplazo.

Tenga en cuenta que Python 2 ha llegado al final de su ciclo de vida (EOL) el 1 de enero de 2020 y dejará de recibir actualizaciones. La CLI de Azure ha dejado de ser compatible con Python 2.7 a partir de versión 2.1.0. Las nuevas versiones ya no garantizan su ejecución correcta con Python 2.7.

sudo zypper install -y azure-cli

Instalación con el script de instalación

Puede instalar manualmente la CLI de Azure en cualquier versión de Linux mediante la opción del script de instalación.

Si va a actualizar a la versión más reciente con este método, asegúrese de desinstalar primero la versión anterior, así como los repositorios que haya agregado para esa versión.

Instalación desde los repositorios de Microsoft

Para instalar la versión histórica más reciente de la CLI de Azure mediante los repositorios de Microsoft, siga estos pasos.

(Este paquete se ha probado con SLES 15 y OpenSUSE Leap 15.1).

  1. Instale curl:

    sudo zypper install -y curl
    
  2. Importe la clave del repositorio de Microsoft:

    sudo rpm --import https://packages.microsoft.com/keys/microsoft.asc
    
  3. Cree la información del repositorio azure-cli local:

    sudo zypper addrepo --name 'Azure CLI' --check https://packages.microsoft.com/yumrepos/azure-cli azure-cli
    
  4. Actualice el índice del paquete zypper e instálelo:

    sudo zypper install --from azure-cli azure-cli
    

    Especifique 2 para continuar con la instalación y omitir algunas de sus dependencias.

Instalación de una versión concreta

Primero debe configurar la información del repositorio azure-cli como se mostró anteriormente. Las versiones disponibles se pueden encontrar en las notas de la versión de la CLI de Azure.

  1. Puede ver las versiones disponibles con este comando:

    zypper search --details --match-exact azure-cli
    
  2. Para instalar una versión específica:

    sudo zypper install --from azure-cli azure-cli=<version>-1.el7
    

Solución de problemas

Estos son algunos problemas comunes que se han observado cuando se instala con zypper. Si tiene algún problema que no se trata aquí, abra una incidencia en GitHub.

Error NotImplementedError en máquina virtual con OpenSUSE 15

La máquina virtual con OpenSUSE 15 tiene una CLI de Azure preinstalada con la versión 2.0.45 que está anticuada y tiene problemas con az login. Elimine esta versión junto con sus dependencias antes de seguir las instrucciones de instalación para agregar la CLI de Azure más reciente:

sudo zypper rm -y --clean-deps azure-cli

Si ha actualizado la CLI de Azure sin eliminar las dependencias de la versión 2.0.45, las dependencias antiguas pueden afectar a la versión más reciente de la CLI de Azure. Debe volver a agregar la versión anterior para vincularla con sus dependencias y, a continuación, eliminar azure-cli junto con sus dependencias:

# The package name may vary on different system version, run 'zypper --no-refresh info azure-cli' to check the source package format
sudo zypper install --oldpackage azure-cli-2.0.45-4.22.noarch

sudo zypper rm -y --clean-deps azure-cli

Instalación en SLES 12 u otros sistemas sin Python 3.6

En SLES 12, el paquete predeterminado de python3 es la versión 3.4 y no es compatible con la CLI de Azure. En primer lugar, puede seguir los pasos 1 a 3 de las instrucciones de instalación para agregar el repositorio azure-cli. A continuación, cree una versión superior de python3 desde el código fuente. Después, puede descargar el paquete de la CLI de Azure e instalarlo sin dependencias.

Puede usar el siguiente comando para instalar o actualizar la CLI de Azure en función de los pasos anteriores. El script instalará Python 3.8 en /usr/local/azcli y hará que la CLI de Azure lo utilice mediante el establecimiento de un alias de az en PATH=/usr/local/azcli/bin:$PATH az. También puede descargar el script y modificarlo según sus necesidades. Por ejemplo, puede cambiar la versión de Python o la ubicación de instalación.

curl -sL https://azurecliprod.blob.core.windows.net/sles12_install_v2.sh | sudo bash

Para la primera instalación, recuerde ejecutar el siguiente comando para activar el alias:

source ~/.bashrc

El servidor proxy bloquea la conexión

Si no puede conectarse a un recurso externo debido a un servidor proxy, asegúrese de que ha configurado correctamente las variables HTTP_PROXY y HTTPS_PROXY en el shell. Deberá ponerse en contacto con el administrador del sistema para saber qué hosts y puertos se van a usar para estos servidores proxy.

Estos valores se respetan en muchos programas de Linux, incluidos los que se usan en el proceso de instalación. Para establecer estos valores:

# No auth
export HTTP_PROXY=http://[proxy]:[port]
export HTTPS_PROXY=https://[proxy]:[port]

# Basic auth
export HTTP_PROXY=http://[username]:[password]@[proxy]:[port]
export HTTPS_PROXY=https://[username]:[password]@[proxy]:[port]

Importante

Si está detrás de un servidor proxy, estas variables de Shell deben establecerse para conectarse a los servicios de Azure con la CLI. Si no utiliza autenticación básica, se recomienda exportar estas variables en su archivo .bashrc. Siga siempre las directivas de seguridad de su empresa y los requisitos del administrador del sistema.

Es posible que también quiera configurar explícitamente zypper (mediante yast2) para usar siempre este proxy. Para ello, ejecute el comando yast2 proxy como superusuario y rellene la información del formulario. Si tiene un administrador de ventanas disponible en el sistema, también puede usar el panel Network Services > Proxy en YaST Control Center.

Para ver la configuración avanzada o más información, consulte la documentación de la configuración del servidor proxy de OpenSUSE.

Para obtener la clave de firma de Microsoft y obtener el paquete desde nuestro repositorio, el proxy debe permitir las conexiones HTTPS a las siguientes direcciones:

  • https://packages.microsoft.com
  • https://download.opensuse.org

Se produce un error en la CLI al instalar o ejecutar en el subsistema de Windows para Linux

Como el subsistema de Windows para Linux (WSL) es una capa de traducción de llamadas del sistema que se ejecuta en la plataforma Windows, es posible que experimente un error al intentar instalar o ejecutar en la CLI de Azure. La CLI se basa en algunas características que podrían producir un error en WSL. Si experimenta un error, independientemente de cómo instale la CLI, es muy probable que se trate de un problema de WSL y no del proceso de instalación de la CLI.

Para solucionar los problemas de instalación de WSL:

  • Si puede, ejecute un proceso de instalación idéntico en una máquina Linux para ver si se realiza correctamente. Si es así, su problema seguramente está relacionado con WSL. Para iniciar una máquina virtual Linux en Azure, consulte Creación de una máquina virtual Linux en Azure Portal.
  • Asegúrese de que usa la versión más reciente de WSL. Para obtener la última versión, actualice su instalación de Windows 10.
  • Consulte los problemas abiertos con WSL que pudieran resolver el problema. Suele haber sugerencias sobre cómo solucionar el problema o información sobre una versión donde se corregirá el problema.
  • Si no hay ninguna incidencia abierta para su problema, abra una incidencia nueva con WSL y asegúrese de incluir toda la información posible.

Si aún tiene problemas para instalar o ejecutar en WSL, considere la posibilidad de instalar la CLI para Windows.

Problema de certificado SSL

Cuando un certificado deja de funcionar o está obsoleto en una máquina, es posible que reciba un error que indica que curl no pudo comprobar la legitimidad del servidor y, por lo tanto, no pudo establecer una conexión segura. Actualice el certificado para corregir el problema.

sudo zypper update-ca-certificates

Actualizar

La CLI proporciona un comando en la herramienta para actualizar a la versión más reciente:

az upgrade

Nota

El comando az upgrade se agregó en la versión 2.11.0 y no funcionará con versiones anteriores a la 2.11.0. Las versiones anteriores se pueden actualizar reinstalando como se indica en Instalación de la CLI de Azure.

Este comando también actualizará todas las extensiones instaladas de forma predeterminada. Para más opciones de az upgrade, consulte la página de referencia del comando.

También puede actualizar el paquete con el comando zypper update.

sudo zypper refresh
sudo zypper update azure-cli

Desinstalación

Si decide desinstalar la CLI de Azure, sentimos que se marche. Antes de desinstalar, use el comando az feedback para contarnos lo que se podría mejorar o corregir. Nuestro objetivo es hacer una CLI de Azure sin errores y fácil de usar. Si encuentra un error, le rogamos que abra una incidencia en GitHub.

  1. Elimine el paquete de su equipo.

    sudo zypper remove -y azure-cli
    
  2. Si no tiene previsto volver a instalar la CLI, elimine la información del repositorio.

    sudo zypper removerepo azure-cli
    
  3. Si no usa otros paquetes de Microsoft, quite la clave de firma de Microsoft.

    MSFT_KEY=`rpm -qa gpg-pubkey /* --qf "%{version}-%{release} %{summary}\n" | grep Microsoft | awk '{print $1}'`
    sudo rpm -e --allmatches gpg-pubkey-$MSFT_KEY
    

Información general

El administrador de paquetes apt contiene un paquete x86_64 para la CLI de Azure que se ha probado en las distribuciones siguientes.

Distribución Versión
Ubuntu 18.04 LTS (Bionic Beaver), 20.04 LTS (Focal Fossa), 22.04 (Jammy Jellyfish)
Debian 10 (Buster), 11 (Bullseye)

Advertencia

Puede seguir usando las versiones históricas de la CLI de Azure en los sistemas anteriores, pero no habrá actualizaciones ni correcciones de errores. Considere la posibilidad de actualizar a versiones más recientes de Ubuntu o Debian para usar la última versión de la CLI de Azure.

Advertencia

Ubuntu 20.04 (Focal Fossa) y 20.10 (Groovy Gorilla) incluyen el paquete azure-cli con la versión 2.0.81 proporcionado por el repositorio universe. Este paquete está obsoleto y no se recomienda. Si este paquete está instalado, elimínelo antes de continuar; para ello, ejecute el comando sudo apt remove azure-cli -y && sudo apt autoremove -y. Consulte Administración de paquetes de Ubuntu o solicite a Ubuntu más información sobre apt remove.

El paquete deb azure-cli no admite la arquitectura ARM64.

Opción de instalación

Hay dos opciones para instalar la CLI de Azure en el sistema. En primer lugar, puede ejecutar un único comando que descargará un script de instalación y ejecutará los comandos de instalación automáticamente. O bien, si lo prefiere, puede ejecutar los comandos de instalación usted mismo en un proceso paso a paso. A continuación se proporcionan ambos métodos.

Opción 1: Instalación con un comando

El equipo de la CLI de Azure mantiene un script para ejecutar todos los comandos de instalación en un solo paso. Este script se descarga mediante curl y se canaliza directamente a bash para instalar la CLI.

Si desea inspeccionar el contenido del script antes de ejecutarlo, solo tiene que descargar el script con curl e inspeccionarlo en el editor de texto que prefiera.

curl -sL https://aka.ms/InstallAzureCLIDeb | sudo bash

Opción 2: instrucciones de instalación paso a paso

Si prefiere un proceso de instalación paso a paso, complete los pasos siguientes para instalar la CLI de Azure.

  1. Obtenga los paquetes necesarios para el proceso de instalación:

    sudo apt-get update
    sudo apt-get install ca-certificates curl apt-transport-https lsb-release gnupg
    
  2. Descargue e instale la clave de firma de Microsoft:

    sudo mkdir -p /etc/apt/keyrings
    curl -sLS https://packages.microsoft.com/keys/microsoft.asc |
        gpg --dearmor |
        sudo tee /etc/apt/keyrings/microsoft.gpg > /dev/null
    sudo chmod go+r /etc/apt/keyrings/microsoft.gpg
    
  3. Agregue el repositorio de software de la CLI de Azure:
    AZ_REPO=$(lsb_release -cs)
    echo "deb [arch=`dpkg --print-architecture` signed-by=/etc/apt/keyrings/microsoft.gpg] https://packages.microsoft.com/repos/azure-cli/ $AZ_REPO main" |
        sudo tee /etc/apt/sources.list.d/azure-cli.list
    
  4. Actualice la información del repositorio e instale el paquete azure-cli:

    sudo apt-get update
    sudo apt-get install azure-cli
    

Instalación de una versión concreta

Primero debe configurar la información del repositorio azure-cli como se mostró anteriormente. Las versiones disponibles se pueden encontrar en las notas de la versión de la CLI de Azure.

  1. Para ver las versiones disponibles con el comando:

    apt-cache policy azure-cli
    
  2. Para instalar una versión concreta:

    sudo apt-get install azure-cli=<version>-1~bullseye
    

Solución de problemas

Estos son algunos problemas comunes que se han observado cuando se instala con apt. Si tiene algún problema que no se trata aquí, abra una incidencia en GitHub.

Problema "no se encuentra el módulo" en Ubuntu 20.04 (Focal) y WSL

Si ha instalado azure-cli en Focal sin agregar el repositorio de software de la CLI de Azure en el paso 3 de las instrucciones de instalación manual o mediante el script, puede encontrar problemas que indican que no se encuentra el módulo llamado "decorator" o "antlr4", ya que el paquete que instaló es la versión azure-cli 2.0.81 obsoleta del repositorio focal/universe. Elimínelo primero mediante la ejecución de sudo apt remove azure-cli -y && sudo apt autoremove -y y, a continuación, siga las instrucciones anteriores para instalar el paquete azure-cli más reciente.

lsb_release no devuelve la versión de distribución de base correcta

Algunas distribuciones derivadas de Ubuntu o Debian, como Linux Mint, no pueden devolver el nombre de la versión correcta de lsb_release. Este valor se utiliza en el proceso de instalación para determinar el paquete que desea instalar. Si conoce el nombre de código de la versión de Ubuntu o Debian de la que deriva su distribución, puede establecer el valor de AZ_REPO manualmente al agregar el repositorio. En caso contrario, busque información relativa a su distribución acerca de cómo determinar el nombre del código de distribución base y establezca AZ_REPO en el valor correcto.

No hay ningún paquete para su distribución

A veces hace falta un tiempo desde el lanzamiento de una distribución para que haya un paquete de la CLI de Azure disponible. La CLI de Azure se ha diseñado para ser resistente con respecto a versiones futuras de las dependencias, y a usar las menos posibles. Si no hay ningún paquete disponible para su distribución de base, pruebe un paquete de una distribución anterior.

Para ello, establezca el valor de AZ_REPO manualmente al agregar el repositorio. En el caso de las distribuciones de Ubuntu, use el repositorio jammy más reciente:

AZ_REPO="jammy"

En el caso de las distribuciones de Debian, use el repositorio bullseye más reciente:

AZ_REPO="bullseye"

Las distribuciones lanzadas antes de Ubuntu Bionic y Debian Buster no se admiten.

Elementary OS (EOS) no instala la CLI de Azure

EOS no puede instalar la CLI de Azure porque lsb_release devuelve HERA, que es el nombre de la versión de EOS. La solución es corregir el archivo /etc/apt/sources.list.d/azure-cli.list y cambiar hera main por bionic main.

Contenido del archivo original:

deb [arch=amd64] https://packages.microsoft.com/repos/azure-cli/ hera main

Contenido de archivo modificado:

deb [arch=amd64] https://packages.microsoft.com/repos/azure-cli/ bionic main

El servidor proxy bloquea la conexión

Si no puede conectarse a un recurso externo debido a un servidor proxy, asegúrese de que ha configurado correctamente las variables HTTP_PROXY y HTTPS_PROXY en el shell. Deberá ponerse en contacto con el administrador del sistema para saber qué hosts y puertos se van a usar para estos servidores proxy.

Estos valores se respetan en muchos programas de Linux, incluidos los que se usan en el proceso de instalación. Para establecer estos valores:

# No auth
export HTTP_PROXY=http://[proxy]:[port]
export HTTPS_PROXY=https://[proxy]:[port]

# Basic auth
export HTTP_PROXY=http://[username]:[password]@[proxy]:[port]
export HTTPS_PROXY=https://[username]:[password]@[proxy]:[port]

Importante

Si está detrás de un servidor proxy, estas variables de Shell deben establecerse para conectarse a los servicios de Azure con la CLI. Si no utiliza autenticación básica, se recomienda exportar estas variables en su archivo .bashrc. Siga siempre las directivas de seguridad de su empresa y los requisitos del administrador del sistema.

También puede configurar explícitamente apt para usar este servidor proxy en todo momento. Asegúrese de que las líneas siguientes aparecen en un archivo de configuración apt en /etc/apt/apt.conf.d/. Se recomienda usar el archivo de configuración global existente, un archivo de configuración de proxy existente, 40proxies o 99local, pero seguir sus requisitos de administración del sistema.

Acquire {
    http::proxy "http://[username]:[password]@[proxy]:[port]";
    https::proxy "https://[username]:[password]@[proxy]:[port]";
}

Si el proxy no utiliza autenticación básica, quite la parte [username]:[password]@ del URI del servidor proxy. Si necesita más información para configurar el servidor proxy, consulte la documentación oficial de Ubuntu:

Para obtener la clave de firma de Microsoft y obtener el paquete de nuestro repositorio, el servidor proxy debe permitir las conexiones HTTPS a la siguiente dirección:

  • https://packages.microsoft.com

Se produce un error en la CLI al instalar o ejecutar en el subsistema de Windows para Linux

Como el subsistema de Windows para Linux (WSL) es una capa de traducción de llamadas del sistema que se ejecuta en la plataforma Windows, es posible que experimente un error al intentar instalar o ejecutar en la CLI de Azure. La CLI se basa en algunas características que podrían producir un error en WSL. Si experimenta un error, independientemente de cómo instale la CLI, es muy probable que se trate de un problema de WSL y no del proceso de instalación de la CLI.

Para solucionar los problemas de instalación de WSL:

  • Si puede, ejecute un proceso de instalación idéntico en una máquina Linux para ver si se realiza correctamente. Si es así, su problema seguramente está relacionado con WSL. Para iniciar una máquina virtual Linux en Azure, consulte Creación de una máquina virtual Linux en Azure Portal.
  • Asegúrese de que usa la versión más reciente de WSL. Para obtener la última versión, actualice su instalación de Windows 10.
  • Consulte los problemas abiertos con WSL que pudieran resolver el problema. Suele haber sugerencias sobre cómo solucionar el problema o información sobre una versión donde se corregirá el problema.
  • Si no hay ninguna incidencia abierta para su problema, abra una incidencia nueva con WSL y asegúrese de incluir toda la información posible.

Si aún tiene problemas para instalar o ejecutar en WSL, considere la posibilidad de instalar la CLI para Windows.

Actualizar

La CLI proporciona un comando en la herramienta para actualizar a la versión más reciente:

az upgrade

Nota

El comando az upgrade se agregó en la versión 2.11.0 y no funcionará con versiones anteriores a la 2.11.0. Las versiones anteriores se pueden actualizar reinstalando como se indica en Instalación de la CLI de Azure.

Este comando también actualizará todas las extensiones instaladas de forma predeterminada. Para más opciones de az upgrade, consulte la página de referencia del comando.

También puede usar apt-get upgrade para actualizar el paquete de la CLI.

sudo apt-get update && sudo apt-get upgrade

Nota

Este comando actualiza todos los paquetes instalados en el sistema que no hayan tenido un cambio de dependencia. Para actualizar solo la CLI, use apt-get install.

sudo apt-get update && sudo apt-get install --only-upgrade -y azure-cli

Desinstalación

Si decide desinstalar la CLI de Azure, sentimos que se marche. Antes de desinstalar, use el comando az feedback para contarnos lo que se podría mejorar o corregir. Nuestro objetivo es hacer una CLI de Azure sin errores y fácil de usar. Si encuentra un error, le rogamos que abra una incidencia en GitHub.

  1. Desinstale con apt-get remove:

    sudo apt-get remove -y azure-cli
    
  2. Si no tiene previsto volver a instalar la CLI, elimine la información del repositorio de la CLI de Azure:

    sudo rm /etc/apt/sources.list.d/azure-cli.list
    
  3. Si no usa ningún otro paquete de Microsoft, quite la clave de firma:

    sudo rm /etc/apt/trusted.gpg.d/microsoft.gpg
    
  4. Quite los paquetes que no necesite:

    sudo apt autoremove
    

Información general

Los RPM se publican para la versión 2.0 de CBL-Mariner.

Instalar

Realice la instalación con el comando tdnf install:

sudo tdnf install azure-cli

Instalación de una versión concreta

Las versiones disponibles se pueden encontrar en las notas de la versión de la CLI de Azure.

Para ver las versiones disponibles con el comando:

tdnf list azure-cli

Para instalar una versión concreta:

sudo tdnf install azure-cli-<version>-1

Actualización

Actualice la CLI de Azure con el comando tdnf update:

sudo tdnf update azure-cli

Desinstalación

Si decide desinstalar la CLI de Azure, sentimos que se marche. Antes de desinstalar, use el comando az feedback para contarnos lo que se podría mejorar o corregir. Nuestro objetivo es hacer una CLI de Azure sin errores y fácil de usar. Si encuentra un error, le rogamos que abra una incidencia en GitHub.

Quite el paquete del sistema:

sudo tdnf remove azure-cli

Información general

Nota

Se recomienda utilizar un administrador de paquetes para instalar la CLI. Con un administrador de paquetes se asegura de que siempre tendrá las últimas actualizaciones y garantiza la estabilidad de los componentes de la CLI. Compruebe si existe un paquete para su distribución antes de instalar manualmente.

La CLI requiere el software siguiente:

Importante

La CLI ha dejado de ser compatible con Python 2.7 a partir de la versión 2.1.0. Las nuevas versiones ya no garantizan su ejecución correcta con Python 2.7.

Instalación o actualización

Para instalar y actualizar la CLI es necesario volver a ejecutar el script de instalación. Ejecute curl para instalar la CLI.

curl -L https://aka.ms/InstallAzureCli | bash

El script también se puede descargar y ejecutar localmente. Para que algunos cambios surtan efecto, es posible que tenga que reiniciar el shell.

Solución de problemas

Estos son algunos problemas comunes que se han observado durante la instalación manual. Si tiene algún problema que no se trata aquí, abra una incidencia en GitHub.

Error de curl "Object Moved" (objeto movido)

Si curl muestra un error relacionado con el parámetro -L o un mensaje de error con el texto "Object Moved" (Objeto movido), pruebe a usar la dirección URL completa en lugar de la redirección aka.ms:

curl https://azurecliprod.blob.core.windows.net/install | bash

Comando az no encontrado

Si después de la instalación no se puede ejecutar el comando y utiliza bash o zsh, debe borrar la memoria caché del hash de comandos del shell. Ejecutar

hash -r

y compruebe si el problema se resuelve.

Este problema también puede ocurrir si no reinició el shell después de la instalación. Asegúrese de que la ubicación del comando az esté en $PATH. La ubicación del comando az es

<install path>/bin

El servidor proxy bloquea la conexión

Si no puede conectarse a un recurso externo debido a un servidor proxy, asegúrese de que ha configurado correctamente las variables HTTP_PROXY y HTTPS_PROXY en el shell. Deberá ponerse en contacto con el administrador del sistema para saber qué hosts y puertos se van a usar para estos servidores proxy.

Estos valores se respetan en muchos programas de Linux, incluidos los que se usan en el proceso de instalación. Para establecer estos valores:

# No auth
export HTTP_PROXY=http://[proxy]:[port]
export HTTPS_PROXY=https://[proxy]:[port]

# Basic auth
export HTTP_PROXY=http://[username]:[password]@[proxy]:[port]
export HTTPS_PROXY=https://[username]:[password]@[proxy]:[port]

Importante

Si está detrás de un servidor proxy, estas variables de Shell deben establecerse para conectarse a los servicios de Azure con la CLI. Si no utiliza autenticación básica, se recomienda exportar estas variables en su archivo .bashrc. Siga siempre las directivas de seguridad de su empresa y los requisitos del administrador del sistema.

Para obtener los scripts de instalación, el servidor proxy debe permitir las conexiones HTTPS a las siguientes direcciones:

  • https://aka.ms/
  • https://azurecliprod.blob.core.windows.net/
  • https://pypi.python.org
  • Puntos de conexión usados por el administrador de paquetes de su distribución (si existe) para los paquetes principales.

Se produce un error en la CLI al instalar o ejecutar en el subsistema de Windows para Linux

Como el subsistema de Windows para Linux (WSL) es una capa de traducción de llamadas del sistema que se ejecuta en la plataforma Windows, es posible que experimente un error al intentar instalar o ejecutar en la CLI de Azure. La CLI se basa en algunas características que podrían producir un error en WSL. Si experimenta un error, independientemente de cómo instale la CLI, es muy probable que se trate de un problema de WSL y no del proceso de instalación de la CLI.

Para solucionar los problemas de instalación de WSL:

  • Si puede, ejecute un proceso de instalación idéntico en una máquina Linux para ver si se realiza correctamente. Si es así, su problema seguramente está relacionado con WSL. Para iniciar una máquina virtual Linux en Azure, consulte Creación de una máquina virtual Linux en Azure Portal.
  • Asegúrese de que usa la versión más reciente de WSL. Para obtener la última versión, actualice su instalación de Windows 10.
  • Consulte los problemas abiertos con WSL que pudieran resolver el problema. Suele haber sugerencias sobre cómo solucionar el problema o información sobre una versión donde se corregirá el problema.
  • Si no hay ninguna incidencia abierta para su problema, abra una incidencia nueva con WSL y asegúrese de incluir toda la información posible.

Si aún tiene problemas para instalar o ejecutar en WSL, considere la posibilidad de instalar la CLI para Windows.

Desinstalar

Si decide desinstalar la CLI de Azure, sentimos que se marche. Antes de desinstalar, use el comando az feedback para contarnos lo que se podría mejorar o corregir. Nuestro objetivo es hacer una CLI de Azure sin errores y fácil de usar. Si encuentra un error, le rogamos que abra una incidencia en GitHub.

Para desinstalar la CLI, puede eliminar los archivos directamente de la ubicación elegida en el momento de la instalación. La ubicación de instalación predeterminada es $HOME.

  1. Elimine los archivos de la CLI instalados.

    rm -r <install location>/lib/azure-cli
    rm <install location>/bin/az
    
  2. Modifique el archivo $HOME/.bash_profile para eliminar la línea siguiente:

    <install location>/lib/azure-cli/az.completion
    
  3. Si usa bash o zsh, vuelva a cargar la memoria caché de comandos del shell.

    hash -r
    

Eliminar datos

Si no planea volver a instalar la CLI de Azure, quite sus datos.

rm -rf ~/.azure

Pasos siguientes

Ahora que ha instalado la CLI de Azure, dé un breve paseo por sus características y comandos más comunes.