Nota
El acceso a esta página requiere autorización. Puede intentar iniciar sesión o cambiar directorios.
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Síntomas
Imagine la siguiente situación:
- Está ejecutando Microsoft Exchange Server 2019, Exchange Server 2016 o Exchange Server 2013.
- Exchange Server está configurado para el acceso POP/IMAP.
- Los buzones compartidos en el entorno de Exchange están configurados para habilitar el acceso POP/IMAP.
- A una cuenta de servicio que no está habilitada para correo se le conceden permisos a los buzones compartidos.
En este escenario, los usuarios no pueden acceder a los buzones compartidos a través de POP/IMAP mediante la cuenta de servicio. Además, verá un mensaje de error en los registros de protocolo POP/IMAP similar al siguiente:
¿"R="? ERROR DE NO LOGIN:""; Msg=NoPrimarySmtpAddress"
Cuando se produce este problema, la cuenta de servicio todavía puede acceder a los buzones compartidos a través de Microsoft Outlook, Outlook Web App, Exchange Web Services o Exchange ActiveSync.
Causa
Este problema se produce porque el proceso de autenticación POP/IMAP espera que los usuarios autenticados tengan definida una dirección SMTP principal.
Solución
Para solucionar este problema, use cualquiera de los métodos siguientes (pero solo uno).
Método 1: Crear un buzón para la cuenta de servicio
Use el Centro de Administración de Exchange o el Shell de administración de Exchange para crear un buzón para la cuenta de servicio. Para obtener más información sobre cómo crear un buzón para un usuario existente, consulte Creación de buzones de usuario en Exchange Server.
Método 2: Agregar una dirección SMTP principal al atributo proxyAddresses
Agregue una dirección SMTP principal al atributo proxyAddresses para la cuenta de servicio mediante Usuarios y equipos de Active Directory. Para ello, siga estos pasos:
Abra Usuarios y equipos de Active Directory.
Seleccione Ver>características avanzadas.
Busque el objeto de usuario de la cuenta de servicio.
Haga clic con el botón derecho en el objeto y, a continuación, seleccione Propiedades.
Seleccione la pestaña Editor de atributos.
Busque el atributo userPrincipalName y anote el valor del atributo (por ejemplo, serviceaccount01@contoso.com).
Busque el atributo proxyAddresses y, a continuación, seleccione Editar.
En el cuadro de texto Valor para agregar , agregue el texto siguiente para establecer una dirección SMTP principal y, a continuación, seleccione el botón Agregar :
SMTP:serviceaccount01@contoso.com
Seleccione Aceptar dos veces y cierre Usuarios y equipos de Active Directory.
Después de realizar este cambio, pida a los usuarios que vuelvan a tener acceso a los buzones compartidos a través de POP/IMAP.