Compartir a través de


No se pueden expandir ni agregar carpetas públicas en Outlook o OWA

Síntomas

En Microsoft Outlook, si un usuario que tiene permisos suficientes para una carpeta pública intenta expandir el árbol de carpetas públicas, se muestra el siguiente mensaje de error:

No se puede expandir la carpeta. error al intentar conectarse a Microsoft Exchange.

En Outlook en la Web, si el usuario intenta agregar la carpeta pública a Favoritos, no aparece la ventana "Agregar carpeta pública". Además, si busca la solicitud GetFolder mediante las herramientas de diagnóstico F12, puede capturar el siguiente mensaje de error en el texto de respuesta:

"Se debe tener acceso al buzón como propietario. Propietario: guid de buzón de carpeta pública; Acceso al usuario: User ExchangelegacyDN"

Nota:

Microsoft no admite soluciones de terceros que permiten el acceso a la información de carpetas públicas a través de la suplantación sin que un usuario con licencia obtenga acceso a la carpeta mediante permisos predeterminados.

Causa

Este problema se produce si el usuario tiene permisos explícitos, como acceso completo, a la propiedad EffectiveDefaultPublicFolderMailbox .

Para comprobar esta condición, ejecute los siguientes cmdlets:

Get-Mailbox <mailbox name of the affected user> | FL *public*
Get-MailboxPermission <EffectiveDefaultPublicFolderMailbox name>

Por ejemplo:

Captura de pantalla del permiso de comprobación.

Solución

Para solucionar este problema, ejecute el cmdlet Remove-MailboxPermission para quitar los permisos explícitos a la propiedad EffectiveDefaultPublicFolderMailbox :

Remove-MailboxPermission pfmbx1 -User exo1 -AccessRights FullAccess

A continuación, ejecute el cmdlet Get-MailboxPermission para comprobar que se han quitado esos permisos explícitos:

Get-MailboxPermission pfmbx1