Compartir a través de


Error "DestinationADNotUpToDatePermanentException" en una solicitud de migración de buzón de carpeta pública

Síntomas

En un lote de migración de carpetas públicas, verá una solicitud de migración de buzón de carpeta pública con errores que tiene el tipo de error "DestinationADNotUpToDatePermanentException".

Captura de pantalla de los errores detallados.

Cuando intenta quitar la solicitud de migración del buzón de carpeta pública con errores, recibe el siguiente mensaje de error:

No se pudo encontrar una solicitud única con la información proporcionada.

Causa

Este problema se produce si la solicitud de migración del buzón de carpeta pública está huérfana o duplicada.

Solución

Para resolver este problema, ejecute este script para identificar y quitar las solicitudes de migración de buzones de carpetas públicas huérfanas o duplicadas. Si el script no funciona, siga estos pasos:

  1. Conéctese al PowerShell de Exchange Online.

  2. Identifique las solicitudes de migración de buzones de carpetas públicas duplicadas mediante la ejecución del siguiente cmdlet:

    Get-PublicFolderMailboxMigrationRequest|Sort-Object targetmailbox|ft targetmailbox,requestguid,name,status
    

    Nota: Para obtener más información sobre este cmdlet, vea Get-PublicFolderMailboxMigrationRequest.

    Este es un ejemplo de la salida:

    Captura de pantalla de solicitudes de migración duplicadas.

  3. Para quitar la solicitud de migración del buzón de carpeta pública con errores, ejecute el siguiente cmdlet:

    Remove-PublicFolderMailboxMigrationRequest -Identity "<RequestGuid>" -Force
    

    Nota: Reemplace <RequestGuid por> el resultado real que obtiene del cmdlet en el paso 2. Para obtener más información sobre el cmdlet, vea Remove-PublicFolderMailboxMigrationRequest.

Más información

Los trabajos en buen estado y duplicados tienen el mismo nombre que contiene el GUID del buzón de correo de destino. El formato del nombre es PublicFolderMailboxMigration<TargetMailboxGuid>. Por ejemplo, PublicFolderMailboxMigration058553ac-200f-4fba-91c4-300e4fa0e8e5. Tanto los trabajos en buen estado como los duplicados apuntan al mismo buzón de destino y sus identidades son las mismas.

Sin embargo, completar un lote de migración no está relacionado con trabajos duplicados porque el lote no considera que los trabajos duplicados formen parte de la migración. Solo se considera que los trabajos que tienen usuarios de migración activos correspondientes pertenecen a una migración. Tanto un usuario de migración activo como una solicitud de migración se conectan a través del RequestGuid parámetro . Por lo tanto, los trabajos duplicados no tienen los usuarios de migración activos correspondientes que forman parte de una migración.

En este caso, es mejor quitar los trabajos orpahned o duplicados mediante el RequestGuid parámetro .

Este es un ejemplo para ilustrar este punto. En la salida del cmdlet Get-PublicFolderMailboxMigrationRequest (como se muestra en la captura de pantalla 1), verá el estado de los trabajos individuales en un lote de migración de carpetas públicas y verá trabajos duplicados que apuntan a los mismos buzones de destino que los trabajos en buen estado. En la salida del cmdlet Get-MigrationUser (como se muestra en la captura de pantalla 2), verá la información de los usuarios de migración, pero no verá ningún estado de error para los buzones de destino a los que apuntan los trabajos duplicados.

Captura de pantalla 1:

Captura de pantalla de trabajos de migración duplicados.

Captura de pantalla 2:

Captura de pantalla del estado del usuario de migración.