Compartir a través de


Diagnóstico y corrección de problemas de permisos de carpetas públicas

Síntomas

En Exchange Online, no puede realizar tareas específicas, como crear o eliminar elementos o subcarpetas en una carpeta pública. Además, puede recibir un mensaje de error que indica que se trata de un problema relacionado con los permisos.

Causa

Este problema suele producirse porque la replicación de la jerarquía de carpetas públicas no se ha completado o tiene problemas.

Pasos para la solución de problemas

  1. Compruebe el buzón de carpeta pública asignado al usuario. Para ello, ejecute el siguiente comando (por ejemplo):

    Get-Mailbox -Identity User1 | Format-List *public*
    
  2. Compruebe que el permiso de carpeta pública se replica en el buzón de carpeta pública asignado al usuario. Para ello, siga estos pasos:

    a) Compruebe primero los permisos en el buzón de carpeta pública de la jerarquía principal. Para ello, ejecute el siguiente cmdlet (por ejemplo):

    Get-PublicFolderClientPermission \puf1 -User User1 -Mailbox (Get-Mailbox -PublicFolder | ?{$_.IsRootPublicFolderMailbox -eq "True"}).Name
    

    b) Compruebe los permisos de la carpeta para el usuario en el buzón de carpeta pública que obtuvo del paso 1 (por ejemplo).

    Get-PublicFolderClientPermission "\puf1" -User User1 -Mailbox pubmbx1
    

    Este cmdlet devuelve la siguiente salida:

    There is no existing permission entry found for user: user1.
        + CategoryInfo          : NotSpecified: (:) [Get-PublicFolderClientPermission], UserNotFoundInPermissionEntryExcep
       tion
        + FullyQualifiedErrorId : [Server=<*ServerName*>,RequestId=<*RequestId*>,TimeStamp=3/19/2020
        5:22:40 AM] [FailureCategory=Cmdlet-UserNotFoundInPermissionEntryException] 91D3F338,Microsoft.Exchange.Managemen
      t.StoreTasks.GetPublicFolderClientPermission
    + PSComputerName        : outlook.office365.com
    

    La salida indica que los permisos aún no se replican en el buzón de carpeta pública asignado al usuario. En algunos casos, el permiso puede aparecer, pero será diferente del permiso que se devuelve en el paso 2b.

Solución

Para corregir este problema, replique manualmente los permisos en el buzón de carpeta pública asignado al usuario mediante la ejecución del siguiente cmdlet (por ejemplo):

Update-PublicFolderMailbox pubmbx1 -InvokeSynchronizer

A continuación, vuelva a comprobar los permisos repitiendo el cmdlet :

Get-PublicFolderClientPermission \puf1 -User User1 -Mailbox pubmbx1

Nota:

Puede tardar varios minutos en mostrar el cambio de permiso.

Más información

Si los permisos siguen sin sincronizarse o se produce un error al forzar la sincronización de jerarquías, siga estos pasos para obtener los registros de sincronización de jerarquías:

  1. Compare la jerarquía entre buzones de carpetas públicas:

    $P=Get-PublicFolderMailboxDiagnostics <Primary_pfmailboxname> -IncludeHierarchyInfo
    $S= Get-PublicFolderMailboxDiagnostics <pfmailboxname_notreceiving_hierarchy> -IncludeHierarchyInfo
    
  2. Compare la salida de "HierarchyInfo" de ambos buzones:

    $p.HierarchyInfo
    $s.HierarchyInfo
    
  3. Si determina que la información de jerarquía no es la misma, ejecute el siguiente comando para ver la hora de la última sincronización:

    $s.SyncInfo.LastAttemptedSyncTime.LocalTime
    

    Este comando indica la última vez que se produjo un error en la sincronización. Un valor sin sentido indica que nunca se ha producido un error en la sincronización.

    $s.SyncInfo.LastFailedSyncTime.LocalTime
    

    El siguiente comando proporciona un mensaje de error detallado del último error de sincronización. Una salida en blanco indica que nunca se ha producido un error en la sincronización:

    $s.SyncInfo.LastSyncFailure
    

    También puede explorar otros valores, como los bloques AssistantInfo y HierarchyInfo.

Si tiene que ponerse en contacto con Soporte técnico de Microsoft, exporte el informe al formato XML y, a continuación, envíelo al agente de soporte técnico. Para exportar el informe, ejecute el siguiente comando (por ejemplo):

Get-PublicFolderMailboxDiagnostics <pf mailbox failing to sync> -IncludeHierarchyInfo |Export-Clixml epf.xml