Compartir a través de


Errores después de anular la asignación de una licencia de usuario

Síntomas

Después de anular la asignación de la licencia de Microsoft 365 u Office 365 para un usuario cuyo buzón normal tiene una suspensión aplicada, se producen los síntomas siguientes:

  • El Centro de administración de Microsoft 365 muestra cualquiera de los siguientes mensajes de error en la pestaña Cuenta del panel flotante que muestra los detalles del usuario:

    • Exchange: se ha producido un error desconocido. Consulte el identificador de correlación: 12ffde19-5350-4fb6-baec-3359e4042eb8.;
    • La ejecución del cmdlet Disable-Mailbox failed..; Exchange: se ha producido un error desconocido.
  • Los cambios realizados en los atributos del usuario en el identificador de Microsoft Entra no se sincronizan con Exchange Online.

  • El buzón del usuario permanece activo en lugar de cambiar a un buzón inactivo.

Nota:

Este problema puede afectar a los usuarios en la nube en Exchange Online y entornos híbridos de Exchange.

Causa

El problema se produce si anula la asignación de la licencia de un usuario activo cuyo buzón normal tiene aplicada una suspensión. Este comportamiento es así por diseño.

Si un buzón no tiene ninguna suspensión aplicada cuando la licencia de usuario no está asignada, Exchange Online desconecta el buzón de la cuenta de usuario y elimina permanentemente el buzón después de 30 días. Sin embargo, si existe una suspensión cuando la licencia de usuario no está asignada, Exchange Online genera un error porque no puede desconectar un buzón cuyo contenido debe conservarse.

Solución

Para resolver el problema, siga estos pasos:

  1. Identifique a todos los usuarios del inquilino que tienen errores de cuenta.

  2. Para cada usuario que tenga un error de cuenta, elija entre las siguientes opciones en función de sus objetivos:

Identificación de todos los usuarios del inquilino que tienen errores de cuenta

  1. Ejecute los siguientes cmdlets de PowerShell para conectarse a Microsoft Graph PowerShell:

    Install-Module Microsoft.Graph -Scope AllUsers -Repository PSGallery -Force
    Connect-MgGraph -Scopes User.Read.All
    
  2. Ejecute el siguiente cmdlet de PowerShell Get-MgBetaUser para enumerar todas las cuentas de usuario del inquilino que tienen errores:

    Get-MgBetaUser -All | Select-Object -Property UserPrincipalName -ExpandProperty ServiceProvisioningErrors | FL UserPrincipalName, AdditionalProperties
    
  3. Compruebe el valor ErrorDescription del parámetro AdditionalProperties para cada usuario enumerado. En el ejemplo siguiente, la descripción del error confirma que Exchange Online no puede deshabilitar un buzón que tenga una suspensión de litigio.

    Captura de pantalla de la salida del cmdlet Get-MgBetaUser de PowerShell.

Anular la asignación de la licencia de usuario y conservar el contenido del buzón

Para convertir un buzón de usuario que tiene un error de cuenta en un buzón inactivo, siga estos pasos:

  1. Reasignar la licencia de usuario para resolver el error de la cuenta. Los pasos siguientes deben completarse mientras la cuenta de usuario tiene licencia.

  2. Para una cuenta de usuario en la nube que se sincroniza desde Active Directory local mediante Microsoft Entra Connect, seleccione una de las siguientes opciones:

    • Elimine la cuenta local.

    • Mueva la cuenta local a una unidad organizativa que no se sincronice con el identificador de Entra de Microsoft.

    • Especifique un valor de atributo en Microsoft Entra Connect que impida que la cuenta local se sincronice con el identificador de Microsoft Entra.

  3. Para una cuenta de usuario que se creó directamente en la nube, elimine la cuenta de usuario.

Después de completar estos pasos, Exchange Online realiza las siguientes acciones:

  • Anula inmediatamente la asignación de la licencia de usuario y la agrega al grupo de licencias disponibles.

  • Agrega la cuenta de usuario eliminada a la lista Usuarios eliminados en el Centro de administración de Microsoft 365 y el Centro de administración de Microsoft Entra. Exchange Online quitará permanentemente la cuenta de usuario eliminada después de 30 días a menos que la restaure. Si restaura la cuenta de usuario, asegúrese de reasignar una licencia.

  • Inicia la conversión del buzón de usuario a un buzón inactivo. La conversión se finaliza cuando la cuenta de usuario se elimina permanentemente.

    Sugerencia

    Los buzones inactivos conservan el contenido del correo electrónico y no requieren una licencia de usuario después de crearlos. Para obtener más información sobre cómo convertir un buzón de usuario en un buzón inactivo, vea Crear y administrar buzones inactivos. Para enumerar los buzones inactivos de la organización, consulte Ver buzones inactivos.

Anular la asignación de la licencia de usuario y eliminar el contenido del buzón

  1. Reasignar una licencia de usuario para resolver el error de la cuenta. El siguiente paso debe completarse mientras la cuenta de usuario tiene licencia.

  2. Siga estos pasos para quitar una o varias suspensiones en el buzón:

    1. Identificación de las suspensiones

    2. Quitar las suspensiones

    3. Quitar la suspensión de retraso resultante

  3. Anular la asignación de la licencia de usuario

Después de completar estos pasos, Exchange Online desconecta el buzón de la cuenta de usuario y elimina permanentemente el buzón después de 30 días o después de 60 días si ha habilitado la resistencia de licencias.