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Se produce un error en las reglas de creación automática de registros cuando el remitente del correo electrónico es un contacto y un usuario de Microsoft Dynamics CRM

En este artículo se proporciona una resolución para que se especifique un error primario de contacto o cuenta que se produce cuando se produce un error en las reglas de creación automática de registros.

Se aplica a: Microsoft Dynamics CRM 2015
Número de KB original: 3094208

Síntomas

Las reglas de creación automática de registros producen un error cuando el remitente del correo electrónico es un contacto y un usuario de Microsoft Dynamics CRM. Al abrir el trabajo del sistema de elementos de regla, verá si se produce un error con el siguiente error:

Debe especificar un contacto primario o una cuenta.

Causa

Se trata de un problema conocido y está programado para corregirse en una actualización de septiembre de Microsoft Dynamics CRM Online.

Solución

Una vez que se haya aplicado esta corrección a la organización de Microsoft Dynamics CRM Online, se le pedirá que deshabilite la regla de creación automática de registros, elimine el paso de creación de casos en el elemento de regla y vuelva a crear el paso de creación de casos. Esto se debe hacer, ya que la corrección incluye nuevos slugs de valor dinámico que se van a crear en los campos Cliente y Contacto listos para usar. Para ello, siga estos pasos:

  1. Vaya a Configuración Administración>automática de>registros y reglas de actualización.
  2. Seleccione la marca de verificación situada junto a la regla y seleccione Desactivar.
  3. A continuación, abra la regla de creación automática de registros.
  4. Seleccione esta opción para abrir el elemento de regla especificado.
  5. En Acciones, seleccione el paso Crear caso y seleccione Eliminar este paso. Guarde el formulario.
  6. Vuelva a agregar la acción a Crear caso.
  7. Seleccione Establecer propiedades y vuelva a agregar las asignaciones personalizadas. Los campos Cliente y Contacto integrados se rellenarán automáticamente en {null(Propiedades del canal)}. Este valor debe permanecer, para que la resolución de correo electrónico se correlacione correctamente con el contacto o la cuenta. Si se cambia este valor, no se puede restablecer manualmente y el paso Crear caso debe eliminarse y volver a crearse.
  8. Guardar el formulario,
  9. Vuelva a habilitar la regla de creación automática de registros.

Más información

El diseño actual de las reglas de creación automática de registros no resolverá el remitente de un correo electrónico si solo existe como usuario en Microsoft Dynamics CRM. También debe existir como contacto o cuenta y se puede crear como contacto automáticamente cuando se recibe. Para crear automáticamente el remitente del correo electrónico como contacto, active la casilla Crear registros para el correo electrónico de remitentes desconocidos en la Regla de creación automática de registros. Si este cuadro está sin marcar, la dirección de correo electrónico no se resolverá y la regla no se desencadenará.