No se encuentra el archivo de base de datos cuando se configura Microsoft Dynamics CRM para Microsoft Office Outlook
En este artículo se proporciona una solución a un error que se produce al configurar Microsoft Dynamics CRM para Microsoft Office Outlook.
Se aplica a: Microsoft Dynamics CRM 2015
Número de KB original: 3091650
Síntomas
Al intentar configurar Microsoft Dynamics CRM para Microsoft Office Outlook, recibirá el siguiente mensaje de error:
"Hay un problema al comunicarse con el servidor de Microsoft Dynamics CRM. Es posible que el servidor no esté disponible. Vuelva a intentarlo más tarde. Si el problema persiste, póngase en contacto con el administrador del sistema".
Al seleccionar los detalles, se muestra el siguiente detalle adicional:
No se encuentra el archivo de base de datos. Compruebe la ruta de acceso a la base de datos. [ Origen de datos = C:\Users\<user>\AppData\Local\Microsoft\MSCRM\Client\MetadataCache-93d47f8c-8eb3-45a6-98c8-d668f4ff9b4c.sdf ] at System.Data.SqlServerCe.SqlCeConnection.Open(Boolean silent)
at System.Data.SqlServerCe.SqlCeConnection.Open()
en Microsoft.Crm.Application.SMWrappers.CrmSqlCeConnection.Open()
en Microsoft.Crm.Application.SMWrappers.CrmSqlCeConnection.ExecuteInNewConnection[TReturn](String connectionString, Func'2 actions, Func'2 exceptionHandler, Boolean disposeConnection)
en Microsoft.Crm.Application.Outlook.ClientMetadataCache.SqlCeManager.GetObjectsReader(MetadataCollectionInfo info, IList'1 requiredValues)
en Microsoft.Crm.Application.Outlook.ClientMetadataCache.SqlCeManager.GetObjectsReader(MetadataCollectionInfo info)
en Microsoft.Crm.Application.Outlook.ClientMetadataCache.MetadataCacheManager.GetObjectsDataReader(MetadataCollectionInfo info)
en Microsoft.Crm.Application.Outlook.ClientMetadataCache.Collections.OnDemandMetadataCollection'1.CreateEnumerator()
at Microsoft.Crm.Application.Outlook.ClientMetadataCache.Collections.OnDemandBaseCollection'1.System.Collections.IEnumerable.GetEnumerator()
at Microsoft.Crm.Caching.UserEntityUISettingsCache.LookupEntries(Guid userId, IOrganizationContext context, DynamicMetadataCache cache)
en Microsoft.Crm.Application.Outlook.Config.OutlookConfigurator.InitializeMapiStoreForFirstTime()
en Microsoft.Crm.Application.Outlook.Config.OutlookConfigurator.Configure(IProgressEventHandler progressEventHandler)
en Microsoft.Crm.Application.Outlook.Config.ConfigEngine.Configure(Object stateInfo)
Causa
Microsoft conoce un escenario en el que este error puede producirse después de configurar Microsoft Dynamics CRM para Microsoft Office Outlook y, a continuación, eliminar esa configuración.
Solución
Cierre el Asistente para configuración de Microsoft Dynamics CRM para Outlook e intente la configuración de nuevo.
Si sigue teniendo problemas para conectar CRM para Outlook a su organización de CRM Online, hay disponible una herramienta de diagnóstico para ayudar a diagnosticar el problema.