Compartir a través de


Coherencia de la actualización de la solución del portal de Microsoft Dynamics 365 para implementaciones multi portal

En este artículo se proporciona una solución a un error que se produce al navegar a un portal asociado a una instancia de Dynamics 365 que contiene algunas soluciones que aún no se han actualizado.

Se aplica a: Microsoft Dynamics CRM
Número de KB original: 4020942

Síntomas

Después de una actualización a las soluciones que admiten un complemento del portal en el Centro de administración de Dynamics 365, los clientes que tienen varios complementos de portal asociados a la misma instancia de Dynamics 365 podrían experimentar errores si las soluciones para otros tipos de portal aún no se han actualizado. Los usuarios que navegan a un portal asociado a una instancia de Dynamics 365 que contienen algunas soluciones que aún no se han actualizado pueden recibir un error similar al ejemplo siguiente:

Lo sentimos, pero algo salió mal.
[00000000-0000-0000-0000-000000000000]
Hemos sido notificados sobre este problema y lo echaremos un vistazo brevemente.
Gracias por su paciencia.

Causa

Cuando se implementa un complemento de portal en una instancia de Dynamics 365, se instalan varias soluciones para admitir la funcionalidad del portal. Las actualizaciones de estas soluciones están disponibles a medida que se publican mejoras y correcciones, y los clientes pueden implementar esas actualizaciones realizando la acción adecuada en el Centro de administración de Dynamics 365.

Dado que varios tipos de portal comparten muchas soluciones, la actualización de un solo tipo de portal sin actualizar ningún otro tipo de portal que se implemente en la misma instancia de Dynamics 365 provocará errores y podría representar uno o varios portales inoperables.

Solución

Para evitar problemas de coincidencia de versiones de la solución, las soluciones para todos los tipos de portal implementados en una sola instancia de Dynamics 365 deben actualizarse más adelante y durante el mismo intervalo de tiempo. Para actualizar las soluciones del complemento del portal para cualquier tipo de portal implementado, se deben seguir los pasos siguientes:

  1. Inicie sesión en el Centro de administración de Dynamics 365 con un usuario con permisos suficientes para actualizar las soluciones de Dynamics 365.
  2. En la pestaña Instancias , seleccione la instancia que tiene implementados dos o más portales.
  3. Con la instancia seleccionada, seleccione el icono Soluciones del panel situado a la derecha.
  4. En la vista Soluciones , seleccione un tipo de portal (como Portal de comunidad) que se haya implementado en esta instancia.
  5. Si el botón Actualizar aparece en el panel derecho, selecciónelo para actualizar las soluciones respectivas en la instancia de Dynamics 365.
  6. Una vez finalizada la actualización, seleccione el siguiente tipo de portal disponible en la vista Soluciones y repita el paso 5.

Cuando se han actualizado todos los tipos de portal, no se producirán errores de coincidencia de versiones de la solución adicionales.