Aparece la advertencia MailboxNotEnabledForRESTAPI en la alerta de buzón de Microsoft Dynamics 365
En este artículo se proporciona una solución a un error que se produce en la alerta de buzón de Microsoft Dynamics 365.
Se aplica a: Microsoft Dynamics 365 Customer Engagement Online
Número de KB original: 4534628
Síntomas
Verá una advertencia como el ejemplo siguiente dentro de una alerta de buzón en Dynamics 365:
"Error general de acceso al buzón al enviar el mensaje de correo electrónico Test SSS with incoming via EXO profile but really on-prem through the mailbox <Mailbox Name>. Se ha notificado al propietario del perfil de servidor de correo electrónico asociado Microsoft Exchange Online. El sistema intentará enviar el mensaje de nuevo más tarde.
Código de error del servidor de correo electrónico: MailboxNotEnabledForRESTAPI. Exchange.server devolvió el error 404".
Causa
Esta advertencia se puede registrar si el buzón está configurado con un perfil de servidor de correo electrónico de Exchange Online en Dynamics 365, pero el buzón es realmente un buzón local de Exchange.
Solución
Si el buzón es un buzón de Exchange local, compruebe que el perfil del servidor de correo electrónico configurado en el registro de buzón no es un perfil de Exchange Online. Se debe usar un perfil de Exchange Server (híbrido) al conectarse a un buzón local de Exchange.
Para obtener más información sobre cómo configurar Dynamics 365 Online con Exchange local, consulte Conexión de aplicaciones de Dynamics 365 for Customer Engagement (en línea) a Exchange Server (local).