Compartir a través de


El cliente de Outlook de Microsoft Dynamics CRM puede dejar de responder en modo no administrador

Este artículo le ayuda a solucionar el problema que se produce al intentar abrir el cliente de Microsoft Dynamics CRM para Outlook o al probar el proceso de sincronización sin conexión en el cliente de Microsoft Dynamics CRM para Outlook con acceso sin conexión.

Se aplica a: Microsoft Dynamics CRM 2013 Service Pack 1, Microsoft Dynamics CRM 2015, Cliente Microsoft CRM para Microsoft Office Outlook
Número de KB original: 3106337

Síntomas

Al intentar abrir el cliente de Microsoft Dynamics CRM para Outlook o al probar el proceso de sincronización sin conexión en el cliente de Microsoft Dynamics CRM para Outlook con acceso sin conexión, es posible que experimente errores como los siguientes:

Outlook deja de responder (parpadeando) y tiene que finalizar el proceso.

Outlook mostrará un error: no había ningún punto de conexión escuchando net.pipe://localhost/WebFormService/{random-guid-number} que pudiera aceptar el mensaje. La causa suele ser una dirección o una acción SOAP incorrecta. Consulte InnerException, si está presente, para obtener más información.

Causa

El cliente CRM para Outlook aprovecha Windows Communication Foundation (WCF) para comunicarse con un servicio fuera del proceso para interactuar con el servidor CRM. El enlace WCF usado es net.pipe que tiene una manera determinada de asignar un nombre a la canalización con nombre subyacente. A partir de WCF 4.0, el proceso de nomenclatura y registro del URI del punto de conexión net.pipe es jerárquico y en dos niveles: modo no administrativo y modo administrativo. Si un proceso registra el URI net.pipe://localhost, todos los procesos no administrativos no podrán acceder a ningún otro servicio con enlace net.pipe, incluida la firma del servicio web de formulario web local de CRM.

Solución

No hay ninguna solución, ya que esto es por diseño. Los servicios WCF no deben tener un URI del agente de escucha en net.pipe://localhost/. Sin embargo, hay dos soluciones alternativas si la situación es cierta.

Para averiguar qué proceso contiene el agente de escucha en net.pipe://localhost/, siga estos pasos:

  • Cargar identificador de herramienta Sysinternals (handle v4.22)

  • Descomprima Handle.zip en una carpeta (por ejemplo: c:\sysinternals)

  • Abra cmd.exe como administrador

  • Vaya a la carpeta donde descomprimió Handle.exe (por ejemplo, cd c:\sysinternals)

  • Ejecute este comando:

    handle "net.pipe:EbmV0LnBpcGU6Ly8rLw=="
    
  • Si hay una coincidencia, indicará el nombre del archivo ejecutable y el PID como la salida de ejemplo siguiente:

    StandAloneService.exe pid: 10724 type: Section 318: \BaseNamedObjects\net.pipe:EbmV0LnBpcGU6Ly8rLw==
    

Solución alternativa

  • Solución alternativa 1

    Busque el archivo (o servicio) que net.pipe://localhost escucha como se especificó anteriormente y deténgalo mientras ejecuta Outlook.

  • Solución alternativa 2 (menos recomendada)

    Si inicia clientes de Microsoft Dynamics CRM para Outlook con derechos de administrador local (haga clic con el botón derecho en Outlook y seleccione Ejecutar como administrador), el cliente de Microsoft Dynamics CRM para Outlook funciona como diseño y puede usar el proceso de sincronización sin conexión sin errores.