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Error "Crystal Print Engine Error 536" o "System Message 7014" al intentar imprimir o imprimir una vista previa de un informe personalizado en Microsoft Dynamics SL

En este artículo se proporcionan varias soluciones a un problema en el que se reciben dos mensajes de error al imprimir o imprimir una vista previa de un informe personalizado.

Se aplica a: Microsoft Dynamics SL
Número de KB original: 897023

Síntomas

Al imprimir un informe personalizado o obtener una vista previa de un informe personalizado antes de imprimirlo en Microsoft Dynamics SL, recibe los siguientes mensajes de error:

Error del motor de impresión de cristal: 536-Error en el archivo. No se puede conectar: parámetros de inicio de sesión incorrectos.

Mensaje del sistema 7014: Error 536 en la ejecución del informe.

Causa

Este problema se produce por una o varias de las siguientes razones.

Causa 1

El parámetro Conexión de confianza del archivo de informe se establece en 1. Consulte resolución 1.

Causa 2

La conexión open database connectivity (ODBC) de la estación de trabajo está dañada. Consulte resolución 2.

Causa 3

El informe apunta a dos bases de datos diferentes. Consulte resolución 3.

Causa 4

La cuenta de inicio de sesión de E7F575915A2E4897A517779C0DD7CE en SQL Server 2005 o en SQL Server 2008 está deshabilitada o tiene una contraseña incorrecta. Consulte resolución 4.

Resolución

Para resolver este problema, use la resolución adecuada.

Solución 1

Para resolver este problema, establezca el parámetro Conexión de confianza en el archivo de informe en 0 (cero). Para ello, siga estos pasos:

  1. Inicia Crystal Reports 10 para Solomon.

  2. Seleccione Abrir, seleccione el informe personalizado y, a continuación, seleccione Abrir.

  3. En el menú Base de datos , seleccione Establecer ubicación del origen de datos.

  4. En el cuadro de diálogo Establecer ubicación del origen de datos , expanda Origen de datos actual: Propiedades.

  5. En Origen de datos actual: Propiedades, busque el parámetro Conexión de confianza: 1 .

    Nota:

    Si el parámetro Conexión de confianza no aparece en la lista, la opción Conexión de confianza no se seleccionó cuando se creó el informe y no es la causa del error.

  6. Haga clic con el botón derecho en Conexión de confianza: 1 y, a continuación, seleccione Editar.

  7. Escriba 0.

  8. Seleccione Cerrar.

  9. Seleccione Guardar.

Solución 2

Para resolver este problema, elimine las conexiones ODBC de Microsoft Dynamics SL. A continuación, deje que Microsoft Dynamics SL vuelva a crear las conexiones. Para ello, siga estos pasos:

  1. Seleccione Inicio, seleccione Panel de control, Herramientas administrativas y, a continuación, Orígenes de datos (ODBC).
  2. En la pestaña DSN de usuario , quite los elementos que apunten a las bases de datos de aplicaciones de Microsoft Dynamics SL.
  3. En la pestaña DSN del sistema , quite los elementos que apunten a las bases de datos de aplicaciones de Microsoft Dynamics SL.
  4. Vuelva a ejecutar el informe en Microsoft Dynamics SL. Las conexiones ODBC se vuelven a crear automáticamente al ejecutar un informe en Microsoft Dynamics SL.

Resolución 3

Para resolver este problema, restablezca el origen de datos en Crystal Reports. Para ello, siga estos pasos:

  1. Inicia Crystal Reports 10 para Solomon.
  2. Seleccione Abrir, seleccione el informe personalizado y, a continuación, seleccione Abrir.
  3. En el menú Base de datos , seleccione Establecer ubicación del origen de datos.
  4. En el cuadro Reemplazar por , expanda Crear nueva conexión y, a continuación, expanda ODBC (RDO).
  5. Seleccione la base de datos de Microsoft Dynamics SL y, a continuación, seleccione Siguiente.
  6. Escriba la información de inicio de sesión. No active la casilla Conexión de confianza .
  7. Seleccione Finalizar.
  8. Seleccione la base de datos en el cuadro Reemplazar por . A continuación, seleccione la base de datos en el cuadro Origen de datos actual .
  9. Seleccione Actualizar.
  10. Si tiene varias bases de datos en el cuadro Origen de datos actual , repita los pasos 8 y 9 para cada base de datos.
  11. Seleccione Guardar y, a continuación, salga de Crystal Reports.

Resolución 4

Para resolver este problema, habilite la cuenta de inicio de sesión de E7F575915A2E4897A517779C0DD7CE en SQL Server 2005 o en SQL Server 2008 y, a continuación, ejecute el escenario de actualización Synchronize All Ownership & Security en la pantalla Mantenimiento de bases de datos (98.290.00) en Microsoft Dynamics SL. Para ello, siga estos pasos:

  1. Inicie SQL Server Management Studio y, a continuación, conéctese al servidor que hospeda las bases de datos de Microsoft Dynamics SL.
  2. En el panel Explorador de objetos, expanda Seguridad y, a continuación, expanda Inicios de sesión.
  3. En Inicios de sesión, haga clic con el botón derecho en E7F575915A2E4897A517779C0DD7CE y, a continuación, seleccione Propiedades.
  4. En el panel Seleccionar una página , seleccione Estado y, a continuación, seleccione Habilitado en Inicio de sesión.
  5. Seleccione Aceptar y, a continuación, cierre SQL Server Management Studio.
  6. En Panel de control, seleccione Herramientas administrativas y, a continuación, seleccione Mantenimiento de bases de datos de Microsoft Dynamics SL.
  7. Conéctese a la instancia de SQL Server que hospeda las bases de datos de Microsoft Dynamics SL.
  8. Seleccione la pestaña Actualizar base de datos .
  9. En la lista Escenarios de actualización , seleccione Sincronizar toda la propiedad & seguridad y, a continuación, seleccione Actualizar base de datos.
  10. En la parte inferior de la pantalla Mantenimiento de la base de datos (98.290.00), confirme que la barra de progreso ha finalizado y, a continuación, seleccione Cerrar.