Error AADSTS50011 con autenticación SAML: la dirección URL de respuesta especificada en la solicitud no coincide

En este artículo se proporciona una resolución del error de AADSTS50011 que se produce durante la autenticación federada con Microsoft Entra ID.

Síntomas

Recibe un error AADSTS50011 al intentar iniciar sesión en una aplicación que se ha configurado para usar Microsoft Entra ID para la administración de identidades mediante el inicio de sesión único basado en SAML.

Error AADSTS50011: la dirección URL de respuesta no coincide con las direcciones URL de respuesta configuradas para el GUID> de la aplicación<. Asegúrese de que la dirección URL de respuesta enviada en la solicitud coincide con una agregada a la aplicación en el Azure Portal. Vaya a https://aka.ms/urlMismatchError para obtener más información sobre cómo solucionarlo". Al intentar iniciar sesión en una aplicación configurada con single Sign-On (SSO) basada en SAML que se ha integrado con Microsoft Entra ID.

Causa

El AssertionConsumerServiceURL valor de la solicitud SAML no coincide con el valor o el patrón url de respuesta configurados en Microsoft Entra ID. El AssertionConsumerServiceURL valor de la solicitud SAML es la dirección URL que aparece en el error.

Solución

Para resolver el problema, siga estos pasos:

  1. Asegúrese de que el AssertionConsumerServiceURL valor de la solicitud SAML coincide con el valor url de respuesta configurado en Microsoft Entra ID.
  2. Compruebe o actualice el valor en el cuadro de texto URL de respuesta para que coincida con el AssertionConsumerServiceURL valor de la solicitud SAML.

Por ejemplo, consulte el artículo siguiente para obtener pasos detallados sobre cómo configurar los valores en Microsoft Entra ID:

Nota:

La dirección URL de respuesta también se conoce como URI de redirección. Estos valores dependen de la aplicación que se use. Debe obtener los valores del proveedor de la aplicación.

Después de actualizar el valor url de respuesta en Microsoft Entra ID y que coincide con el valor que envía la aplicación en la solicitud SAML, debería poder iniciar sesión en la aplicación.

Más información

Para obtener una lista completa de los códigos de error de autenticación y autorización de Active Directory, consulte Microsoft Entra códigos de error de autenticación y autorización.

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