Compartir a través de


La disponibilidad de la máquina virtual podría ser inexacta durante los reinicios de la máquina virtual.

Se aplica a: ✔️ Máquinas virtuales Linux ✔️ Máquinas virtuales Windows

En este artículo se describe cómo se puede notificar la disponibilidad de la máquina virtual inexactamente durante un reinicio de máquina virtual (VM) emitido por un usuario autorizado o causado por un bloqueo del sistema operativo invitado. Es posible que el estado de disponibilidad de la máquina virtual inexacta se publique en los siguientes recursos de Microsoft Azure:

  • Métricas de Azure Monitor
  • Azure Resource Graph
  • Azure Resource Health

Síntomas

Azure sigue informando inexactamente de una máquina virtual como disponible durante algunas situaciones poco frecuentes, como un usuario autorizado que reinicia la máquina virtual o un bloqueo que se inicia dentro del sistema operativo invitado y provoca un reinicio de la máquina virtual. En estos tipos de situaciones, se producen las siguientes cosas:

Causa

Cuando se reinicia la máquina virtual, puede producirse un retraso de 15 segundos mientras el servicio de supervisión subyacente recopila el estado de mantenimiento de la máquina virtual. Este intervalo puede ir seguido de hasta tres minutos de retraso al emitir el estado de mantenimiento externamente. Si se inicia y se completa un reinicio de máquina virtual dentro del período de tiempo del retraso acumulado, los distintos recursos de Azure no indican ningún cambio en el estado.

Solución alternativa

Si ve que la máquina virtual tiene el estado Disponible, asegúrese de que el estado permanece sin cambios durante tres minutos y 15 segundos antes de continuar con el uso de la máquina virtual.

Nota:

Estamos priorizando las mejoras de infraestructura para minimizar el retraso en la detección y notificación. Esta inversión forma parte de Project Flash. Este proyecto está diseñado para mantener información de disponibilidad de máquina virtual altamente precisa y accionable.

Referencias

Ponte en contacto con nosotros para obtener ayuda

Si tiene preguntas, puede preguntar al soporte de la comunidad de Azure. También puede enviar comentarios sobre el producto con los comentarios de la comunidad de Azure.