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No se puede conectar a Microsoft Dynamics CRM error del servidor se produce al intentar conectarse Microsoft Dynamics CRM 2013 para Microsoft Office Outlook a CRM Online

En este artículo se proporciona una solución a un error que se produce al intentar conectar Microsoft Dynamics CRM 2013 para Microsoft Office Outlook a CRM Online.

Se aplica a: Microsoft Dynamics CRM Online
Número de KB original: 3089686

Síntomas

Al intentar conectar Microsoft Dynamics CRM 2013 para Microsoft Office Outlook (cliente de Outlook) a una organización de CRM Online, recibe el siguiente error:

"No se puede conectar a Microsoft Dynamics CRM servidor porque no podemos autenticar sus credenciales. Compruebe la conexión o póngase en contacto con el administrador para obtener más ayuda".

Al seleccionar Detalles, verá los siguientes detalles adicionales:

El valor no puede ser nulo.
Nombre del parámetro: path1
at System.IO.Path.Combine(String path1, String path2)
at Microsoft.Crm.Passport.IdCrl.FederationLogOnManager.. ctor(Entorno de cadena)
at Microsoft.Crm.Outlook.ClientAuth.PassportAuthProvider'1.GetLogonManager()
at Microsoft.Crm.Outlook.ClientAuth.PassportAuthProvider'1.SignIn()
at Microsoft.Crm.Outlook.ClientAuth.ClientAuthProvidersFactory'1.SignIn(Uri endPoint, Credential credentials, AuthUIMode uiMode, IClientOrganizationContext context, Form parentWindow, Boolean retryOnError)
en Microsoft.Crm.Application.Outlook.Config. DeploymentsInfo.DeploymentInfo.LoadOrganizations(AuthUIMode uiMode, Form parentWindow, Credential credentials)
en Microsoft.Crm.Application.Outlook.Config. DeploymentsInfo.InternalLoadOrganizations(OrganizationDetailCollection orgs, AuthUIMode uiMode, Form parentWindow)

Causa

El Asistente de inicio de sesión de Microsoft Online Services no está instalado o no se proporciona el nombre de usuario y la contraseña correctos. Si el problema se debe a un nombre de usuario o contraseña incorrectos, podrían ser las credenciales que se almacenan en caché en el Administrador de credenciales de Windows.

Solución

Si el Asistente para inicio de sesión de Microsoft Online Services no está instalado, instálelo con el vínculo adecuado siguiente. Después de la instalación, cierre y vuelva a abrir el Asistente para configuración de Microsoft Dynamics CRM para Microsoft Office Outlook.

Si el Asistente de inicio de sesión de Microsoft Online Services ya está instalado y sigue recibiendo este error, seleccione Aceptar y verá un mensaje para el nombre de usuario y la contraseña. Si el nombre de usuario y la contraseña ya están rellenados, indica que las credenciales se almacenaron en caché. Vuelva a escribir el nombre de usuario y la contraseña correctos para asegurarse de que no se usan credenciales incorrectas.

Nota:

Para ver si las credenciales se almacenan en el Administrador de credenciales de Windows, seleccione el menú Inicio en Windows y escriba Administrador de credenciales. En el área Credenciales genéricas, es posible que vea credenciales que comienzan por Microsoft_CRM. Si ha cambiado la contraseña o usa otra cuenta de usuario, es posible que estas credenciales almacenadas no sean correctas. Estas credenciales se pueden quitar, lo que impedirá que el Microsoft Dynamics CRM para Microsoft Office Outlook las use al intentar conectarse.

Si su organización de CRM Online ya se ha actualizado a la actualización de 2015 (7.0 o posterior), puede usar Microsoft Dynamics CRM 2015 para Microsoft Office Outlook que no dependa del Asistente de inicio de sesión de Microsoft Online Services.

Más información

Si el Asistente de inicio de sesión de Microsoft Online Services no está instalado, el archivo de registro contiene el siguiente error:

19:23:00| Error| Error al conectarse a la dirección URL: https://disco.crm.dynamics.com/XRMServices/2011/Discovery.svc Excepción: System.DllNotFoundException: El Asistente para inicio de sesión de Microsoft Online Services no está instalado. 32 bits: https://g.microsoftonline.com/0BX00en/500 64 bits: https://g.microsoftonline.com/0BX00en/501