No se puede conectar al mensaje de Exchange cuando se usa la aplicación Microsoft Dynamics 365 para Outlook
En este artículo se proporcionan soluciones para el problema que recibe un mensaje Can't connect to Exchange when using Microsoft Dynamics 365 App for Outlook.
Se aplica a: Microsoft Dynamics 365 Customer Engagement Online
Número de KB original: 4534356
Síntomas
Al usar la aplicación Microsoft Dynamics 365 para Outlook, verá el siguiente mensaje:
"No se puede conectar a Exchange".
El resto de la aplicación puede cargarse correctamente, pero la capacidad de realizar un seguimiento de los elementos y usar Set Regarding puede faltar.
Causa
Esto suele ocurrir cuando se usa un buzón local de Microsoft Exchange y puede deberse a una de las siguientes razones:
Causa 1: la autenticación de OAuth no está habilitada en Exchange.
Causa 2: Hay un problema con el certificado de autenticación usado por Exchange.
Resolución 1: Comprobar que la autenticación de OAuth está habilitada en Exchange
En el servidor Exchange, abra el Shell de administración de Exchange.
Ejecute el siguiente comando:
Get-WebServicesVirtualDirectory | FL server,*auth
Compruebe que los resultados devueltos muestran que OAuthAuthentication está establecido en True.
Si
OAuthAuthentication
se establece en False, es necesario ejecutar un comando como el siguiente:Set-WebServicesVirtualDirectory -Identity "EWS (Default Web Site)" -OAuthAuthentication $true
El valor de identificación es el nombre del directorio virtual que se puede encontrar en el Centro de administración de Exchange seleccionando servidores y seleccionando directorios virtuales o ejecutando el siguiente comando y revisando el valor Nombre devuelto:
Get-WebServicesVirtualDirectory | FL
Puede encontrar más información sobre este comando en Set-WebServicesVirtualDirectory.
Para obtener más información sobre los requisitos de autenticación para permitir que un complemento de Outlook realice solicitudes asincrónicas de Exchange Web Service (EWS), consulte Consideraciones sobre autenticación y permisos para makeEwsRequestAsync.
Ejecute el siguiente comando:
Get-OrganizationConfig | FL OAuth2ClientProfileEnabled
Si el valor devuelto es False, ejecute el siguiente comando:
Set-OrganizationConfig -OAuth2ClientProfileEnabled:$True
Compruebe también que la versión de Exchange tiene la actualización mencionada en Can't access EWS from Outlook/OWA add-ins via makeEwsRequestAsync in Exchange Server 2016 and Exchange Server 2013.
Resolución 2: Comprobar el certificado de Exchange
En el servidor Exchange, abra el Shell de administración de Exchange.
Ejecute el siguiente comando:
Get-AuthConfig | FL
Compruebe que los resultados muestran IsValid como True.
Copie el valor devuelto para CurrentCertificateThumbprint y úselo en el siguiente comando:
Get-ExchangeCertificate -Thumbprint <CurrentCertificateThumbprint Value>| FL
Compruebe que los resultados muestran lo siguiente:
Status = Válido
La fecha actual está dentro de las fechas NotAfter y NotBefore que indican que el certificado no ha expirado.
Si el comando anterior no recupera correctamente el certificado, esto indica un problema con la configuración del certificado que puede requerir que cree y configure un nuevo certificado. A continuación se muestran algunos recursos con pasos para crear y configurar un nuevo certificado:
Si se requiere algún cambio después de seguir los pasos anteriores, cierre y vuelva a abrir Outlook para ver si el problema se ha resuelto. Si el problema persiste y el administrador de Microsoft Exchange ha comprobado que OAuth está habilitado y el certificado es válido, es posible que sea necesario ponerse en contacto con Soporte técnico de Microsoft.