El código de error 80048539 se produce al intentar importar la revisión de la solución en Microsoft Dynamics 365
En este artículo se proporciona una resolución para el código de error 80048539 que puede producirse al intentar importar una revisión de solución en Microsoft Dynamics 365.
Se aplica a: Microsoft Dynamics 365
Número de KB original: 4471087
Síntomas
Al intentar importar una revisión de solución en Microsoft Dynamics 365, se produce el siguiente error:
Error en la importación de la solución: [nombre de revisión de la solución].
Código de error 80048539.
Si descarga el archivo de registro y lo abre en Excel, verá más detalles, como los siguientes:
Detalles del síntoma 1:
Error 0x80048539
Importación de manifiesto de solución: FAILURE: Patch version 1.0.1.0 is invalid for parent version 1.1.0.0
Detalles del síntoma 2:
Error 0x80048539
Importación del manifiesto de solución: ERROR: ya existe la solución de retención MyPatchTesting_Upgrade.
Causa
Nota:
Si usa make.powerapps.com para importar la actualización de la solución no administrada y obtener este error, Microsoft conoce el problema y está trabajando en una corrección. Para solucionar el problema, abra la configuración avanzada y seleccione la opción Actualizar (no recomendado).
El código de error 80048539 indica que se está importando una revisión no válida. Hay algunas causas posibles, entre las que se incluyen las siguientes:
Causa 1
Si ve los detalles del error mencionados en la sección Detalles del síntoma 1 mencionado anteriormente:
La versión de revisión de la solución es inferior a la versión de la solución ya instalada. Por ejemplo: una solución denominada SolutionA ya está instalada con la versión 1.1.0.0 y está intentando importar una revisión que sea la versión 1.0.1.0.
Causa 2
Si ve los detalles del error mencionados en la sección Detalles del síntoma 2 mencionado anteriormente:
Esto puede ocurrir si ya tiene una actualización importada para esa solución, pero aún no se ha aplicado. Después de importar una solución que sea una actualización de una solución existente, el final de la importación de la solución proporciona un botón para aplicar la actualización de la solución. Si no seleccionó ese botón durante una importación anterior de una actualización de la solución para esta solución, debe buscar la solución en la lista de soluciones y seleccionar el botón Aplicar actualización de la solución.
Solución
Resolución 1
Si ve los detalles del error mencionados en la sección Detalles del síntoma 1 mencionado anteriormente:
Compruebe que la versión de revisión de la solución que está intentando importar es una versión superior a la de la solución ya instalada.
Resolución 2
Si ve los detalles del error mencionados en la sección Detalles del síntoma 2 mencionado anteriormente:
Vaya a Configuración, Personalizaciones y, a continuación, seleccione Soluciones. Seleccione la solución instalada existente que está intentando actualizar y, a continuación, seleccione Aplicar actualización de la solución.