Compartir a través de


Código de error: 2147812097 licencia no válida: esta aplicación requiere una licencia y no tiene asignada una licencia adecuada.

En este artículo se proporciona una solución a un error que se produce al intentar acceder a un módulo de aplicación (aplicación empresarial) que requiere una licencia adecuada y no se asigna.

Se aplica a: Microsoft Dynamics CRM Online
Número de KB original: 4548022

Síntomas

Cuando un usuario intenta acceder a un módulo de aplicación (aplicación empresarial) que requiere una licencia adecuada y no está asignado, el usuario recibe el siguiente mensaje de error:

Esta aplicación requiere una licencia y no tiene la licencia adecuada para acceder a esta aplicación. Póngase en contacto con el administrador para obtener la licencia adecuada asignada, según los detalles proporcionados.
Detalles
El usuario no tiene una licencia para acceder a este módulo de aplicación uniqueName= unique name> con Id=<Id> from publisher=<publisher name>.< Se requiere una licencia con uno de los planes de servicio: <Nombre> del plan de servicio: <Identificador> del plan de servicio. Consulte el vínculo del artículo <a esta BASE de conocimientos> para obtener más información.

Causa

Este problema se produce cuando una aplicación requiere una licencia y el administrador no ha asignado la licencia adecuada a los usuarios de la aplicación.

Por ejemplo, si el usuario con una licencia de miembro del equipo intenta acceder a la aplicación Customer Service Hub, el usuario verá este error:

Esta aplicación requiere una licencia y no tiene la licencia adecuada para acceder a esta aplicación. Póngase en contacto con el administrador para obtener la licencia adecuada asignada, según los detalles proporcionados.

Detalles

El usuario no tiene ninguna licencia para acceder a este módulo de aplicación uniqueName= Customerservicehub desde publisher= dynamics365customerengagement. Se requiere una licencia con uno de los planes de servicio: "Dynamics 365 para el servicio de atención al cliente: <GUID>

Solución

La resolución consiste en ponerse en contacto con el administrador y solicitar que se asigne la licencia. El nombre de la licencia y los nombres de la aplicación están presentes en los detalles del error.

Captura de pantalla del error de licencia de miembro del equipo de Dynamics.

Acceso a aplicaciones personalizadas:

Para acceder a aplicaciones personalizadas (basadas en lienzos o modelos), es preciso que se le asigne una licencia de Dynamics 365 Enterprise o Professional, un plan de usuario de Power AppsPer o que al entorno se le den planes de aplicación de Power Appsper (también conocidos como pases de aplicación). Para obtener más información sobre los planes de aplicaciones de Power Appsper (también conocido como pases de aplicación), consulte Acerca de Power Apps por planes de aplicación.