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Ya no tiene permiso para acceder a Management Reporter después de realizar cambios en el dominio.

En este artículo se proporciona una resolución para el problema de permisos que se produce después de realizar cambios en el dominio.

Se aplica a: Microsoft Management Reporter 2012, Microsoft Dynamics GP, Microsoft Dynamics AX 2009, Microsoft Dynamics SL 2015, Microsoft Dynamics SL 2011
Número de KB original: 3163587

Síntomas

Después de realizar cambios en el dominio, los usuarios no pueden acceder a Management Reporter.

Causa

El SID de Windows ha cambiado para el usuario y ya no es válido.

Solución

Actualice el SID de Windows para un usuario que tenga el rol de administrador en Management Reporter.

  1. Inicie sesión en SQL Server como uno de los usuarios que tiene el rol Administrador en Management Reporter.

  2. Seleccione Iniciar>ejecución y escriba CMD.

    1. En el comando Dos, escriba:

      Whoami /user

    2. En la ventana DOS, haga clic con el botón derecho, seleccione Seleccionar todo y presione Entrar.

    3. Pegue la información en el Bloc de notas.

  3. Abra SQL Server Management Studio y ejecute la siguiente instrucción SQL en la base de datos de Management Reporter.

    1. Management Reporter 2012 CU13 y versiones posteriores

      SELECT A.UserName, 
      B.Name, 
      CASE A.ROLETYPE 
      WHEN 2 THEN 'VIEWER' 
      WHEN 3 THEN 'GENERATOR' 
      WHEN 4 THEN 'DESIGNER' 
      WHEN 5 THEN 'ADMINISTRATOR' 
      END AS SecurityRole, 
      A.WindowsSecurityIdentifier, 
      A.UserID, 
      CASE A. AccountDisabled 
      When 0 Then 'Enabled' 
      When 1 Then 'Disabled'
      End AS AccountStatus 
      FROM Reporting.SecurityUser A 
      JOIN Reporting.SecurityPrincipal B 
      ON A.USERID = B.ID 
      ORDER BY A.UserName
      
    2. Management Reporter CU12 o versiones anteriores.

      SELECT A.UserName, 
      B.Name, 
      CASE A.ROLETYPE 
      WHEN 2 THEN 'VIEWER' 
      WHEN 3 THEN 'GENERATOR' 
      WHEN 4 THEN 'DESIGNER' 
      WHEN 5 THEN 'ADMINISTRATOR' 
      END AS SecurityRole, 
      A.WindowsSecurityIdentifier, 
      A.UserID, 
      CASE A. AccountDisabled 
      When 0 Then 'Enabled' 
      When 1 Then 'Disabled'
      End AS AccountStatus 
      FROM SECURITYUSER A 
      JOIN SECURITYPRINCIPAL B 
      ON A.USERID = B.ID 
      ORDER BY A.UserName
      
  4. Tenga en cuenta el id. de usuario.

  5. Realice una copia de seguridad de la base de datos de Management Reporter y ejecute la siguiente instrucción SQL. Debe modificar la instrucción para incluir el SID de Windows del nuevo usuario y su UserID existente.

    1. Management Reporter CU13 o posterior

      UPDATE Reporting.SecurityUser 
      SET WindowsSecurityIdentifier = '<copy/paste new Windows SID>' 
      WHERE UserID = '<paste UserId from step4>'
      
    2. Management Reporter CU12 o versiones anteriores

      UPDATE SecurityUser 
      SET WindowsSecurityIdentifier = '<copy/paste new Windows SID>' 
      WHERE UserID = '<paste UserId from step4>'
      
  6. Ejecute la siguiente instrucción SQL, modificando la instrucción para incluir el dominio\alias del nuevo usuario.

    1. Management Reporter 2012 CU13 o posterior.

      UPDATE Reporting.SecurityPrincipal 
      SET Name = '<enter new domain\alias>' 
      WHERE ID = '<paste UserId from step4>'
      
    2. Management Reporter 2012 CU12 o versiones anteriores

      UPDATE SecurityPrincipal 
      SET Name = '<enter new domain\alias>' 
      WHERE ID = '<paste UserId from step4>'
      
  7. El usuario debería poder iniciar sesión ahora en Management Reporter. Para actualizar los demás usuarios, seleccione Seguridad. Seleccione Usuarios y quite los usuarios que no pueden acceder a Management Reporter. A continuación, puede volver a agregar los usuarios con su nuevo nombre de dominio.