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Los cheques no se cargan en la ventana de carga de SafePay-Transactions en Microsoft Dynamics GP

En este artículo se proporciona una solución a un problema por el que los cheques no se cargan en la ventana de carga de SafePay-Transactions en Microsoft Dynamics GP.

Se aplica a: Microsoft Dynamics GP
Número de KB original: 2708664

Síntomas

Los cheques no se rellenan en la ventana de Carga de Transacciones de SafePay al seleccionar el botón Cargar o Volver a Cargar Transacciones.

Causa

Hay varias razones por las que es posible que las comprobaciones no rellenen la ventana Carga de transacciones safePay, entre las que se incluyen:

  • El ID del talonario de cheques en el que se generó el cheque no está vinculado al ID de carga del banco en SafePay.
  • La fecha de verificación no se encuentra dentro del intervalo entre la Fecha de última carga y la Fecha límite de carga especificado en la ventana Carga de SafePay-Transactions.
  • La comprobación ya se ha cargado en un archivo SafePay.
  • Los códigos de transacción no se han definido en el configurador safepay.
  • El cliente no está registrado para el módulo conciliación bancaria.
  • SafePay Configurator tiene una configuración marcada para omitir los cheques que comienzan con caracteres alfabéticos.
  • Se eliminó el prefijo DD del número de la siguiente Declaración de Ganancias en Nómina, por lo que el sistema trata todos los cheques como depósitos directos y no los incluye en la carga de SafePay.

Solución

Método 1 - El ID del talonario no está vinculado al ID de carga bancaria en SafePay.

Siga estos pasos para asegurarse de que el identificador del cheque esté vinculado al identificador de carga del banco que está utilizando en SafePay:

  1. Seleccione Herramientas en el menú microsoft Dynamics GP, seleccione Configurar, comprar y, a continuación, seleccione Pagaderos. Revise cuál es el ID de chequera predeterminado para cuentas por pagar y, a continuación, seleccione Aceptar para cerrar la ventana.

    Nota:

    Si también establece un identificador de chequera predeterminado a nivel del proveedor, puede que también quiera comprobar el identificador de chequera predeterminado asignado a los proveedores.

  2. Seleccione Herramientas en el menú de Microsoft Dynamics GP, apunte a Rutinas, apunte a Financiera, apunte a Safe Pay y, a continuación, seleccione Subir Mantenimiento.

  3. Seleccione el ID de carga bancaria que está utilizando en el menú desplegable.

  4. Revise los identificadores de talonario enumerados. Si el identificador del talonario que desea no aparece, haga clic en Agregar talonario para seleccionar un identificador de talonario que se vinculará a este ID de carga bancaria.

  5. Guarde los cambios y vuelva a probarlo.

Método 2 : la fecha de comprobación no se encuentra dentro del intervalo Fecha de última carga y Fecha límite de carga especificado en la ventana SafePay-Transactions Upload (Carga de transacciones seguras).

Asegúrese de que hay cheques emitidos entre la fecha de última carga y la fecha límite de carga usada en la ventana Carga de Transacciones SafePay.

  1. Anote la fecha del problema de una comprobación de ejemplo.

  2. En la ventana Carga de safePay-Transactions, asegúrese de que esta fecha se encuentra entre la fecha de última carga y la fecha límite de carga.

Método 3 : las comprobaciones ya se han cargado en un archivo SafePay.

Revise para ver si las comprobaciones que intenta cargar ya se han cargado. Siga estos pasos para revisar el historial de transacciones:

  1. Seleccione Herramientas en el menú de Microsoft Dynamics GP, seleccione Rutinas, Finanzas, Pago seguro y, a continuación, Historial de transacciones.

  2. Escriba el identificador de carga del banco (al que está vinculado el identificador de la chequera).

  3. Use los botones de desplazamiento izquierdo/derecho para desplazarse por todos los identificadores de carga bancaria. Revise los detalles de la transacción en la parte inferior de la ventana para ver si los números de comprobación que está intentando cargar ya se han cargado.

  4. Seleccione Cargar en la parte superior de la ventana Cargar historial de transacciones para volver a generar el archivo SafePay para el id. de carga seleccionado en la ventana.

Método 4 : los códigos de transacción no se han definido en safepay Configurator.

Los códigos de transacción deben obtenerse del banco y escribirse en la ventana de introducción de códigos en la configuración del Configurator de Safepay. Estos son códigos que el banco usa para distinguir cheques, anulaciones y pagos EFT entre sí en el archivo. El sistema reemplazará el código adecuado especificado en el archivo De pago seguro generado para el campo Tipo de transacción asignado. Para definir los códigos de transacción en el configurador, siga estos pasos:

  1. Abra el archivo configurador. Para ello, seleccione Herramientas en Microsoft Dynamics GP, seleccione Rutinas, Finanzas, Pago seguro y Configurator.

  2. En la ventana Configuración de pago seguro, seleccione el identificador de formato de banco que usa.

  3. En la barra de menús superior, seleccione Entrada de códigos y, a continuación, seleccione Entrada de códigos de transacción. (Debe obtener los códigos que necesita introducir desde el Banco antes de realizar este paso. O puede saber si examina el archivo de importación bancaria).

  4. En la ventana Entrada de tipos de transacción:

    1. Seleccione Comprobar el tipo de transacción y escriba el código coincidente del banco que significa comprobar.

    2. Seleccione Void en Tipo de transacción y escriba el código coincidente del banco que significa void. También hay una opción para Voids Zero Amount. Marque si desea que la cantidad de transacciones anuladas sea de 0,00, o déjela sin marcar para que la cantidad original aparezca en la transacción anulada en el archivo SafePay.

    3. Seleccione EFT para tipo de transacción y escriba el código coincidente del banco que significa EFT. Si el banco no tiene un código específico para EFT, introduzca el mismo código que especificó para el tipo Cheque, ya que muchos bancos simplemente consideran los EFTs y los cheques del mismo tipo.

    4. Seleccione Guardar y cierre la ventana. Seleccione Guardar de nuevo en la ventana del Configurador de Pago Seguro y pruebe si la ventana de Carga de Pago Seguro se rellena ahora.

Método 5 : el cliente no está registrado para el módulo conciliación bancaria.

SafePay extrae de la tabla de CM20200 en la conciliación bancaria. Por lo tanto, el cliente debe estar registrado en Conciliación Bancaria para usar SafePay.

Opción 1: póngase en contacto con su partner para revisar los módulos para los que está registrado el cliente o para comprar el módulo conciliación bancaria.

Opción 2: si la tabla SQL (CM20200) está vacía, es probable que no esté registrada para conciliación bancaria. Puede usar SQL Server Management Studio para revisar la tabla SQL.

Método 6 - Si los cheques tienen un prefijo, se pueden omitir al cargar la ventana de Carga de Transacciones Safepay debido a una casilla marcada dentro de la configuración. Vaya al configurador Safepay, seleccione el ID de formato, seleccione Introducción de códigos | Introducción de códigos de transacción y seleccione Cheques. Compruebe que la casilla "Omitir comprobaciones con alfas" no está marcada. Si está marcado, las comprobaciones que comiencen con caracteres alfa no cargarán la ventana Carga de transacciones safepay.

Método 7 - El prefijo DD se quitó del Número del Siguiente Estado de Ganancias en Nómina, por lo que el sistema trata todos los cheques como depósitos directos y no los incluye en la carga de Safepay.

El procedimiento almacenado que se usa para rellenar la ventana SafePay-Transactions verá el prefijo asignado al siguiente número de Informe de Ingresos en nómina, ya sea que esté usando la nómina de EE. UU. o el depósito directo, o no. El sistema comparará todas las comprobaciones con el siguiente número de declaración de ganancias para determinar si es un depósito directo o no. Por lo tanto, si un usuario quita el prefijo DD predeterminado, el sistema tratará todas las comprobaciones como depósitos directos que comienzan con el mismo dígito y no los rellenarán en la ventana Carga de transacciones de SafePay. Por ejemplo, si el siguiente número de declaración de ganancias para depósitos directos comienza con 0, el sistema también tratará todos los cheques que también comienzan con 0 como depósitos directos y no los incluyen en SafePay. Siga estos pasos para revisar:

  1. Seleccione Herramientas en el menú microsoft Dynamics GP, seleccione Configurar, seleccione Nómina y, a continuación, seleccione Depósito directo.

  2. Asegúrese de que el prefijo DD está al principio del siguiente número de declaración de ganancias. Agregue el prefijo DD al principio del siguiente número de declaración de ganancias si es necesario.

  3. Seleccione Aceptar para cerrar la ventana.

Nota:

El procedimiento almacenado comprobará el número de la siguiente declaración de ganancias, ya sea que esté usando nómina o depósito directo.