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Los informes financieros de Management Reporter no coinciden con los informes de saldo de prueba de General Ledger en Microsoft Dynamics GP

Se aplica a: Microsoft Dynamics GP
Número de KB original: 2910626

Síntomas

Se pueden usar muchas herramientas de informes diferentes para preparar los informes financieros que se usan para equilibrar el informe de equilibrio de evaluación de GL en Microsoft Dynamics GP. Por lo tanto, debe determinar si los informes financieros solo leen datos de GL o si también se usan datos de AA. Si se usan datos de AA para preparar los informes financieros, se pueden sesgar si los datos de las tablas de AA no coinciden con los datos de las tablas de GL.

  • Management Reporter con Data Mart leerá de las tablas de AA si se ha activado AA. Esto es por diseño en versiones de hasta CU9.
  • Management Reporter con el proveedor heredado le permite elegir si desea extraer de una empresa de AA o de una empresa de GL.

Causa

Los informes financieros pueden ser incorrectos, si se usaron datos de AA para ensamblar el informe y los datos de AA no coinciden con los datos de GL. Es posible que falten registros de las tablas de AA o que se omitan si difieren del registro correspondiente en GL.

Hay varias razones por las que es posible que los datos de AA no coincidan con los datos de GL o que tengan problemas, entre los que se incluyen:

  • El módulo de contabilidad analítica no se ha instalado en todas las estaciones de trabajo, donde los usuarios están registrando o contabilizando transacciones. Por lo tanto, el registro existe en GL, pero no en AA.
  • Los usuarios deshabilitan el módulo De contabilidad analítica si reciben algún error que haga referencia a "aa", por lo que las tablas de AA no se actualizan.
  • Los registros se importan directamente en tablas gl y no en tablas de AA. O bien, los usuarios deshabilitan AA si reciben errores "aa" durante el proceso de importación.
  • Los usuarios cierran el año de GL en una estación de trabajo en la que no se ha instalado AA. Como resultado, los registros de AA no se mueven al historial y no se crea ninguna entrada de diario balance traído hacia delante en las tablas de AA.
  • Management Reporter no puede leer el registro de AA si el identificador de moneda difiere entre el registro AA y el registro correspondiente en GL, lo que podría deberse a la importación de registros, la activación de la simultaneidad múltiple o cualquier problema de calidad con los identificadores de moneda que se han corregido desde entonces.
  • La base de datos de Dynamics se ha restaurado por sí misma, lo que hace que el "siguiente número disponible" (en la tabla de AAG00102) se vuelva a establecer en un valor que ya se ha usado. Este sistema incrementará el valor de este valor para el siguiente valor de id. de encabezado a medida que inserta nuevos registros en la tabla, por lo que puede duplicarse si se inserta en un valor de id. oído que ya se ha usado.
  • Si actualiza a Microsoft Dynamics GP 2013 y establece un identificador de moneda funcional, pero no está registrado para multidivisa, o no ejecuta vínculos de comprobación como se indica después de configurar la moneda funcional.
  • Contabilización de interrupciones

Solución

Si necesita ayuda para corregir cualquiera de los resultados devueltos de los scripts siguientes, abra un incidente de soporte técnico con las categorías siguientes para llegar al equipo de ingenieros de soporte técnico correcto. Incluya la información como se indica en cada paso.

  • Para abrir un incidente de soporte técnico en línea, use este vínculo: https://serviceshub.microsoft.com/supportforbusiness.
  • Use el tema de soporte técnico: Contabilidad financiera y analítica y el sub-tema: Problemas de coherencia de datos.
  • Para comunicarse con el Centro de mensajes para abrir un incidente de soporte técnico, llame al 1-888-477-7877. Y proporcione tantos detalles como pueda.
  • Tenga en cuenta que el incidente de soporte técnico puede tardar mucho tiempo, por lo que debe dejar tiempo suficiente para trabajar con el ingeniero.
  • El incidente de soporte técnico se cobrará a menos que se determine que la única causa es un problema de calidad conocido en Microsoft Dynamics GP. Si se solucionan varios problemas, el caso seguirá cobrando.
  • El ámbito del incidente de soporte técnico incluirá la corrección de todos los datos devueltos por los scripts SQL siguientes, dentro de las directrices de lo que podemos hacer en un caso de soporte técnico normal. Si se necesita ayuda adicional para encontrar la "causa principal", esto requerirá que se abra un nuevo incidente de soporte técnico. Algunas de las causas son comunes, como se explica en la sección Causa anterior. Sin embargo, por ejemplo, si determina que existe una diferencia de identificador de moneda en los registros que se importaron en Microsoft Dynamics GP, esto requeriría que se abra un nuevo incidente de soporte técnico para trabajar con el equipo de soporte técnico de eConnect/Integration Manager. El ingeniero mantiene la discreción de informar cuando se necesita un nuevo incidente de soporte técnico o cuándo puede convertirse en una contratación de consultoría.
  • Un caso de soporte técnico se puede abrir inicialmente, con los resultados de todos los scripts de los pasos 1 a 10 siguientes. El Ingeniero trabajará con usted en una empresa, y se espera que corrija las otras compañías por su cuenta, siguiendo los mismos pasos que el Ingeniero le proporcionó para la primera empresa. La asistencia adicional con varias empresas puede requerir un nuevo caso y depende de la discreción del Ingeniero.

Pasos

Nota:

Para ver los resultados de cada script en Texto, puede presionar ALT - T (o seleccionar Consulta en la barra de menús superior, apuntar a Resultados a y seleccionar Resultados en Texto) y, a continuación, volver a ejecutar el script. Esto proporcionará más detalles para cada sección de resultados devueltos.

El archivo KB_AllAAFindScripts.zip contiene todos los scripts para los pasos 2,3,4,6 y 9, por lo que solo tiene que descargarlo una vez, pero se proporciona el mismo vínculo en todos estos pasos.

Paso 1: años distintos

Ejecute los scripts siguientes para comprobar que los años son distintos en cada tabla y no se superponen entre sí, y también son coherentes con los años de las tablas de GL. Los mismos años deben estar en la AAG30000 que la tabla GL20000 y la tabla AAG40000 con la tabla GL30000. No se deben superponer años entre las tablas de AA o entre las tablas de GL. Si encuentra el mismo año en tablas abiertas y de historial o entre tablas, o no es coherente con los años de las tablas de GL, abra un caso de soporte técnico para obtener más ayuda e incluya los resultados de todos los scripts.

select distinct(YEAR1) from AAG30000 order by YEAR1
select distinct(YEAR1) from AAG40000 order by YEAR1
select distinct(OPENYEAR) from GL20000 order by OPENYEAR
select distinct(HSTYEAR) from GL30000 order by HSTYEAR

Paso 2: Buscar discrepancias de identificador de moneda

Descargue el archivo KB_AllAAFindScripts.zip* y use el script de AA_FindCurrencyDiscrepancy.sql del paso 2 para identificar las transacciones en las que el identificador de moneda no coincide entre las tablas GL y AA tanto en el historial como en el abierto:

https://mbs2.microsoft.com/fileexchange/?fileID=622816f0-ae1d-4768-a914-e710ec50f411

(*El archivo zip contiene los scripts de los pasos 2, 3, 4, 6 y 9).

  • Si no usa multidivisa o solo usa un identificador de moneda, puede actualizar los campos CURNCYID y CURRNIDX directamente en las tablas AA (AAG30001/AAG40002) o GL (GL20000/GL30000). Pruebe para asegurarse de que el identificador de moneda coincide con las transacciones con clave recientemente para asegurarse de que no hay un problema en curso. Abra un incidente de soporte técnico si necesita ayuda para actualizar CURNCYID directamente en la tabla SQL o si puede volver a crearlo en una transacción actual.

  • Si se usa la simultaneidad múltiple, abra un incidente de soporte técnico e incluya lo siguiente:

    • Proporcione los resultados del script en formato de texto. Necesitamos saber qué tabla tenía el identificador de moneda y qué tabla no. ¿Y son estas transacciones más antiguas o más recientes? Si las transacciones anteriores y acaba de instalar Administración de simultaneidad múltiple, ¿ha ejecutado vínculos de comprobación en el programa de instalación de simultaneidad múltiple? Compruebe que los vínculos deben volver atrás y actualizar el identificador de moneda en todas las transacciones existentes.

    • ¿Qué versión de Microsoft Dynamics GP usa?

    • ¿De dónde proceden las transacciones? Pruebe para ver si se trata de un problema en curso. Compruebe si Administración de simultaneidad múltiple está marcada en la ventana Registro (en Microsoft Dynamics GP, vaya aRegistrodel sistema>de configuración> de herramientas>).

    • ¿Cuál es su moneda funcional? ¿Cuántos identificadores de moneda usa?

Paso 3: Búsqueda de distribuciones no coincidentes

Descargue el archivo KB_AllAAFindScripts.zip* y use AA_FindUnmatchedDists.sql script del paso 3 para identificar si los datos detallados no coinciden entre las tablas AA y GL. Si se devuelve algún resultado, abra un caso de soporte técnico para obtener más ayuda. Y adjunte el archivo de resultados en formato de texto. Estos registros de problemas suelen deberse a problemas de importación o a usuarios que trabajan en una estación de trabajo en la que AA se deshabilitó o no se instaló.

https://mbs2.microsoft.com/fileexchange/?fileID=622816f0-ae1d-4768-a914-e710ec50f411

(*El archivo zip contiene los scripts de los pasos 2, 3, 4, 6 y 9).

Nota:

Este script no debe usarse para versiones inferiores a Microsoft Dynamics GP 10.0 SP2 o donde aún no haya completado un cierre de fin de año de GL en una versión superior a esa (es decir, donde los datos anteriores a SP2 AA aún no se han movido al historial).

tenga en cuenta que los "totales de resultados" pueden mostrarse entre las secciones y son engañosos. Estos totales de resultados son un factor de cómo se escribió el script y se pueden omitir. Solo debe preocuparse por los "totales de resultados" que se encuentran inmediatamente después de una "sección" y que devuelven datos reales.

Paso 4: Búsqueda de identificadores de código AA duplicados

Descargue el archivo KB_AllAAFindScripts.zip* y busque el script de AA_FindDupaaTrxDimCodeID_AAG00401.sql del paso 4 para ver si hay algún identificador de código AA duplicado (debido a la importación). Si se devuelve algún resultado, abra un caso de soporte técnico para obtener más ayuda. Adjunte los resultados del script en formato de texto y también el contenido de la tabla de AAG00401. Podemos proporcionarle los pasos necesarios para resolverlo, pero hacer que Microsoft lo haga por usted puede ser un gasto de consultoría. Este problema se debe a la importación o la restauración de una copia anterior de la base de datos de Dynamics por sí misma.

https://mbs2.microsoft.com/fileexchange/?fileID=622816f0-ae1d-4768-a914-e710ec50f411

(*El archivo zip contiene los scripts de los pasos 2, 3, 4, 6 y 9).

Paso 5: Búsqueda de identificadores de encabezado AA duplicados

Ejecute el script siguiente para determinar si tiene identificadores de encabezado duplicados entre las tablas abiertas e históricas de AA. Podemos proporcionar los pasos para resolver esto, pero hacer que Microsoft lo haga por usted puede ser un gasto de consultoría. Este problema se debe a la importación, la restauración de una copia anterior de la base de datos de Dynamics por sí misma o una interrupción de la publicación.

select aaGLHdrID from AAG30000 where aaGLHdrId in (select aagLHDrId from AAG40000)

o

select a.aaGLHdrID, a.JRNENTRY as OPEN_JE#,a.YEAR1 as 'OPEN_YEAR1',
b.JRNENTRY as 'HIST_JE#', b.YEAR1 as 'HIST_YEAR1' From AAG30000 a (nolock)
join AAG40000 b (nolock) on a.aaGLHdrID = b.aaGLHdrID
where a.JRNENTRY <> b.JRNENTRY

Si se devuelve algún resultado, abra un caso de soporte técnico e incluya la siguiente información:

  • Resultados del script en formato de texto.
  • Investigue los registros y avise si son exactamente el mismo registro o si son registros diferentes, pero solo tienen el mismo identificador de encabezado.

Paso 6: Buscar números de secuencia no coincidentes (para entradas P&L)

Descargue el archivo KB_AllAAFindScripts.zip* y ejecute el script de AA_FindYEC_RetainedEarnings.sql para buscar registros en los que los números de secuencia no coincidan entre AA y GL entre las tablas abiertas y las tablas de historial para la entrada de diario Ganancias retenidas (SOURCDOC ='P&L'). Si se devuelven resultados, abra un caso de soporte técnico e incluya los resultados del script en formato de texto. (Tenga en cuenta que si ha tenido algún resultado en el paso 3 anterior para las secciones "GLSEQNMBR", queremos que los corrija primero y, a continuación, vuelva a ejecutar este script para el paso 6, por lo que no necesitamos sus resultados ahora para el paso 6 si tenía resultados en el paso 3).

https://mbs2.microsoft.com/fileexchange/?fileID=622816f0-ae1d-4768-a914-e710ec50f411

(*El archivo zip contiene los scripts de los pasos 2, 3, 4, 6 y 9).

Nota:

Es posible obtener resultados con este script anterior si actualmente tiene entradas P&L con varias líneas de distribución con el mismo ACTINDX y los datos son realmente válidos. Debe comparar el SEQNUMBR entre el AAG30001 y el GL20000 (o AAG40001 y GL30000) para los resultados devueltos y, si el SEQNUMBR coincide, puede omitir los errores de validación de MR para SEQNUMBR y continuar.

Paso 7: Búsqueda de entradas BBF que faltan

Si descubre que los informes financieros están desactivados por el importe de los saldos iniciales, es posible que falten las entradas de Saldo presentado (BBF) en las tablas de AA. Ejecute los scripts siguientes para determinar si faltan las entradas BBF en GL de las tablas de AA. Esto se debe a que el usuario cierra el año de GL en una estación de trabajo donde AA se deshabilitó o no se instaló. Para Microsoft Dynamics GP 2013 SP2 y versiones anteriores, deberá tener abierto un servicio de consultoría para volver a abrir el año de GL. Si es Microsoft Dynamics GP 2013 R2 o versiones posteriores, puede usar la casilla Año histórico inverso en la rutina de cierre de fin de año de GL para volver a abrir el año y, a continuación, volver a incluirlo en una máquina donde esté instalado el código de AA, de modo que las entradas de BBF se creen en las tablas AA y GL.

PRINT 'OPEN year missing BBF'
Select distinct (JRNENTRY) from GL20000
where JRNENTRY not in (select JRNENTRY from AAG30000)
and SOURCDOC in ('BBF','P/L')
PRINT 'HISTORY year missing BBF'
Select distinct (JRNENTRY) from GL30000
where JRNENTRY not in (select JRNENTRY from AAG40000)
and SOURCDOC in ('BBF','P/L')

Paso 8: Problema conocido para los presupuestos de AA (solo en Microsoft Dynamics GP 2010 y Microsoft Dynamics GP2013)

En Microsoft Dynamics GP 2013 y Microsoft Dynamics GP 2010, se produjo un problema de calidad conocido (69354 TFS/69692 PS) en el que el nivel superior del árbol presupuestario tendrá un valor incorrecto en la tabla AAG00902 (aaLvlCodeString campo) si continúa modificando el presupuesto. Management Reporter busca un valor en blanco en este campo para identificar el registro principal del árbol presupuestado, por lo que este valor incorrecto hace que se produzcan errores en los informes de MR y no se devuelvan datos presupuestados de AA. Este problema se ha corregido en Microsoft Dynamics GP 2013 R2 (12.00.1745). A continuación se proporcionan scripts SQL para ejecutarse en la base de datos de la empresa para buscar este problema y también para resolverlo.

Select * from AAG00902 where aaLvlCodeString <> '' and aaLevel = 0

Si el script anterior devuelve resultados, puede resolver el problema ejecutando este script en la base de datos de la empresa:

update AAG00902 set aaLvlCodeString = '' where aaLevel = 0

Paso 9: los totales de suma de AAG30002/AAG40002 no coinciden con AAG30001/AAG40001

La suma de los registros asignados en las tablas AAG30002/AAG40002 debe coincidir con la suma de los importes de las tablas de distribución de AAG30001/AAG40001 por transacción. Si los importes se asignan a varios códigos AA, puede tener un número diferente de registros entre estas tablas, pero la parte importante es que coinciden en el total de "suma" por transacción. Los informes de MR no leerán los registros si los totales de suma no coinciden entre estas tablas para cada transacción. Descargue los scripts de "búsqueda y comparación" para los años abiertos e históricos siguientes y ejecútelos en la base de datos de la empresa.

Nota:

Si ha tenido algún resultado en el paso 3 anterior para las secciones "AAG30002/AAG40002", queremos que los corrija primero y, a continuación, vuelva a ejecutar este script para el paso 9, por lo que no necesitamos los resultados ahora para el paso 9 si tenía resultados en el paso 3.

Descargue el archivo KB_AllAAFindScripts.zip* del vínculo siguiente y use el AA_CompareAAG30001AndAAG30002SummaryValues.sql para el año abierto actual de AA para el paso 9 y el script de AA_CompareAAG40001AndAAG40002SummaryValues.sql del año histórico para el paso 9.

https://mbs2.microsoft.com/fileexchange/?fileID=622816f0-ae1d-4768-a914-e710ec50f411

(*El archivo zip contiene los scripts de los pasos 2, 3, 4, 6 y 9).

Si se devuelven resultados de cualquiera de los scripts, guarde los resultados en un .rpt archivo y abra un caso de soporte técnico para obtener más ayuda. Adjunte los resultados para su revisión.

Paso 10: Débitos o créditos en la misma línea de distribución

MR no puede leer los registros en los que los campos de débito y crédito se rellenan en la misma línea de distribución. Las causas conocidas pueden ser "importar" en los registros de esa condición o haber usado la Utilidad de costos estándar en el inventario con una invalidación. Puede ejecutar los scripts de consulta SQL siguientes en la base de datos de la empresa para ayudar a identificar estos registros. Para corregir los registros, deberá actualizar el registro directamente en las tablas SQL de GL/AA para "net" el importe en el campo débito o crédito, ya que solo se debe rellenar uno de estos campos. Se recomienda corregir cada registro manualmente uno por uno mediante el Dex_Row_Id. (Si necesita scripts para hacerlo en masa, consulte a su partner de Microsoft para obtener ayuda). Use los scripts siguientes para buscar los registros de problemas:

select JRNENTRY,CRDTAMNT,DEBITAMT,ORCRDAMT,ORDBTAMT,* from GL10001 where (CRDTAMNT<>0 and DEBITAMT<>0) or (ORCRDAMT<>0 and ORDBTAMT<>0) 
select JRNENTRY,CRDTAMNT,DEBITAMT,ORCRDAMT,ORDBTAMT,* from GL20000 where (CRDTAMNT<>0 and DEBITAMT<>0) or (ORCRDAMT<>0 and ORDBTAMT<>0) 
select JRNENTRY,CRDTAMNT,DEBITAMT,ORCRDAMT,ORDBTAMT,* from GL30000 where (CRDTAMNT<>0 and DEBITAMT<>0) or (ORCRDAMT<>0 and ORDBTAMT<>0) 
--if using AA, also compare the AA tables:

select AAG0.JRNENTRY  from AAG30001 AAG1
join AAG30000 AAG0 on AAG0.aaGLHdrID = AAG1.aaGLHdrID
where ((AAG1.DEBITAMT <> 0 and AAG1.CRDTAMNT <> 0) or (AAG1.ORDBTAMT <> 0 and AAG1.ORCRDAMT <> 0)) and AAG1.SOURCDOC not in ('BBF','P/L')

select AAG0.JRNENTRY  from AAG40001 AAG1 join AAG40000 AAG0 on AAG0.aaGLHdrID = AAG1.aaGLHdrID 
where ((AAG1.DEBITAMT <> 0 and AAG1.CRDTAMNT <> 0) 
or (AAG1.ORDBTAMT <> 0 and AAG1.ORCRDAMT <> 0)) 
and AAG1.SOURCDOC not in ('BBF','P/L')

Paso 11: Recompilar el data mart

Una vez corregidos todos los resultados anteriores, vuelva a ejecutar cada script para asegurarse de que ya no se devuelvan resultados.

A continuación, vuelva a generar Data Mart en Management Reporter y vuelva a generar los informes financieros. (Con SQL Change Tracking, algunos cambios pueden actualizarse automáticamente, pero no todos, por lo que consideramos que es recomendable volver a generar Data Mart si se han realizado cambios directamente en SQL para asegurarse de que se reconocen todos los cambios). Estos son los pasos para hacerlo (por precaución, puede hacer una copia de seguridad de la base de datos DDM, ya que se eliminará y se volverá a crear):

  1. Abra la consola de configuración en el servidor desde el menú Inicio .
  2. En el panel de navegación izquierdo, seleccione Integraciones ERP.
  3. Seleccione la integración que se usa (anote el nombre del servidor y los nombres de base de datos) y deshabilite la integración con el botón "Deshabilitar integración".
  4. Seleccione Quitar para quitar la integración de ERP.
  5. Seleccione Management Reporter Services en el panel de navegación izquierdo y detenga ambos servicios de Management Reporter.
  6. Elimine la base de datos DDM en SQL (puede realizar primero una copia de seguridad, si es necesario).
  7. Inicie Management Reporter Services.
  8. Vuelva a configurar la integración de ERP; para ello, vaya aConfiguraciónde archivos>.
  9. Una vez completada la configuración, habilite las integraciones de ERP.

Con los datos de AA corregidos, y el mr actualizado DDM debe extraer los valores correctos.

Paso 12: Comprobación de los saldos del informe

Determine si el informe se equilibra con el informe balance de evaluación de GL o no. Si no es así, vea si puede determinar cuál es la diferencia. ¿La diferencia sigue estando relacionada con que las entradas de balance presentadas no sean correctas? Si es así, abra un incidente de soporte técnico para obtener más ayuda.

Más información

Para obtener más información, consulte Los procedimientos de cierre de fin de año para la contabilidad analítica en Microsoft Dynamics GP.