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Error al enviar correos cifrados S/MIME desde OWA: Outlook Web Access no pudo encontrar el identificador digital para el cifrado

Número de KB original: 2497165

Síntomas

Los usuarios no pueden enviar correo electrónico seguro o multipropósito (S/MIME) firmados o cifrados en Microsoft Office Outlook Web Access (OWA). Un cuadro de diálogo muestra el siguiente mensaje de error.

Outlook Web Access could not find your digital ID for encryption. If your digital ID is on a smart card, insert the card in the card reader, and then try to send the message again. You may also try sending the message unencrypted.

If your digital ID is not trusted by the Exchange server, you cannot use it to encrypt messages. For more information, contact technical support for your organization.

Causa

Los campos Asunto o Nombre alternativo del firmante del certificado de usuario deben contener una dirección SMTP que aparece en la cuenta usada para iniciar sesión en OWA.

En una instalación predeterminada de Exchange Server 2007 o Exchange Server 2010, si el certificado de usuario se emite a una dirección SMTP que no aparece en la cuenta de Active Directory, OWA no usará el certificado.

Nota:

Para usar las características de S/MIME en OWA, debe ejecutar Exchange Server 2007 Service Pack 1 (SP1) o versiones posteriores de Exchange.

Resolución

Para resolver este problema, debe obtener un identificador digital.

Si tiene un identificador digital que se puede usar para los correos electrónicos S/MIME, pero la dirección SMTP no coincide con la cuenta de buzón de Exchange Server, el administrador de Exchange puede habilitar el siguiente valor del Registro para permitir la selección del certificado de usuario. Esto permite a los usuarios seleccionar el certificado que se usará para firmar mensajes salientes. El cliente de OWA omitirá la comprobación de nombres SMTP.

Siga estos pasos para habilitar esta característica de OWA.

Advertencia

Es posible que se produzcan problemas graves si modifica el registro incorrectamente mediante el Editor del Registro o mediante otro método. Estos problemas pueden requerir la reinstalación del sistema operativo. Microsoft no puede garantizar que estos problemas se puedan resolver. La modificación del Registro se hará bajo su propia responsabilidad.

  1. Haga clic en Iniciar>Ejecutar, escriba regedit y presione Entrar.
  2. Expanda HKLM\System\CurrentControlSet\services\MSExchangeOWA\SMIME.
  3. Haga clic con el botón derecho en la tecla SMIME y haga clic en Nuevo>DWORD (32 bits).
  4. Asigne un nombre al nuevo valor DWORD AllowUserChoiceOfSigningCertificate.
  5. Haga doble clic en AllowUserChoiceOfSigningCertificate y establezca el valor en 1.
  6. Cierre el editor del Registro.
  7. Haga clic en Iniciar>Ejecutar, escriba cmd y presione Enter.
  8. Desde el símbolo del sistema, ejecute IISReset /noforce. O bien, puede reiniciar el servicio de administración de IIS en Services.msc.

Una vez que haya configurado la clave del Registro, el usuario verá una nueva opción en la sección Seguridad de correo electrónico en las opciones de OWA. Habrá una nueva sección para permitir que el usuario elija manualmente el certificado de firma.

  1. Inicie sesión en OWA y haga clic en Opciones.
  2. Haga clic en Seguridad de correo electrónico.
  3. En la sección Seleccionar certificado para firma de correo , cambie el botón de radio para seleccionar manualmente el certificado.
  4. Haga clic en Elegir certificado de firma.... Se abrirá una nueva ventana en la que se mostrarán los certificados de usuario disponibles.
  5. Seleccione el certificado adecuado y haga clic en Aceptar.

Cuando el usuario envía correo firmado, se firmará con el certificado que fue seleccionado. El proceso de selección no verifica la dirección SMTP incluida en las extensiones de nombre del asunto o nombre alternativo del asunto del certificado frente a las direcciones SMTP de la cuenta de usuario en Active Directory.

Información adicional

Con un cliente de Outlook, puede desactivar la coincidencia de correo electrónico para los certificados a través de una clave del Registro del lado cliente. Los pasos completos para el cliente de Outlook se documentan en Cómo desactivar la coincidencia de correo electrónico para los certificados en Outlook.

Para obtener más información sobre cómo administrar la configuración de S/MIME para OWA, consulte los siguientes artículos de TechNet online.

Cómo administrar S/MIME para Outlook Web Access (Exchange Server 2007)

Administrar S/MIME para Outlook Web App (Exchange Server 2010)